LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-01-2017, 02:11 AM   #16
ferrari
Senior Member
 
Registered: Sep 2003
Location: Auckland, NZ
Distribution: openSUSE Leap
Posts: 4,786

Rep: Reputation: 900Reputation: 900Reputation: 900Reputation: 900Reputation: 900Reputation: 900Reputation: 900Reputation: 900

The ens0 interface is down. After you changed the config file naming, did you restart wicked (or reboot)?

Try bringing up the interface with
Code:
ifup ens0
then once that's done check that there is a valid IP address assigned again.
 
Old 11-01-2017, 02:24 AM   #17
nordsense
LQ Newbie
 
Registered: Aug 2017
Location: United States of America
Distribution: CentOS
Posts: 14

Original Poster
Rep: Reputation: Disabled
Yes I did reboot. I do not see ens0 anywhere.
Attached Thumbnails
Click image for larger version

Name:	1.png
Views:	75
Size:	3.6 KB
ID:	26204   Click image for larger version

Name:	2.png
Views:	88
Size:	3.1 KB
ID:	26205   Click image for larger version

Name:	wat2.png
Views:	85
Size:	8.0 KB
ID:	26206  
 
Old 11-01-2017, 02:25 AM   #18
ferrari
Senior Member
 
Registered: Sep 2003
Location: Auckland, NZ
Distribution: openSUSE Leap
Posts: 4,786

Rep: Reputation: 900Reputation: 900Reputation: 900Reputation: 900Reputation: 900Reputation: 900Reputation: 900Reputation: 900
I meant ens3, as your output shows.
 
Old 11-01-2017, 02:28 AM   #19
nordsense
LQ Newbie
 
Registered: Aug 2017
Location: United States of America
Distribution: CentOS
Posts: 14

Original Poster
Rep: Reputation: Disabled
I changed ifcfg-eth0 to ifcfg-ens3 rebooted and ran ifup ens3 and I got this
Attached Thumbnails
Click image for larger version

Name:	1.png
Views:	107
Size:	3.2 KB
ID:	26207  
 
Old 11-01-2017, 02:30 AM   #20
ferrari
Senior Member
 
Registered: Sep 2003
Location: Auckland, NZ
Distribution: openSUSE Leap
Posts: 4,786

Rep: Reputation: 900Reputation: 900Reputation: 900Reputation: 900Reputation: 900Reputation: 900Reputation: 900Reputation: 900
Your image of the ifcfg-* config files still show ifcfg-eth0, rather ifcfg-ens3. I think you should review the links I gave in my initial reply. You do need some basic Linux and networking knowledge, otherwise things are gong to be a struggle.
 
Old 11-01-2017, 02:31 AM   #21
nordsense
LQ Newbie
 
Registered: Aug 2017
Location: United States of America
Distribution: CentOS
Posts: 14

Original Poster
Rep: Reputation: Disabled
I changed it back to ifcfg-ens3. You confused me when you said:

he ens0 interface is down. After you changed the config file naming, did you restart wicked (or reboot)?

Try bringing up the interface with

ifup ens0
then once that's done check that there is a valid IP address assigned again.
 
Old 11-01-2017, 02:33 AM   #22
nordsense
LQ Newbie
 
Registered: Aug 2017
Location: United States of America
Distribution: CentOS
Posts: 14

Original Poster
Rep: Reputation: Disabled
sI changed ifcfg-eth0 to ifcfg-ens3 rebooted and ran ifup ens3 and I got this
Attached Thumbnails
Click image for larger version

Name:	1.png
Views:	66
Size:	3.2 KB
ID:	26208  
 
Old 11-01-2017, 02:34 AM   #23
ferrari
Senior Member
 
Registered: Sep 2003
Location: Auckland, NZ
Distribution: openSUSE Leap
Posts: 4,786

Rep: Reputation: 900Reputation: 900Reputation: 900Reputation: 900Reputation: 900Reputation: 900Reputation: 900Reputation: 900
Ok, make sure that the configuration file matches the actual interface name, then try to bring it up manually, and check the status again.
 
Old 11-01-2017, 02:35 AM   #24
ferrari
Senior Member
 
Registered: Sep 2003
Location: Auckland, NZ
Distribution: openSUSE Leap
Posts: 4,786

Rep: Reputation: 900Reputation: 900Reputation: 900Reputation: 900Reputation: 900Reputation: 900Reputation: 900Reputation: 900
Report back with output from
Code:
ls -l /etc/sysconfig/network-scripts/ifcfg-*
 
Old 11-01-2017, 02:39 AM   #25
nordsense
LQ Newbie
 
Registered: Aug 2017
Location: United States of America
Distribution: CentOS
Posts: 14

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by ferrari View Post
Report back with output from
Code:
ls -l /etc/sysconfig/network-scripts/ifcfg-*
I do not know what you mean by "bring it up manually". Here is the screen shot of that output
Attached Thumbnails
Click image for larger version

Name:	1.png
Views:	103
Size:	5.2 KB
ID:	26209  
 
Old 11-01-2017, 02:42 AM   #26
ferrari
Senior Member
 
Registered: Sep 2003
Location: Auckland, NZ
Distribution: openSUSE Leap
Posts: 4,786

Rep: Reputation: 900Reputation: 900Reputation: 900Reputation: 900Reputation: 900Reputation: 900Reputation: 900Reputation: 900
I mean using the ifup command. I note that you still have ifcfg-eth0:0 present. If it's needed at all, it should be ifcfg-ens3:0. That will cause issues otherwise.
 
Old 11-01-2017, 02:59 AM   #27
nordsense
LQ Newbie
 
Registered: Aug 2017
Location: United States of America
Distribution: CentOS
Posts: 14

Original Poster
Rep: Reputation: Disabled
Hello


ifup ens3 returns the same [/etc/sysconfig/network-scripts/ifup-eth] Device eth0 does not seem to be present, delaying initialization. I am wondering why this ifup ens3 command keeps talking about eth0...I have triple checked and the configuration file is indeed named ens3. I have also changed eth0:0 to ifcfg-ens3:0, brought it up manually and rebooted. Still not able to connect.
Attached Thumbnails
Click image for larger version

Name:	1.png
Views:	75
Size:	7.4 KB
ID:	26210  
 
Old 11-01-2017, 03:06 AM   #28
ferrari
Senior Member
 
Registered: Sep 2003
Location: Auckland, NZ
Distribution: openSUSE Leap
Posts: 4,786

Rep: Reputation: 900Reputation: 900Reputation: 900Reputation: 900Reputation: 900Reputation: 900Reputation: 900Reputation: 900
You need to share your actual configuration in ifcfg-ens3 and ifcfg-ens3:0. Did you change the 'DEVICE=' and 'NAME=' entries to match the actual device node name? I suspect not.
 
Old 11-03-2017, 12:54 AM   #29
nordsense
LQ Newbie
 
Registered: Aug 2017
Location: United States of America
Distribution: CentOS
Posts: 14

Original Poster
Rep: Reputation: Disabled
Dear ferrari


I want to thank you for taking time to look over this problem for the last couple of days. I changed the DEVICE= name to match the node name; also ONBOOT=no so I switched this to ONBOOT=yes and now I am able to SSH.


Thank you
 
Old 11-03-2017, 01:55 AM   #30
ferrari
Senior Member
 
Registered: Sep 2003
Location: Auckland, NZ
Distribution: openSUSE Leap
Posts: 4,786

Rep: Reputation: 900Reputation: 900Reputation: 900Reputation: 900Reputation: 900Reputation: 900Reputation: 900Reputation: 900
Glad to have been of help. It would probably have been a good idea to have had you share the configuration from the start. Anyway, good to know its working as expected now.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Network is running even if network service is stopped achtani_jeetu Linux - Newbie 3 03-09-2010 11:32 PM
Network Manager service vs Network service jeromeNP7 Fedora 2 07-18-2009 03:28 PM
what is the difference between service network reload and service network restart ? markraem Linux - Networking 3 11-21-2007 03:08 PM
In FC6 network interface doesn't come up if 'service network restart' command is run rajat Linux - Networking 2 05-02-2007 11:53 PM
LXer: Telsasoft, a Telecommunications Service Assurance Software Company Based in Minneapolis, Minnesota Received Order for a Set of GSM CDR (Call Detail Record) Reports from a Regional GSM Network Service LXer Syndicated Linux News 0 01-03-2006 09:46 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 07:57 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration