-   Linux - Newbie (
-   -   network manager system tray applet (

heltgroen 06-28-2009 09:25 AM

network manager system tray applet

I accidently closed my network manager applet in the system tray. Now im having trouble adding it again. The network manager program is running in the background, i just have no way of accessing the features of the applet (for instance choosing which networks i want to log onto).
Ive tried adding it by right-clicking the system tray and use the add applet but it is not to be found there.
Ive tried removing both the network manager package and the network manager applet package (both partial and complete removal) and reinstalling them without luck.
How do i add the network manager applet to my system tray without reinstalling linux?


repo 06-28-2009 09:33 AM

Did you try to restart X ?

colucix 06-28-2009 10:25 AM

What about launching nm-applet from the command line?

LeeDaugherty 06-28-2009 06:30 PM

Go to Preferences->Startup Applications (or the similar (Sessions))

Look for "Network Manager" under the "Startup Programs" tab
Make sure it's checked (to automatically start on boot-up)
Click edit-the default command line to run it is "nm-applet --sm-disable"

This can all be added if it has somehow disappeared.

You can also try hitting alt-F2 to bring up the "Run Dialog" and enter "nm-applet --sm-disable" and see if that works...if not we got another issue somewhere...

heltgroen 06-29-2009 06:13 AM

thanks for responding

I did try to run nm-applet from the command line. First of all its still running in the background so before i was able to do that i needed to kill the process. I did that and ran nm-applet. It does what networkmanager usually does - tries to log onto the networks ive tried to log onto before. However i still dont get the small icon in the systray so im not able to do access any other function (ie choose other networks).
I did also check that it is in the startup script and it is. The "nm-applet -- sm-disable" is in the startup script and is checked.

I dont know what restart x is so i havent done it. What is it?


repo 06-29-2009 06:27 AM


I dont know what restart x is so i havent done it. What is it?
log out and log back in

All times are GMT -5. The time now is 06:45 PM.