-   Linux - Newbie (
-   -   Network manager applet does not start in xmonad (

johnnyxxxcakes 02-18-2009 04:37 PM

Network manager applet does not start in xmonad
I've installed and changed my session at the login screen to the xmonad window manager. When everything boots up all fine, I don't have internet. I think this is because the network manager applet which is in GNOME doesn't startup with xmonad. How do I get this working so I get my wireless internet to work?

I've already tried typing "sudo /etc/init.d/networking restart", "network-manager-gnome", and "network-manager-applet" from within the terminal, but nothing seems to work.

indienick 02-18-2009 04:42 PM

Have you tried running "nm-applet" (without "sudo" or "gk-su")?

I don't know too much about Xmonad, but from the few screenshots I've seen, it doesn't seem to have a system tray that NetworkManager would usually reside in.

Unless Xmonad has a system tray, of some sort, built-in, I would suggest using "stalonetray".

johnnyxxxcakes 02-19-2009 10:08 AM

Thank you! That worked perfectly.

indienick 02-19-2009 10:09 AM

Hey - no problem! :)

All times are GMT -5. The time now is 09:35 PM.