LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-23-2017, 08:51 PM   #1
Buddidge
LQ Newbie
 
Registered: Apr 2017
Location: UK
Distribution: Custom
Posts: 22

Rep: Reputation: Disabled
Question Network issue on new build


Hi All,

I cant seem to work out why I'm unable to pass traffic on the network link.

Running on hyper-v (win10), gen1 vm, tried legacy and standard nic with same results, I have a scrollout F1, debian 8 and 2 server 2012 vm's (mix of gen1/2) running on same vswitch without issues.

/etc/sysconfig/ifconfig.
ONBOOT=yes
IFACE=sit0
SERVICE=ipv4-static
IP=10.0.0.30
GATEWAY=10.0.0.254
PREFIX=24
BROADCAST=10.0.0.254

ip link
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen1
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: sit0@NONE: <NOARP,UP,LOWER_UP> mtu 1480 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1
link/sit 0.0.0.0 brd 0.0.0.0

ip addr
2: sit0@NONE: <NOARP,UP,LOWER_UP> mtu 1480 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1
link/sit 0.0.0.0 brd 0.0.0.0
inet 10.0.0.30/24 brd 10.0.0.255 scope global sit0
valid_lft forever preferred_lft forever
inet6 ::10.0.0.30/96 scope global
valid_lft forever preferred_lft forever
inet6 ::172.0.0.1/96 scope host
valid_lft forever preferred_lft forever

ip route
default via 10.0.0.254 dev sit0
10.0.0.0/24 dev sit0 proto kernel scope link src 10.0.0.30

I'm unable to send or receive any packet data.

Not sure where else to look? Config seems ok to me and I'm assuming the kernel complied with the correct modules to show the nic in the fist place?

I'm a bit of a noob to linux so any help and suggestions are appreciated!

Rob
 
Old 04-24-2017, 08:21 AM   #2
camorri
LQ Veteran
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1, 14.2, current, slackware-arm-currnet
Posts: 5,420

Rep: Reputation: 617Reputation: 617Reputation: 617Reputation: 617Reputation: 617Reputation: 617
It looks like you may have a DNS configuration problem.

Some questions. Have you got any other device that works through the same network?

What happens if you try and ping something like www.google.co.uk ? That should work. This causes a DNS lookup. If that fails, then try:

Quote:
ping 172.217.0.163
PING 172.217.0.163 (172.217.0.163) 56(84) bytes of data.
64 bytes from 172.217.0.163: icmp_seq=1 ttl=58 time=13.5 ms
This is the IP address of google UK. If that works, then you do have a DNS problem.

DNS is usually configured either in your router, or in /etc/resolv.conf. You may need to contact your ISP to find out what IP addresses to configure to use their DNS servers. Of course you could just use free ones, like 8.8.8.8.

Hope this helps.
 
Old 04-24-2017, 08:27 AM   #3
Buddidge
LQ Newbie
 
Registered: Apr 2017
Location: UK
Distribution: Custom
Posts: 22

Original Poster
Rep: Reputation: Disabled
I'm unable to ping internal or external ip's or names bar the loopback address and itself ie 127.0.0.1 10.0.0.30. ping just shows x packets transmitted 100% packet loss.
 
Old 04-24-2017, 08:44 AM   #4
camorri
LQ Veteran
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1, 14.2, current, slackware-arm-currnet
Posts: 5,420

Rep: Reputation: 617Reputation: 617Reputation: 617Reputation: 617Reputation: 617Reputation: 617
If you can not ping 127.0.0.1 or 10.0.0.30 ( your own system ) I would think you have a problem in the TCP/IP stack.

What distro are you using? ( version and release ) Did you do a full install? Has it ever worked?
 
Old 04-24-2017, 08:53 AM   #5
Buddidge
LQ Newbie
 
Registered: Apr 2017
Location: UK
Distribution: Custom
Posts: 22

Original Poster
Rep: Reputation: Disabled
Sorry they are the only addresses that I can ping. both reply as you would expect.

I've compiled the distro myself, always had *nix systems on the networks I've looked after over the years and always needed to google xyz to do what ever was needed so decided it was about time to learn it properly!

This is the first boot of this install so no hasn't worked yet.

From what I can see the device seems to picked up ok by udev (sit0), the config files don't look wrong and based on the loop back test working I'm assuming that the tcp stack is also ok.

Although on a side note I've just noticed that I have put .254 as my broadcast address on my first post here, it is in fact .255 in the config, no remote shell so had to type them all out manually
 
Old 04-24-2017, 09:11 AM   #6
camorri
LQ Veteran
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1, 14.2, current, slackware-arm-currnet
Posts: 5,420

Rep: Reputation: 617Reputation: 617Reputation: 617Reputation: 617Reputation: 617Reputation: 617
It might help if you posted some details about the network hardware. Is this a wired or wireless connection? If you knoe the router works with other installs, then for now I would think that is not part of the problem.

The output for lspci -vv for the adapter you are using will show the driver for sit0.

You said you have compiled the distro. Is this Linux From Scratch? There may be doc there that may help.
 
Old 04-24-2017, 09:39 AM   #7
Buddidge
LQ Newbie
 
Registered: Apr 2017
Location: UK
Distribution: Custom
Posts: 22

Original Poster
Rep: Reputation: Disabled
Apologies I thought I stated on the first post that this is running on a hyper-v gen 1 vm.

Tried with both standard and legacy nic's.

Yes was an lfs 8.0 build. Nothing I could see in their hints files / docs or else where online for a similar issue which is why I decided to post here.

lspci -vv

00:0a.0 Ethernet controller: Digital Equipment Corporation DEChip 21140 [FasterNet (rev 20)
Subsystem: Device 0a00:2114
Control: I/O+ Mem+ Busmaster+ SpecCycle- MemWINV+ VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx-
Status: Cap- 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <Tabort- <MAbourt- >SERR- <PERR- INTx-
Latency: 64 (5000ns min, 10000ns max), Cache Line Size: 32 bytes
Interrupt: ping A routed to IRQ 11
Region 0: I/O ports at ec00 [size=128]
Region 1: Memory at febff000 (32-bit, non-prefetchable) [size=4K]
Expansion ROM at febe0000 [disabled] [size=64K]
 
Old 04-24-2017, 09:56 AM   #8
camorri
LQ Veteran
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1, 14.2, current, slackware-arm-currnet
Posts: 5,420

Rep: Reputation: 617Reputation: 617Reputation: 617Reputation: 617Reputation: 617Reputation: 617
No need to alologise. I didn't read your first post carefully enough; my error.

I don't know anything about Hyper-V, other than it is allows for running virtual machines on Win. Sorry. LFS I have very little experience with it. You have posted a lot of information, so I'm hoping someone with more experience in this area will chime in.
 
Old 04-24-2017, 10:22 AM   #9
Buddidge
LQ Newbie
 
Registered: Apr 2017
Location: UK
Distribution: Custom
Posts: 22

Original Poster
Rep: Reputation: Disabled
lol no problem.

Thanks for the help either way Cliff.
 
Old 04-24-2017, 11:27 AM   #10
AwesomeMachine
LQ Guru
 
Registered: Jan 2005
Location: USA and Italy
Distribution: Debian testing/sid; OpenSuSE; Fedora; Mint
Posts: 5,513

Rep: Reputation: 1004Reputation: 1004Reputation: 1004Reputation: 1004Reputation: 1004Reputation: 1004Reputation: 1004Reputation: 1004
You could try turning off Windows firewall service. Also, in the guest, run
Code:
$ iptables -L
and check if anything is allowed. I'd go back to legacy NIC. If there are different types of networking available, try NAT and bridge for the guest.

You may have to enable netbios protocol in the guest, since Microsoft seems to think it's the greatest thing ever. And in the connection settings (control panel) Windows might list the guest connection. Try tuning it up from there.

1480 is a bad MTU to use. It should be 1484, 1492 or 1500, because packet headers are 8 or 16 bytes. That shouldn't shut down the whole connection, but it should still be changed.
 
Old 04-24-2017, 01:56 PM   #11
lazydog
Senior Member
 
Registered: Dec 2003
Location: The Key Stone State
Distribution: CentOS Sabayon and now Gentoo
Posts: 1,239
Blog Entries: 3

Rep: Reputation: 194Reputation: 194
Since you have stated that you have other linux version running have you tried to do a stare and compare?
 
Old 04-24-2017, 01:56 PM   #12
Buddidge
LQ Newbie
 
Registered: Apr 2017
Location: UK
Distribution: Custom
Posts: 22

Original Poster
Rep: Reputation: Disabled
The windows firewall service will not interact with guest vm's in any way.

The vswitch it is connected to also has other vm's on there working with out issue.

All guests are set to bridge with the physical network with a combination of standard and legacy nics, windows creates a virtual nic based on a per vswitch basis so there is no individual nics for the vm's visible on the host side.

I have changed the mtu to 1500 but still the same issue.

I haven't actually compiled iptables on this build yet as it was purely to test if I could build a distro in the first place.

As far as I understand there wouldn't be a need for iptables to get tcp working?
 
Old 04-24-2017, 01:58 PM   #13
Buddidge
LQ Newbie
 
Registered: Apr 2017
Location: UK
Distribution: Custom
Posts: 22

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by lazydog View Post
have you tried to do a stare and compare?
Possibly a stupid question but what is a stare and compare?
 
Old 04-24-2017, 02:01 PM   #14
lazydog
Senior Member
 
Registered: Dec 2003
Location: The Key Stone State
Distribution: CentOS Sabayon and now Gentoo
Posts: 1,239
Blog Entries: 3

Rep: Reputation: 194Reputation: 194
Only stupid question is the one not asked.

Look at both configurations and see what might be different besides the obvious ip addreses
 
Old 04-24-2017, 02:02 PM   #15
linux4evr5581
Member
 
Registered: Sep 2016
Location: USA
Posts: 275

Rep: Reputation: Disabled
I think he means compare the system that works, with the system that doesn't.. Network Troubleshooting Steps: 1) ping localhost (127.0.0.1) to make sure your OS's TCP/IP stacks is working 2) ping the IP address of the local adapter that's connected to the network to make sure that's functioning 3) ping your default gateway to confirm you have connectivity with your LAN 4) finally ping a device that's outside your LAN e.g. Google's DNS server 8.8.8.8... Also make sure you don't have a link-local address as those cannot connect to the internet, or an IP-conflict which is when two devices on the network have the same IP..

Last edited by linux4evr5581; 04-24-2017 at 02:19 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Build Issue JaguarAnon AryaLinux 7 05-16-2016 08:14 PM
issue during RPM build your_shadow03 Linux - Server 2 05-17-2013 03:29 PM
Android - Build Issue linux_newbie79 Linux - Software 1 01-06-2010 06:18 AM
Glibc-2.3.6 build issue ---- wordexp.o not build Dhana_pal Linux - Software 0 12-27-2006 01:56 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 01:53 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration