LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-12-2020, 02:17 AM   #1
nigelc
Member
 
Registered: Oct 2004
Location: Sydney, Australia
Distribution: Mageia 7
Posts: 384
Blog Entries: 4

Rep: Reputation: 80
Network has an error whilst starting


HI,
My system has an just while starting the network.

Code:
[root@localhost ~]# journalctl -ab --no-pager -u network
-- Logs begin at Sun 2019-08-25 04:46:34 AEST, end at Sun 2020-07-12 17:08:11 AEST. --
Jul 12 16:48:11 localhost systemd[1]: Starting LSB: Bring up/down networking...
Jul 12 16:48:11 localhost network[1178]: Bringing up loopback interface:  [  OK  ]
Jul 12 16:48:11 localhost ifplugd(eno1)[1420]: ifplugd 0.28 initializing.
Jul 12 16:48:11 localhost ifplugd(eno1)[1420]: Using interface eno1/74:D4:35:83:A9:7B with driver <e1000e> (version: 3.2.6-k)
Jul 12 16:48:11 localhost ifplugd(eno1)[1420]: Using detection mode: SIOCETHTOOL
Jul 12 16:48:11 localhost ifplugd(eno1)[1420]: Initialization complete, link beat not detected.
Jul 12 16:48:11 localhost network[1178]: Bringing up interface eno1:  [  OK  ]
Jul 12 16:48:12 localhost network[1178]: Bringing up interface enp0s29u1u2:  ERROR     : [/etc/sysconfig/network-scripts/ifup-eth] Device enp0s29u1u2 does not seem to be present, delaying initialization.
Jul 12 16:48:12 localhost network[1178]: [FAILED]
Jul 12 16:48:12 localhost systemd[1]: network.service: Control process exited, code=exited, status=1/FAILURE
Jul 12 16:48:12 localhost systemd[1]: network.service: Failed with result 'exit-code'.
Jul 12 16:48:12 localhost systemd[1]: Failed to start LSB: Bring up/down networking.
Jul 12 16:48:16 localhost ifplugd(eno1)[1420]: Link beat detected.
Jul 12 16:48:17 localhost ifplugd(eno1)[1420]: Executing '/etc/ifplugd/ifplugd.action eno1 up'.
Jul 12 16:48:17 localhost dhclient[4075]: DHCPREQUEST for 192.168.20.3 on eno1 to 255.255.255.255 port 67
Jul 12 16:48:17 localhost dhclient[4075]: DHCPACK of 192.168.20.3 from 192.168.20.1
Jul 12 16:48:17 localhost dhclient[4075]: bound to 192.168.20.3 -- renewal in 34219 seconds.
Jul 12 16:48:17 localhost ifplugd(eno1)[1420]: client: Determining IP information for eno1... done.
Jul 12 16:48:17 localhost ifplugd(eno1)[1420]: Program executed successfully.
Jul 12 17:07:25 localhost systemd[1]: network.service: Found left-over process 1420 (ifplugd) in control group while starting unit. Ignoring.
Jul 12 17:07:25 localhost systemd[1]: This usually indicates unclean termination of a previous run, or service implementation deficiencies.
Jul 12 17:07:25 localhost systemd[1]: network.service: Found left-over process 4075 (dhclient) in control group while starting unit. Ignoring.
Jul 12 17:07:25 localhost systemd[1]: This usually indicates unclean termination of a previous run, or service implementation deficiencies.
Jul 12 17:07:25 localhost systemd[1]: Starting LSB: Bring up/down networking...
Jul 12 17:07:25 localhost network[20332]: Bringing up loopback interface:  [  OK  ]
Jul 12 17:07:25 localhost network[20332]: Bringing up interface eno1:  Sorry, there is already an instance of ifplugd for eno1 running.
Jul 12 17:07:25 localhost network[20332]: [FAILED]
Jul 12 17:07:25 localhost network[20332]: Bringing up interface enp0s29u1u2:  ERROR     : [/etc/sysconfig/network-scripts/ifup-eth] Device enp0s29u1u2 does not seem to be present, delaying initialization.
Jul 12 17:07:25 localhost network[20332]: [FAILED]
Jul 12 17:07:25 localhost network[20332]: RTNETLINK answers: File exists
Jul 12 17:07:25 localhost network[20332]: RTNETLINK answers: File exists
Jul 12 17:07:25 localhost network[20332]: RTNETLINK answers: File exists
Jul 12 17:07:25 localhost network[20332]: RTNETLINK answers: File exists
Jul 12 17:07:25 localhost network[20332]: RTNETLINK answers: File exists
Jul 12 17:07:25 localhost network[20332]: RTNETLINK answers: File exists
Jul 12 17:07:25 localhost network[20332]: RTNETLINK answers: File exists
Jul 12 17:07:25 localhost network[20332]: RTNETLINK answers: File exists
Jul 12 17:07:25 localhost network[20332]: RTNETLINK answers: File exists
Jul 12 17:07:25 localhost systemd[1]: network.service: Control process exited, code=exited, status=1/FAILURE
Jul 12 17:07:25 localhost systemd[1]: network.service: Failed with result 'exit-code'.
Jul 12 17:07:25 localhost systemd[1]: Failed to start LSB: Bring up/down networking.
[root@localhost ~]#
What is device interface enp0s29u1u2 ?

chears Nigel
 
Old 07-12-2020, 07:41 PM   #2
frankbell
LQ Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Ubuntu MATE, Mageia, and whatever VMs I happen to be playing with
Posts: 16,395
Blog Entries: 27

Rep: Reputation: 4921Reputation: 4921Reputation: 4921Reputation: 4921Reputation: 4921Reputation: 4921Reputation: 4921Reputation: 4921Reputation: 4921Reputation: 4921Reputation: 4921
It's the ethernet card under the laughingly misnamed "predictable device names" protocol.

This link might shed some light on it.
 
Old 07-16-2020, 06:08 PM   #3
nigelc
Member
 
Registered: Oct 2004
Location: Sydney, Australia
Distribution: Mageia 7
Posts: 384

Original Poster
Blog Entries: 4

Rep: Reputation: 80
This gets rid of the error.:

Code:

rm -f /etc/sysconfig/network-scripts/ifcfg-enp0s29u1u2
 
Old 07-16-2020, 06:35 PM   #4
rnturn
Senior Member
 
Registered: Jan 2003
Location: Illinois (SW Chicago 'burbs)
Distribution: Currently: openSUSE, Raspbian, Slackware. Formerly: CentOS, MacOS, Red Hat. Other: Solaris, Tru64
Posts: 1,975

Rep: Reputation: 324Reputation: 324Reputation: 324Reputation: 324
Quote:
Originally Posted by nigelc View Post
This gets rid of the error.:

Code:

rm -f /etc/sysconfig/network-scripts/ifcfg-enp0s29u1u2
Hmm... I think I would have hidden the file instead of deleting it.
Code:
# cd /etc/sysconfig/network-scripts
# mv ifcfg-enp0s29u1u2 .ifcfg-enp0s29u1u2
 
Old 07-20-2020, 08:40 PM   #5
nigelc
Member
 
Registered: Oct 2004
Location: Sydney, Australia
Distribution: Mageia 7
Posts: 384

Original Poster
Blog Entries: 4

Rep: Reputation: 80
@ rnturn
I suppose I should have hidden it.
Thanks for the advice.

Nigel.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Starting File System .. Starting File System .. Starting File System .. Starting File rmknox Linux - Newbie 3 08-15-2010 11:30 PM
error whilst installing fedora core 6 JohnntB Fedora - Installation 2 06-12-2007 10:30 AM
Error whilst copying from Dvd Drive: final60 Linux - Hardware 3 04-23-2006 01:44 AM
locked myself out whilst configuring network... DanBallance SUSE / openSUSE 2 11-10-2005 06:25 AM
Error whilst intalling 'libgtk2.0-dev', 'Broken Pipe'?! Eerath MEPIS 4 08-15-2005 09:47 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 04:07 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration