LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-12-2013, 10:18 AM   #1
cortexa
LQ Newbie
 
Registered: Feb 2013
Posts: 6

Rep: Reputation: Disabled
Network configuration on RHEL 6.3


Hi, I'm having trouble configuring network access and I hope you can help.

I recently reinstalled Red Hat Enterprise 6.3 and set up the NetworkManager to configure my dhcp connection to a wired network.
I also altered the ifcfg-eth0 file to include the lines ONBOOT="yes" and BOOTPROTO="dhcp".

I'm not sure if this was the right thing to do, but in any case it worked, and I had full connectivity. Today, I had to reboot the computer and when I did I could no longer connect to the network; NetworkManager doesn't seem to be able to acquire an IP address.

I've tried multiple options to fix this problem, using the NetworkManager and network services. I've tried every possible combination of the ifcfg-eth0 and /etc/sysconfig/network files, including or removing HWADDR, GATEWAY and NM_CONTROLLED parameters.

/etc/sysconfig/network-scripts/ifcfg-eth0:
Quote:
DEVICE="eth0"
NM_CONTROLLED="no"
ONBOOT="yes"
BOOTPROTO="dhcp"
#HWADDR=18:03:73:3F:FD:AB
/etc/sysconfig/network:
Quote:
NETWORKING=yes
HOSTNAME=ECAPPSY191.ucc.ie
#GATEWAY=143.239.1.199
Basically, when I try to connect via NetworkManager I just get a message saying either 'The network was disconnected' or 'Device not managed', depending on the options I included. When I try to connect via the network service (i.e. 'service network restart') the startup hangs on the line 'Determining IP information for eth0...', regardless of what options I have used.

I don't think there are any hardware problems as I managed to connect before (apparently by pure fluke) and I know the network port is active.

I'd really appreciate any advice you can offer here; I'm sure I've just done something stupid or missed an obvious clue, but I'm not sure what to do next.

Thanks!

Output of ifconfig:

Quote:
eth0 Link encap:Ethernet HWaddr 18:03:73:3F:FD:AB
inet6 addr: 2002:8fef:aabb:4:1a03:73ff:fe3f:fdab/64 Scope:Global
inet6 addr: fec0::4:1a03:73ff:fe3f:fdab/64 Scope:Site
inet6 addr: fe80::1a03:73ff:fe3f:fdab/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:1792490 errors:1 dropped:0 overruns:0 frame:1
TX packets:834 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:189774068 (180.9 MiB) TX bytes:241652 (235.9 KiB)
Interrupt:20 Memory:eb400000-eb420000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:30 errors:0 dropped:0 overruns:0 frame:0
TX packets:30 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
 
Old 02-12-2013, 11:33 AM   #2
jpollard
Senior Member
 
Registered: Dec 2012
Location: Washington DC area
Distribution: Fedora, CentOS, Slackware
Posts: 4,711

Rep: Reputation: 1279Reputation: 1279Reputation: 1279Reputation: 1279Reputation: 1279Reputation: 1279Reputation: 1279Reputation: 1279Reputation: 1279
If you are using network manager then it must be "NM_CONTROLLED=yes" or NetworkManager will not bring up the interface.
 
Old 02-12-2013, 11:47 AM   #3
cortexa
LQ Newbie
 
Registered: Feb 2013
Posts: 6

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by jpollard View Post
If you are using network manager then it must be "NM_CONTROLLED=yes" or NetworkManager will not bring up the interface.
Yes, thanks, I did try that - I switched NM_CONTROLLED to "no" when I was trying to connect via the network service. I had it switched to "yes" when I was trying to get NetworkManager to work.
 
Old 02-12-2013, 12:12 PM   #4
jpollard
Senior Member
 
Registered: Dec 2012
Location: Washington DC area
Distribution: Fedora, CentOS, Slackware
Posts: 4,711

Rep: Reputation: 1279Reputation: 1279Reputation: 1279Reputation: 1279Reputation: 1279Reputation: 1279Reputation: 1279Reputation: 1279Reputation: 1279
Ok. It may be something else then. I gave up NetworkManager since F16 because it doesn't seem to handle static IP numbers properly.

My configuration (ifcfg-eth1) was derived from a F14 one that worked, plus tweaks from F16.:
Code:
# Networking Interface
DEVICE=p6p1
HWADDR=xx:xx:xx:xx...
ONBOOT=yes
BOOTPROTO=dhcp
TYPE=Ethernet
NM_CONTROLLED=no
USERCTL=no
IPV6INIT=no
NAME="System eth1"
UUID=xxxxxxxxxxxxxxxxxxxxxxxxx
DEFROUTE=yes
PEERDNS=yes
PEERROUTES=yes
IPV4_FAILURE_FATAL=yes
Note the device name - p6p1 - Ethernet names changed to a port/unit type of numbering. You might check that. Also the UUID is to reinforce the correct identity of the interface (one of the tweaks from F16 I believe).
 
Old 02-12-2013, 12:49 PM   #5
lleb
Senior Member
 
Registered: Dec 2005
Location: Florida
Distribution: CentOS/Fedora
Posts: 2,630

Rep: Reputation: 495Reputation: 495Reputation: 495Reputation: 495Reputation: 495
on my centOS 6.3 box i have the following configurations that might help. FYI i DO NOT use the GUI at all as my cent box is my server. it has no keyboard, mouse, nor monitor connected to it, just a power cable and a network cable, nothing more.

Code:
[root@centos ~]# ifconfig
eth0      Link encap:Ethernet  HWaddr xx:xx:xx:xx:xx:xx  
          inet addr:192.168.2.125  Bcast:192.168.2.255  Mask:255.255.255.0
          inet6 addr: xxxxx Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:753640106 errors:928 dropped:0 overruns:0 frame:928
          TX packets:152723550 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:273664141857 (254.8 GiB)  TX bytes:185828292469 (173.0 GiB)
          Interrupt:22 Base address:0x8000 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:85 errors:0 dropped:0 overruns:0 frame:0
          TX packets:85 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:11840 (11.5 KiB)  TX bytes:11840 (11.5 KiB)

[root@centos ~]# cat /etc/sysconfig/network

NETWORKING=yes
HOSTNAME=mine.not.yours
GATEWAY=192.168.2.1
[root@centos ~]# cat /etc/sysconfig/network-scripts/ifcfg-eth0
DEVICE="eth0"
TYPE="Ethernet"
HWADDR=xx:xx:xx:xx:xx:xx
NAME="System eth0"
ONBOOT="yes"
#BOOTPROTO="dhcp"   NOTE this line is for when I take the box out of the house
BOOTPROTO="static"   it will be swapped with this line
NM_CONTROLLED="no"
IPADDR=192.168.2.125
NETMASK=255.255.255.0
USERCTL="no"
#DEFROUTE=yes
#PEERROUTES=yes
#PEERDNS=yes
IPV4_FAILURE_FATAL=yes
IPV6INIT=no
[root@centos ~]# cat /etc/resolv.conf 
nameserver 192.168.2.1
also when i switch over to DHCP i comment out the IPADDR and NETMASK lines.

not the resolv.conf. I run internal DNS so i point everything there. when I leave the house I will switch the nameserver from internal to 8.8.8.8 and use google's DNS.

hope that helps.
 
Old 02-12-2013, 06:23 PM   #6
chrism01
LQ Guru
 
Registered: Aug 2004
Location: Sydney
Distribution: Centos 6.9, Centos 7.3
Posts: 17,411

Rep: Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397
I agree that I've always had trouble with NM (as have others), so I always disable it.
My resolv.conf
Code:
cat /etc/resolv.conf
; generated by /sbin/dhclient-script
nameserver 192.168.1.254
using dhcp.

You can check the correct MAC by looking at /etc/udev/rules.d/70-persistent-net.rules
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Network Configuration on RHEL 6.2 Santiago - Need an advice shaifulsafar Linux - Networking 10 02-13-2013 11:20 PM
Manual RHEL 6 Network configuration linuxunix Linux - Newbie 6 03-15-2011 09:10 PM
Issue pertaining to network configuration on RHEL pachax_linux Linux - Networking 2 05-28-2010 11:22 AM
Static Network Configuration on RHEL dssr Red Hat 11 04-28-2010 11:14 AM
RHEL Gnome GUI Network Configuration tool pellicle Linux - Networking 3 07-16-2008 12:16 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 07:41 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration