-   Linux - Newbie (
-   -   net working eth0 eth1 wlan0 "no connection" "no LAN" "no wi-fi" (

Cayitano 12-06-2007 06:55 PM

net working eth0 eth1 wlan0 "no connection" "no LAN" "no wi-fi"
Newbie Sort Of Running PCLinuxOS on a Toshiba Tecra 9000 Worked fine yesterday just after connecting to repository and shutting down.

Now cannot connect to Internet in Library using built-in Wi-Fi or PCMCIA wi-fi card or LAN connection.

When I go into the Control Panel and set up for new network connection, it takes me to the last step and pulls up a menu that says, "Please wait-updating file list Downloading and installing packages."

OK I do so and the daemon menu says ERROR "could not install the dhcpcd package." Synapatic says the package is installed.

ifconfig in the terminal says I have a LAN # assigned but ISPs for the two wi-fi links.

What may I do in the terminal console to make sure evreything is configured correctly? I have used intuition to configure my KDE networking set up and it is reading ISP #s.

masonm 12-06-2007 08:41 PM

What's the output of ifconfig?

Cayitano 12-07-2007 07:45 PM

ifconfig for the moment listed below

The inet address is back to the normal one. It was 169. something which I do not see very often. Still cannot get wi-fi out of my built-in hardware. It isnṫ showing connected in my monitor and when it does show I am linked, I still cannot get my icon in the task tray to show an established link. LAN connection problem appears to have been a problem with an RJ45 connector that does not click into place and pulls out from the back of the laptop. The eth1 message from the control panel attempts to link say ZeroConf problem even though I do not have my PCMCIA antenna installed.


[root@eburg ~]# ifconfig
eth0 Link encap:Ethernet HWaddr 00:00:39:A8:4B:9F
inet addr: Bcast: Mask:
inet6 addr: fe80::200:39ff:fea8:4b9f/64 Scope:Link
RX packets:52740 errors:0 dropped:0 overruns:0 frame:0
TX packets:31787 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:63058650 (60.1 MiB) TX bytes:2841820 (2.7 MiB)

eth1 Link encap:Ethernet HWaddr 00:02:2D:36:8A:F7
RX packets:2308 errors:0 dropped:0 overruns:0 frame:0
TX packets:64 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:199398 (194.7 KiB) TX bytes:8336 (8.1 KiB)
Interrupt:11 Base address:0xd100

lo Link encap:Local Loopback
inet addr: Mask:
inet6 addr: ::1/128 Scope:Host
RX packets:5165 errors:0 dropped:0 overruns:0 frame:0
TX packets:5165 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:270568 (264.2 KiB) TX bytes:270568 (264.2 KiB)

pentode 12-08-2007 01:25 PM

Take a look at lsmod to see what modules are loaded. This might be easier if you remove or turn off the wireless NICs until you get the wired Ethernet NIC working, then try adding one of the wireless NICs. It's always good to break problems down to smaller problems.

Cayitano 12-09-2007 06:52 PM

It looks like my problem may caused by /dev/hda1 being at 100% full capacity. Next stop: how to increase partition size using the command line when KDE Control says I need to know what I am doing before playing like a monkey on the plates. Will figure out what Ismod is all about on my way into my new world of Linux. Thank-you. JR

Cayitano 12-09-2007 07:11 PM

The wi-fi worked in the small cafe on the edge of town so it looks like eth1 won'ṫ work when LAN hardwire eth0 is hooked in. These glitches may be caused by my /dev/hda1 being filled to capacity, 7.7 GB. Time for me to learn how to increase partition size. Thank-you. JR

All times are GMT -5. The time now is 06:30 AM.