LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-17-2011, 12:19 PM   #1
sharmashivani
LQ Newbie
 
Registered: Jun 2011
Posts: 3

Rep: Reputation: Disabled
net-snmp-5.6.1 Installation on Solaris 10!!


Hello,

I am trying to install net-snmp-5.6.1 on Solaris 10. I can configure the package just fine, but when I do a "make" it gives me below error. Could someone help me with this? I have fairly basic knowledge of working with Solaris, so any help would be appreciated.

t.o snmp_openssl.o
*** Error code 1
make: Fatal error: Command failed for target `libnetsnmp.la'
Current working directory /export/home/users/tech/net-snmp-5.6.1/snmplib
*** Error code 1
The following command caused the error:
if test "snmplib agent apps man local mibs" != ""; then \
it="snmplib agent apps man local mibs" ; \
for i in $it ; do \
echo "making all in `pwd`/$i"; \
( cd $i ; make ) ; \
if test $? != 0 ; then \
exit 1 ; \
fi \
done \
fi
make: Fatal error: Command failed for target `subdirs'
#


Thank you!
 
Old 06-18-2011, 04:02 PM   #2
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 19,253

Rep: Reputation: 4435Reputation: 4435Reputation: 4435Reputation: 4435Reputation: 4435Reputation: 4435Reputation: 4435Reputation: 4435Reputation: 4435Reputation: 4435Reputation: 4435
Quote:
Originally Posted by sharmashivani View Post
Hello,
I am trying to install net-snmp-5.6.1 on Solaris 10. I can configure the package just fine, but when I do a "make" it gives me below error. Could someone help me with this? I have fairly basic knowledge of working with Solaris, so any help would be appreciated.

t.o snmp_openssl.o
*** Error code 1
make: Fatal error: Command failed for target `libnetsnmp.la'
Current working directory /export/home/users/tech/net-snmp-5.6.1/snmplib
*** Error code 1
The following command caused the error:
if test "snmplib agent apps man local mibs" != ""; then \
it="snmplib agent apps man local mibs" ; \
for i in $it ; do \
echo "making all in `pwd`/$i"; \
( cd $i ; make ) ; \
if test $? != 0 ; then \
exit 1 ; \
fi \
done \
fi
make: Fatal error: Command failed for target `subdirs'
This would be better in the Solaris forums, since it's a Solaris question, not a Linux/Newbie question. Did you read the readme documentation that came with net-snmp for Solaris? Your path has to be correct/modified before it'll work. Add /usr/ccs/bin to your PATH environment variable, and try it again.
 
Old 06-19-2011, 01:03 PM   #3
sharmashivani
LQ Newbie
 
Registered: Jun 2011
Posts: 3

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by TB0ne View Post
This would be better in the Solaris forums, since it's a Solaris question, not a Linux/Newbie question. Did you read the readme documentation that came with net-snmp for Solaris? Your path has to be correct/modified before it'll work. Add /usr/ccs/bin to your PATH environment variable, and try it again.
Hello,

Thanks for the response. Yes I should post it in Solaris forum to get better response. However, you suggested that my PATH should have /usr/css/bin. When I do echo $PATH in the working directory.. I do see it is inculded in the PATH as below:

# echo $PATH
/opt/csw/bin:/usr/sbin:/usr/bin:/usr/dt/bin:/usr/openwin/bin:/usr/ccs/bin:/usr/sfw/bin:/opt/mqm/bin:/opt/mqm/samp/bin

Thank you.
 
Old 06-19-2011, 09:22 PM   #4
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 19,253

Rep: Reputation: 4435Reputation: 4435Reputation: 4435Reputation: 4435Reputation: 4435Reputation: 4435Reputation: 4435Reputation: 4435Reputation: 4435Reputation: 4435Reputation: 4435
Quote:
Originally Posted by sharmashivani View Post
Hello,

Thanks for the response. Yes I should post it in Solaris forum to get better response. However, you suggested that my PATH should have /usr/css/bin. When I do echo $PATH in the working directory.. I do see it is inculded in the PATH as below:

# echo $PATH
/opt/csw/bin:/usr/sbin:/usr/bin:/usr/dt/bin:/usr/openwin/bin:/usr/ccs/bin:/usr/sfw/bin:/opt/mqm/bin:/opt/mqm/samp/bin

Thank you.
Ok....and did you read the docs that came with net-snmp?? Have you checked Sun's BigAdmin site for a pre-compiled package?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Integrate Mod-Apache-Snmp with Net-SNMP source kirukan Linux - Server 2 05-11-2011 02:48 AM
net-snmp on Solaris 10 Alans07 Solaris / OpenSolaris 1 03-03-2009 09:10 AM
Net-SNMP writing a Subagent - snmp.conf Unknown token: master AustinMarton Programming 0 12-16-2008 08:34 PM
How to configure ucd-snmp and net-snmp? Tazzmanian Linux - Networking 1 05-27-2005 09:09 AM
snmp (ucd-snmp, net-snmp) markus1982 Linux - Software 1 11-21-2002 11:45 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 07:38 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration