LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Need urgent help. Sound problem. (https://www.linuxquestions.org/questions/linux-newbie-8/need-urgent-help-sound-problem-66644/)

Genesis 06-19-2003 12:14 PM

Need help. Sound problem.
 
Hey, I've been on RH9 for 2 days. I've also been using Linux for only 2 days. My sound worked perfectly after install. I ran up2date and downloaded the updates and also installed the nVidia Display Drivers and now I have no sound.

My sound card is an SiS 730. I need help urgently please. Linux is the only OS on my pc and I need to get working. Any idea of any files I should check?

BTW: I already tried recompiling the kernel. But to no avail. Still no sound. Please help me. Thanks

:newbie:

carlywarly 06-19-2003 12:24 PM

A few things to check -
go into your bios during boot and see if there is an option to turn plug'n'play off
open a terminal, as root, and type sndconfig - see if you can configure the card that way
open a terminal and, as root, type lsmod, to see which sound modules are running.

acid_kewpie 06-19-2003 12:25 PM

please don't use words like "Urgent", we do not do that here, thanks.

Genesis 06-19-2003 12:42 PM

Ok carly, I am going through the ALSA Drivers install. Following these steps here : http://www.alsa-project.org/alsa-doc...module=trident

After this process completes if I still do not have sound I will try what you recommended. Thank you.

Genesis 06-19-2003 12:51 PM

Ok My BIOS does have an option called Plug and Play Aware OS it is on. I can turn it off.

When I type SNDCONFIG I got an invalid command message.
' lsmod ' gave me the following.

Module Size Used by Tainted: P
snd-seq-oss 34144 0 (unused)
snd-seq-midi-event 5672 0 [snd-seq-oss]
snd-seq 46864 2 [snd-seq-oss snd-seq-midi-event]
snd-seq-device 6204 0 [snd-seq-oss snd-seq]
snd-pcm-oss 44836 0 (unused)
snd-pcm 84480 0 [snd-pcm-oss]
snd-page-alloc 8388 0 [snd-pcm]
snd-timer 19716 0 [snd-seq snd-pcm]
snd-mixer-oss 16184 0 [snd-pcm-oss]
snd 43716 0 [snd-seq-oss snd-seq-midi-event snd-seq snd-seq-device snd-pcm-oss snd-pcm snd-timer snd-mixer-oss]
trident 32820 0
soundcore 6468 4 [snd trident]
pcigame 2952 0 [trident]
gameport 3364 0 [pcigame]
ac97_codec 14536 0 [trident]
agpgart 47968 3 (autoclean)
nvidia 1670784 10 (autoclean)
parport_pc 18788 1 (autoclean)
lp 8804 0 (autoclean)
parport 36800 1 (autoclean) [parport_pc lp]
autofs 13108 0 (autoclean) (unused)
sis900 16492 1
ipt_REJECT 3992 6 (autoclean)
iptable_filter 2412 1 (autoclean)
ip_tables 14648 2 [ipt_REJECT iptable_filter]
sg 35852 0 (autoclean)
sr_mod 17720 0 (autoclean)
ide-scsi 12016 0
scsi_mod 106584 3 [sg sr_mod ide-scsi]
ide-cd 35424 0
cdrom 33216 0 [sr_mod ide-cd]
keybdev 2912 0 (unused)
mousedev 5428 1
hid 21892 0 (unused)
input 5792 0 [keybdev mousedev hid]
usb-ohci 21320 0 (unused)
usbcore 78272 1 [hid usb-ohci]
ext3 69984 2
jbd 51508 2 [ext3]

Also, ALSA did not work. Does anyone know how to uninstall all the stuff I did when I followed the ALSA install steps.

o51974 06-19-2003 01:44 PM

If you used up2date and updated the kernel, how about selecting the previous kernel and see if it may work? Then, we can eliminate the kernel factor. Make sense?!

Genesis 06-19-2003 01:49 PM

Kernel....
 
When I tried to load up the old kernel I got some error about nVidia drivers. So far I can only load up this kernel.

*edit* I am going to do a reinstall of RH9 and do not update anything via up2date until I have installed nVidia drivers and the sound is working fine. Post my results back here in a bit.

Genesis 06-19-2003 03:04 PM

Alright, Re Installed Linux. Everything working perfect now. Have nVidia drivers installed and the sound is working. Not sure if I should update the kernel. Will I see a big preformance difference if I update? And should I download and install the other RHN updates?


All times are GMT -5. The time now is 09:34 PM.