LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-08-2017, 03:32 AM   #1
priyalaksh
LQ Newbie
 
Registered: Nov 2017
Posts: 1

Rep: Reputation: Disabled
Need to install dbkg


Hi,

I am trying to install puppet master to my EC2 machine, and when i try to execute the below step, it is throwing me an error.

[root@ip-172-31-32-158 ~]# dpkg -i puppetlabs-release-precise.deb
-bash: dpkg: command not found

After which when i try to install dpkg package i am having the same problem.

[root@ip-172-31-32-158 ~]# yum install dpkg
Loaded plugins: priorities, update-motd, upgrade-helper
amzn-main | 2.1 kB 00:00:00
amzn-updates | 2.5 kB 00:00:00
puppet5 | 2.5 kB 00:00:00
puppetlabs-deps | 2.5 kB 00:00:00
puppetlabs-products | 2.5 kB 00:00:00
(1/3): puppetlabs-deps/x86_64/primary_db | 8.4 kB 00:00:00
(2/3): puppet5/x86_64/primary_db | 27 kB 00:00:00
(3/3): puppetlabs-products/x86_64/primary_db | 69 kB 00:00:00
48 packages excluded due to repository priority protections
No package dpkg available.

Please help me or correct me if i am wrong anywhere.

Regards,
Priya
 
Old 11-08-2017, 06:11 AM   #2
nagaraja
LQ Newbie
 
Registered: Nov 2017
Location: india
Posts: 10

Rep: Reputation: Disabled
Quote:
Originally Posted by priyalaksh View Post
Hi,

I am trying to install puppet master to my EC2 machine, and when i try to execute the below step, it is throwing me an error.

[root@ip-172-31-32-158 ~]# dpkg -i puppetlabs-release-precise.deb
-bash: dpkg: command not found

After which when i try to install dpkg package i am having the same problem.

[root@ip-172-31-32-158 ~]# yum install dpkg
Loaded plugins: priorities, update-motd, upgrade-helper
amzn-main | 2.1 kB 00:00:00
amzn-updates | 2.5 kB 00:00:00
puppet5 | 2.5 kB 00:00:00
puppetlabs-deps | 2.5 kB 00:00:00
puppetlabs-products | 2.5 kB 00:00:00
(1/3): puppetlabs-deps/x86_64/primary_db | 8.4 kB 00:00:00
(2/3): puppet5/x86_64/primary_db | 27 kB 00:00:00
(3/3): puppetlabs-products/x86_64/primary_db | 69 kB 00:00:00
48 packages excluded due to repository priority protections
No package dpkg available.

Please help me or correct me if i am wrong anywhere.

Regards,
Priya
APT maintains the package index which is a database of available packages available in repo defined in /etc/apt/sources.list file and in the /etc/apt/sources.list.d directory. All these methods will fail to satisfy the software dependency if the dependencies required by the deb is not present in the package index

Regards,
Nagaraja
 
Old 11-08-2017, 06:21 AM   #3
jsbjsb001
Senior Member
 
Registered: Mar 2009
Location: Earth? I would say I hope so but I'm not so sure about that... I could just be a figment of your imagination too.
Distribution: CentOS at the time of this writing, but some others over the years too...
Posts: 1,767

Rep: Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848
Quote:
Originally Posted by priyalaksh View Post
Hi,

I am trying to install puppet master to my EC2 machine, and when i try to execute the below step, it is throwing me an error.

[root@ip-172-31-32-158 ~]# dpkg -i puppetlabs-release-precise.deb
-bash: dpkg: command not found
It's telling you that you do not have the dpkg command installed.

Quote:
After which when i try to install dpkg package i am having the same problem.

[root@ip-172-31-32-158 ~]# yum install dpkg
Loaded plugins: priorities, update-motd, upgrade-helper
amzn-main | 2.1 kB 00:00:00
amzn-updates | 2.5 kB 00:00:00
puppet5 | 2.5 kB 00:00:00
puppetlabs-deps | 2.5 kB 00:00:00
puppetlabs-products | 2.5 kB 00:00:00
(1/3): puppetlabs-deps/x86_64/primary_db | 8.4 kB 00:00:00
(2/3): puppet5/x86_64/primary_db | 27 kB 00:00:00
(3/3): puppetlabs-products/x86_64/primary_db | 69 kB 00:00:00
48 packages excluded due to repository priority protections
No package dpkg available.

Please help me or correct me if i am wrong anywhere.

Regards,
Priya
First question, why are you trying to install dpkg on a rpm based distro?

Which Linux distro are we talking about?

The dpkg package would likely not exist in an rpm based distro, that's where you have gone wrong there.
 
Old 11-08-2017, 07:37 AM   #4
pan64
LQ Guru
 
Registered: Mar 2012
Location: Hungary
Distribution: debian/ubuntu/suse ...
Posts: 11,280

Rep: Reputation: 3388Reputation: 3388Reputation: 3388Reputation: 3388Reputation: 3388Reputation: 3388Reputation: 3388Reputation: 3388Reputation: 3388Reputation: 3388Reputation: 3388
as you tried to use yum to install dpkg - which actually does not work - try also yum to install other packages.
 
Old 11-08-2017, 08:51 PM   #6
Soitgoes
Member
 
Registered: Oct 2016
Location: Beyond Thunderdome
Distribution: Gentoo
Posts: 67

Rep: Reputation: Disabled
You could convert the .deb file to an .rpm file with something like Ďaliení .
 
Old 11-11-2017, 02:32 AM   #7
rosehosting.com
Member
 
Registered: Jun 2012
Location: Missouri, USA
Posts: 225

Rep: Reputation: 62
Run the following command:

cat /etc/issue && cat /etc/redhat-release

and download the packages from puppet Yum repositories specific to your Linux distribution as described at https://puppet.com/docs/puppet/5.3/puppet_platform.html
 
Old 11-11-2017, 02:27 PM   #8
AwesomeMachine
LQ Guru
 
Registered: Jan 2005
Location: USA and Italy
Distribution: Debian testing/sid; OpenSuSE; Fedora; Mint
Posts: 5,378

Rep: Reputation: 979Reputation: 979Reputation: 979Reputation: 979Reputation: 979Reputation: 979Reputation: 979Reputation: 979
Why are you using yum and dpkg on the same system?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] [RHL 6.2] Fresh install. XWindows Server didn't install. Can I install it manually? Patriot2135 Red Hat 9 11-19-2013 12:37 AM
yum install lib getting fails yum install lib* leads to install 1050 dependency pkg LittleMaster Linux - Server 3 10-29-2012 01:14 AM
Uncertain how to configure/install packages & compiler before install VMware on FC8. Azazwa Linux - Newbie 1 03-28-2009 07:27 PM
Ubuntu as frugal install, iso install, img install? impossible? nooby Ubuntu 15 08-22-2008 05:49 AM
apt-get install dependency problems with hplip software and kde install for Agnula maybi7 Linux - Software 1 02-03-2007 05:16 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 12:23 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration