LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Need to access files on 2nd SATA hard drive but can't mount (https://www.linuxquestions.org/questions/linux-newbie-8/need-to-access-files-on-2nd-sata-hard-drive-but-cant-mount-641652/)

Io3 05-12-2008 09:47 AM

Need to access files on 2nd SATA hard drive but can't mount
 
Hello,

I have a system with a single SATA hard drive running Fedora 8 and have installed a 2nd SATA hard drive that was the primary drive in system running Fedora 6. I need to access the files on this 2nd hard drive (/dev/sdb2).

When I attempt to mount the device /dev/sdb2 it will not recognize the filesystem.

I searched through the forums but did not come up with any threads with a similar problem. Can someone help me with this?

Thank you.


Here are some details:

[root@localhost ~]# fdisk -l

Disk /dev/sda: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0xed5943bb

Device Boot Start End Blocks Id System
/dev/sda1 * 1 25 200781 83 Linux
/dev/sda2 26 19457 156087540 8e Linux LVM

Disk /dev/sdb: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0xc7e94dd9

Device Boot Start End Blocks Id System
/dev/sdb1 * 1 13 104391 83 Linux
/dev/sdb2 14 19457 156183930 8e Linux LVM

Disk /dev/dm-0: 157.7 GB, 157705830400 bytes
255 heads, 63 sectors/track, 19173 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x00000000

Disk /dev/dm-0 doesn't contain a valid partition table

Disk /dev/dm-1: 2080 MB, 2080374784 bytes
255 heads, 63 sectors/track, 252 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x30307800

[root@localhost ~]# cat /etc/fstab
/dev/VolGroup00/LogVol00 / ext3 defaults 1 1
LABEL=/boot /boot ext3 defaults 1 2
tmpfs /dev/shm tmpfs defaults 0 0
devpts /dev/pts devpts gid=5,mode=620 0 0
sysfs /sys sysfs defaults 0 0
proc /proc proc defaults 0 0
/dev/VolGroup00/LogVol01 swap swap defaults 0 0




Disk /dev/dm-1 doesn't contain a valid partition table



[root@localhost ~]# pvdisplay
WARNING: Duplicate VG name VolGroup00: Existing R0ox8k-wsTR-jVfz-8y2L-X5QR-K5rd-wDxCxA (created here) takes precedence over SkYedY-zkN4-CwND-w9a3-6e8A-1sqE-olMWP1
--- Physical volume ---
PV Name /dev/sdb2
VG Name VolGroup00
PV Size 148.95 GB / not usable 11.37 MB
Allocatable yes
PE Size (KByte) 32768
Total PE 4766
Free PE 1
Allocated PE 4765
PV UUID 3cjuJe-Lj5Z-H9Cy-pqYg-QDVT-CQ7c-rO8E1V

--- Physical volume ---
PV Name /dev/sda2
VG Name VolGroup00
PV Size 148.86 GB / not usable 13.24 MB
Allocatable yes
PE Size (KByte) 32768
Total PE 4763
Free PE 1
Allocated PE 4762
PV UUID KoQY86-5gJd-BDcz-vwAd-JxOw-NRlh-10Li80





[root@localhost ~]# lvdisplay
WARNING: Duplicate VG name VolGroup00: Existing R0ox8k-wsTR-jVfz-8y2L-X5QR-K5rd-wDxCxA (created here) takes precedence over SkYedY-zkN4-CwND-w9a3-6e8A-1sqE-olMWP1
--- Logical volume ---
LV Name /dev/VolGroup00/LogVol00
VG Name VolGroup00
LV UUID RzFlyf-Cxd5-3g37-xBH3-gcjN-1wo2-VjREZ6
LV Write Access read/write
LV Status available
# open 1
LV Size 146.88 GB
Current LE 4700
Segments 1
Allocation inherit
Read ahead sectors 0
Block device 253:0

--- Logical volume ---
LV Name /dev/VolGroup00/LogVol01
VG Name VolGroup00
LV UUID 2Rr3w7-lEEJ-y5J5-zZWT-j70C-oDIr-J3FBeD
LV Write Access read/write
LV Status available
# open 1
LV Size 1.94 GB
Current LE 62
Segments 1
Allocation inherit
Read ahead sectors 0
Block device 253:1

[root@localhost ~]#
[root@localhost ~]#
[root@localhost ~]# mount /dev/sdb2 /test
mount: you must specify the filesystem type

[root@localhost ~]# mount -t ext3 /dev/sdb2 /test
mount: wrong fs type, bad option, bad superblock on /dev/sdb2,
missing codepage or helper program, or other error
In some cases useful info is found in syslog - try
dmesg | tail or so

[root@localhost ~]# dmesg | tail
Bluetooth: RFCOMM ver 1.8
eth0: no IPv6 routers present
[drm] Initialized drm 1.1.0 20060810
PCI: Setting latency timer of device 0000:00:02.0 to 64
[drm] Initialized i915 1.6.0 20060119 on minor 0
kjournald starting. Commit interval 5 seconds
EXT3 FS on sdb1, internal journal
EXT3-fs: mounted filesystem with ordered data mode.
hfs: unable to find HFS+ superblock
VFS: Can't find ext3 filesystem on dev sdb2.
[root@localhost ~]#

Jay_Drummond 05-12-2008 04:40 PM

Looks like you have the same LVM volume and group names on both drives.

I'd remove the first disk from the system. Plug the drive you are trying to add in as the first disk. Boot a live CD. Mount the hard disk and copy it to another drive or network location.

Then follow a LVM recipe - http://tldp.org/HOWTO/LVM-HOWTO/recipes.html - to add the drive back into your system. Once it's back in, you can copy the files back onto the drive from the backup. This should be safe.

It might be possible rename the LVM volume group and then there won't be a name conflict. Make sure you have a backup before trying it. ;)


All times are GMT -5. The time now is 04:14 AM.