-   Linux - Newbie (
-   -   Need solution to "failed to fork PTY" and "error creating the child process" problems (

Gnusboy 12-20-2009 10:09 PM

Need solution to "failed to fork PTY" and "error creating the child process" problems
I am new to Linux. I have been trying to find a solution to problems created by Mediabuntu during installation.

When I try to use or use Synaptic Package Manager to fix the broken dependencies it says there are 5 broken packages. However, Only four packages are listed.
When I mark for re-installation and hit Apply, I get the "Error Failed to Fork PTY" message.

Trying to use the terminal I get "error creating the child process"

I have been trying to get help with these problems for 2 weeks without success. I keep hoping that someone will give me a simple, easy to follow solution to the problems, but no one has.
I have looked in Google, the forums and chat. I have searched dozens of threads that appear related to the "failed to fork pty" but cannot get an understandable answer.

I have tried dozens of times using Ctl/Alt F1 console to enter this line: sudo cp /etc/init.d/ /etc/init.d/ To which I get
Failed to execute child process "/home/amazonas/file system" (No such file or directory) or other error messages.

I do not know how to copy the console output to examine when I close the console.
I do not know how to have the console and desktop open together.
I cannot find correct keyboard commands to move or stop the fast scrolling while in console
I do not know how to copy and paste commands while in console
In the console I also get a you do not have permission -xxx-

I cannot fix my problem on my own
I have asked for help in several forums - I get different command strings from the very few people who have responded to my posts.
My questions go unanswered and the command strings do not work and the error messages continue.
If this is not the right place to ask these questions - please inform me of the correct place to get a solution.

Thank You.

Agrouf 12-21-2009 05:17 AM


Please type this code in console (ctrl+alt+F1):

sudo echo "devpts /dev/pts devpts rw,noexec,nosuid,gid=5,mode=620 0 0" >> /etc/fstab
sudo mount /dev/pts

Gnusboy 12-22-2009 04:41 AM

type this code in consol
Thank you.
I'll let you know the results. I truly appreciate your help.

Gnusboy 01-01-2010 08:43 PM

Failed to fork pty - still broken
Just had the time to try your solution, but it does not work!

I still get the "error failed to fork pty" message

When I go to console and enter your recommended fix, I get a "permission denied" message OR "/etc/fstab" is not a directory

I have gone back into my file system and changed all the permissions to allow privileges
But that does not help either.
Again, I am baffled.

Any ideas?


Agrouf 01-02-2010 08:54 AM


sudo gedit /etc/fstab
then add the line:

devpts /dev/pts devpts rw,noexec,nosuid,gid=5,mode=620 0 0
then type this command in terminal:

sudo mount /dev/pts

All times are GMT -5. The time now is 07:37 AM.