LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   need help with connecting to my GPS unit through USB in kubuntu 12.10 (https://www.linuxquestions.org/questions/linux-newbie-8/need-help-with-connecting-to-my-gps-unit-through-usb-in-kubuntu-12-10-a-4175437509/)

OriginalCrazyone 11-16-2012 09:11 PM

need help with connecting to my GPS unit through USB in kubuntu 12.10
 
hello, all...

I have been trying for 2 days now to connect to my GPS unit, a Garmin Streetpilot c330. I plug the usb cord into the computer, and nothing happens, it doesn't see it at all... the unit recarges the battery but that is the only thing that happens... I know that garmin doesn't support using their products with linux, and their tools are buggy and don't wirk using wine, but I am wanting to be able to use the unit connected to the laptop not only for updating, but for use with mapping software and I don't know how this community feels about this activity, but I enjoy wardriving, I.E. mapping out wifi access points while driving around, and detecting if they are open or closed. I don't use them unless they are open and I am having an emergency, I.E. my car broke down once while out in the middle of nowhere and I had no cell signal and was lucky enough to be near a house that had their wifi unsecure, so I was able to get a friend out there to help... it is just interesting to me to do this... I would also like to be able to update the unit and put new voices on it and things like that, but it would be nice to at least access the unit in any way... even just to download the saved locations off of it to use with google maps to get directions to them again in case the unit goes out, as it is an older discontinued model... I have tried GPSbabbel, foxtrot gps, qlandkartegt, gebabbel, the garmin utilities in wine, and nothing sees the unit at all! I am getting very frustrated...

Thanks!
-OcO-

markush 11-17-2012 01:58 PM

Hi,

gpsbabel works very well with Garmin-devices. The problem in most cases is the module garmin_gps, this should be blacklisted.

Try (when the device is connected)
Code:

sudo rmmod garmin_gps
Afterwards you can use gpsbabel in order to transfer data to the device and vice versa. I've written a little Howto here: http://docs.slackware.com/howtos:hardware:gps_devices it is written for Slackware but actually distribution-independend.

If it works you should find out how you can blacklist garmin_gps in your distribution.

Markus

OriginalCrazyone 11-17-2012 06:37 PM

when I tried that command, it returned this: ERROR: Module garmin_gps does not exist in /proc/modules

abd I still can't access the unit... I even tried running GPSBabbel as rooth as some guides have suggested, and had no luck there, either...

the computer does nothing in any way to acknowledge that the device is attached, but the unit is charging through the USB, so I know it is attached... I have tried even switching out the cord in case the data pins were messed up to no avail...
Thanks for the suggestion, any more ideas?

-OcO-

markush 11-17-2012 06:40 PM

Well, when the module is not loaded, the load it
Code:

modprobe garmin_gps
and look what happens (sometimes it works).

You should also take a look at the output of the dmesg command and please look at lsusb. These commands should show some information about the device.

Which command did you execute with gpsbabel?

Markus

OriginalCrazyone 11-17-2012 06:49 PM

FATAL: Error inserting garmin_gps (/lib/modules/3.5.0-18-generic/kernel/drivers/usb/serial/garmin_gps.ko): Operation not permitted

and I tried these commands:
gpsbabel -T -i garmin -f usb: -o kml -F /home/originalcrazyone/Desktop/PositionLogging.kml
and
gpsbabel -w -i garmin -f usb: -o gpx -F /home/originalcrazyone/Desktop/GarminWaypoints.gpx

-OcO-

markush 11-17-2012 06:53 PM

Did you do it as root?

Well, maybe the module isn't correct.

gpsbabel comes with it's own drivers. referring to this site http://www.gpsbabel.org/htmldoc-1.4.2/fmt_garmin.html your device is supported. Which type of files do you want to transfer to the device? and which command do you use?

Markus

OriginalCrazyone 11-17-2012 06:57 PM

I would like to update the base software of the unit to the current, but mostly I would like to download and backup the location info from my favorite locations I have saved to the unit and to be able to add some points of interest to it so I can take the kids on a roadtrip around the area exploring new places, and I would like to be able to get realtime gps info from the unit to use it with my laptop for wardriving purposes...

-OcO-

OriginalCrazyone 11-17-2012 07:00 PM

if it is possible I would be willing to flash the unit to a new non garmin software to use open source maps and to make it do what I want, but I doubt that the proprietary hardware of the garmin unit is flashable in this fashion...

and the unit is listed on the gpsbabbel site as compattable...

-OcO-

markush 11-17-2012 07:02 PM

Well, for example if you want to read waypoints from the device to your computer you could use
Code:

gpsbabel -i garmin -f usb: -o gpx -F blah.gpx
and this gpxfiles can be opened for example with qlandkartegt.

But at first you'll have to find out if the device is recognized by the system.

When I install new firmware on my Garmin, I use mapsource on a Windowscomputer.

Markus

markush 11-17-2012 07:05 PM

I'm using maps from openstreetmap with my Garmin, but the maps are stored on a micro-SD-card which I can insert. I've a Etrex Legend Hcx device.

Did you check what the lsusb command shows about the device?

Markus

OriginalCrazyone 11-17-2012 07:21 PM

well, that made progress.... I found out I was using the wrong usb port trying to read data from it, and managed to get it to return current position data from the unit... however, every command I execute on it returns the error:
gpsbabel was unexpectedly quit during its operation.
Created files should not get used but deleted.

so we are making progress, but what am I doing wrong now... the unit is on
Bus 005 Device 027: ID 091e:0003 Garmin International GPS (various models)

-OcO-

markush 11-17-2012 07:30 PM

you could try to transfer any waypoint files to the device. You could also try to connect to the device with qlandkartegt. My device doesen't connect to qlandkartegt, but otherwise this program comes with extra Garmin-drivers. Maybe it works.

I'll have to go to bed now, it's half past 2 in the morning here in Germany. I'll help you if I can with this issue, maybe you find out more about what works and what not works.

Regards

Markus

OriginalCrazyone 11-17-2012 07:33 PM

Thank you very much for all the help with this :) as much as this is bugging me, it is teaching me alot as well! I will mess with it some more and post here results as I go.

goodnight
-OcO-

markush 11-18-2012 05:17 AM

Quote:

Originally Posted by OriginalCrazyone (Post 4831670)
if it is possible I would be willing to flash the unit to a new non garmin software to use open source maps and to make it do what I want, but I doubt that the proprietary hardware of the garmin unit is flashable in this fashion...
...

There is no need to flash the unit. You can use the maps from openstreetmap.org http://wiki.openstreetmap.org/wiki/O...Garmin#Devices here it is explained, it is the same procedure for all Garmin-devices. Download a map in gmapsupp.img format (the card has always this name!) and store it in a directory "Garmin" on a micro-SD-card. Then put the SD-card into the Garmin and turn the device on. The map should be recognized by the system automatically.

There are several types of maps which can be downloaded. At least here in Europe there are also Mountainbike or Biketravel maps as well as cards for hiking and also streetmaps for the car. http://wiki.openstreetmap.org/wiki/O...armin/Download

One can download maps in gmapsupp.img format and also convert other maps to this format, it is also possible to create one's own maps.
There's an online-tool where you can select areas for your map and download the map afterwards

Markus


All times are GMT -5. The time now is 06:27 PM.