LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-15-2005, 10:50 PM   #1
frandres
LQ Newbie
 
Registered: Jan 2005
Location: Venezuela
Distribution: Fedora Core 3
Posts: 5

Rep: Reputation: 0
Question Need help mounting a VFat partition r/w


Greetings...

I'm having problems with mounting a Vfat partition r/w in Fedora Core 3. When the system boots, I cant write to my files. However, if I umount it and then remount it (as an user), the problem seems to be solved... Can anyone plz help me? My fstab entry is as follows...

/dev/hda7 /mnt/Documentos vfat gid=501,user,pamconsole,suid,dev,exec,auto,sync 0 0

I read somewhere that using a group could solved this, so I followed the instructions and make a group called Documentos and then I added myself at /etc/group... Any ideas?
 
Old 01-16-2005, 12:36 AM   #2
dping
Member
 
Registered: Dec 2004
Location: Oregon, USA
Distribution: Kubuntu 9.04
Posts: 181

Rep: Reputation: 30
umask

Add umask=0 to your options list...

(eg)
/dev/hda2 /mnt/OShared vfat umask=0,defaults 0 0

The umask=0 entry makes the filesystem read/writeable for ordinary users.
 
Old 01-16-2005, 11:52 AM   #3
walker
Member
 
Registered: Nov 2003
Posts: 78

Rep: Reputation: 15
simply comment your /etc/fstab line

#/dev/hda7 /mnt/Documentos vfat gid=501,user,pamconsole,suid,dev,exec,auto,sync 0 0

as above so the system don't use it but if you want to go back to your previous setting you have only to take off this # from the beginning of the line

and add (always in /etc/fstab) this line

/dev/hda7 /mnt/Documents vfat user,noauto,exec,rw 0 0

so you can mount and umount it when you want.

Let me know but it should work.

walker
 
Old 01-16-2005, 03:56 PM   #4
frandres
LQ Newbie
 
Registered: Jan 2005
Location: Venezuela
Distribution: Fedora Core 3
Posts: 5

Original Poster
Rep: Reputation: 0
Ok ill do that but is there a way to use umask without making the partition r/w for every user?
 
Old 01-16-2005, 06:06 PM   #5
frandres
LQ Newbie
 
Registered: Jan 2005
Location: Venezuela
Distribution: Fedora Core 3
Posts: 5

Original Poster
Rep: Reputation: 0
Well adding the umask option actually worked but again, is there a way to make a partition r/w only to an specific group without having this problem? Thanks......
 
Old 01-17-2005, 12:18 AM   #6
walker
Member
 
Registered: Nov 2003
Posts: 78

Rep: Reputation: 15
I can't answer your last question because I've never had this problem.
I'm the only user and admin of my pc.
Let me a little time to try out if it's possible.

walker
 
Old 01-17-2005, 03:23 AM   #7
walker
Member
 
Registered: Nov 2003
Posts: 78

Rep: Reputation: 15
I can suggest you to try this trick

add group=*(the name of the group which should be able to mount the partition)

i.e. /dev/hda7 /mnt/Documents vfat user,group=*,noauto,exec,rw 0 0

Let me know

 
Old 01-17-2005, 07:31 AM   #8
egag
Senior Member
 
Registered: Jul 2004
Location: Netherlands
Distribution: Slackware
Posts: 2,721

Rep: Reputation: 52
i think it should be :

/dev/hda7 /mnt/Documents vfat user,GID=<id of group>,noauto,exec,rw 0 0

you can also use " UID " for only one user

egag
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
mounting vfat partition in fc3 reksav Linux - Newbie 1 04-12-2005 12:19 AM
mounting vfat-partition rw for all users ruh31 Debian 4 01-27-2005 04:27 AM
problems mounting vfat partition oDyman Slackware 6 11-11-2004 05:18 AM
Mounting extended vfat partition shaggz Linux - General 15 05-26-2003 06:33 AM
Problem mounting vfat partition!!! yalanop Linux - Newbie 1 02-02-2003 03:21 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 04:06 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration