LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-26-2005, 10:21 AM   #1
cevilgenius
LQ Newbie
 
Registered: Mar 2005
Posts: 7

Rep: Reputation: 0
Need help mounting a hard drive


I need help mounting my hard drive in Fedora Core 3. I've tried a method through the terminal using this rpm file that I downloaded online for my kernel and then mounting using "mount /dev/hda2 /mnt/audio-video" but it always give me this "fs type ntfs not supported by kernel" error.

Here's the guide: fedoraforum.org/forum/showthread.php?p=223661

Norm
 
Old 03-26-2005, 10:24 AM   #2
Seventh
Member
 
Registered: Dec 2003
Location: Boston, MA
Distribution: Redhat / Debian
Posts: 269

Rep: Reputation: 30
Sounds like you need to compile NTFS support into your kernel.

http://fedoranews.org/contributors/vitor_domingos/ntfs/

Last edited by Seventh; 03-26-2005 at 10:37 AM.
 
Old 03-26-2005, 10:30 AM   #3
cevilgenius
LQ Newbie
 
Registered: Mar 2005
Posts: 7

Original Poster
Rep: Reputation: 0
That link says it's for FC2. Sorry about not being so clear but I'm using Fedora Core 3 Kernel 2.6.9-1.667. There's no option to install Kernel Development.

Norm
 
Old 03-26-2005, 10:37 AM   #4
Seventh
Member
 
Registered: Dec 2003
Location: Boston, MA
Distribution: Redhat / Debian
Posts: 269

Rep: Reputation: 30
This link should help you out. Seems like there's an RPM out there that should make things easier.

Quote:
Open the terminal. Type:

su

Hit enter. Type your root password. Hit enter. Type:

uname -r -p

This will output your kernel version and processor type.

Open Firefox. Go to http://linux-ntfs.sourceforge.net/rpm/fedora3.html and download (save to disk) the appropriate NTFS RPM for your kernel version and processor type. (These instructions will help you find the correct RPM: http://linux-ntfs.sourceforge.net/rp...ructions.html.)

With the root terminal still open type:

rpm -ivh *.rpm

Hit enter. Wait for the installation to complete. Type:

rm *.rpm

Hit enter. Type "y" and hit enter. Type:

su -

Hit enter. Type:

mkdir /mnt/windows

Hit enter. Type:

fdisk -l /dev/hda

Hit enter. This will output your HPFS/NTFS partition identifier. Type:
gedit /etc/fstab

Type the following in gedit:

/dev/hda1 /mnt/windows ntfs ro,defaults,umask=0222 0 0

If your partition identifier is not "/dev/hda1" substitute the correct characters. Click the "save" icon in gedit and exit gedit. Close the terminal. Reboot. Your Windows partition should now be available in the file browser under "/mnt/windows".
 
Old 03-26-2005, 10:38 AM   #5
Seventh
Member
 
Registered: Dec 2003
Location: Boston, MA
Distribution: Redhat / Debian
Posts: 269

Rep: Reputation: 30
Direct link: http://madpenguin.org/cms/?m=show&id=3506#NTFS
 
Old 03-26-2005, 11:02 AM   #6
cevilgenius
LQ Newbie
 
Registered: Mar 2005
Posts: 7

Original Poster
Rep: Reputation: 0
I'm following the instructions and I did it twice but it still hasn't produced any results. I think I'm doing something wrong here:

Quote:
Open Firefox. Go to http://linux-ntfs.sourceforge.net/rpm/fedora3.html and download (save to disk) the appropriate NTFS RPM for your kernel version and processor type. (These instructions will help you find the correct RPM: http://linux-ntfs.sourceforge.net/r...tructions.html.)

With the root terminal still open type:

rpm -ivh *.rpm

Hit enter. Wait for the installation to complete. Type:

rm *.rpm

Hit enter. Type "y" and hit enter. Type:
What exactly do I put for *.rpm? I tried leaving it as it, as well as /home/(username)/kernel-module-ntfs-2.6.9-1.667-2.1.20-0.rr.3.3.i686.rpm (which was where I downloaded it to). It gave me all these errors. I skipped this part, then continued this twice, restarted my computer twice yet /mnt/windows has nothing in it. Also note I see the fs type not supported error and [failed] when I load up Fedora.

I really don't know what to do. I'm pretty much a Linux here.

EDIT: I've also tried directly installing the rpm by double clicking on it, it says it's already installed.

Norm

Last edited by cevilgenius; 03-26-2005 at 11:10 AM.
 
Old 03-26-2005, 11:31 AM   #7
cevilgenius
LQ Newbie
 
Registered: Mar 2005
Posts: 7

Original Poster
Rep: Reputation: 0
Nvm, I use the su command to install, it claimed it was installed already. Then I did the rm *.rpm and typed in y and <enter>. I went on with the rest of the instructions, but it didn't affect it any. I still got the mount error when loading up Fedora and nothing was in /mnt/windows.

Norm
 
Old 03-26-2005, 08:19 PM   #8
dns21
Member
 
Registered: Feb 2004
Location: AZ
Distribution: Slackware, Ubuntu, CentOS, Debian
Posts: 139

Rep: Reputation: 15
I'm not positive on the FC3 distro but can you list the contents of your /etc/fstab file? Somebody correct me if I am wrong here, but wouldn't this be pertinent?
 
Old 04-01-2005, 02:42 PM   #9
cevilgenius
LQ Newbie
 
Registered: Mar 2005
Posts: 7

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by dns21
I'm not positive on the FC3 distro but can you list the contents of your /etc/fstab file? Somebody correct me if I am wrong here, but wouldn't this be pertinent?
Code:
# This file is edited by fstab-sync - see 'man fstab-sync' for details
LABEL=/                 /                       ext3    defaults        1 1
none                    /dev/pts                devpts  gid=5,mode=620  0 0
none                    /proc                   proc    defaults        0 0
none                    /dev/shm                tmpfs   defaults        0 0
/dev/hda5 /mnt/windows ntfs ro,defaults,umask=0222 0 0
/dev/hdd                /media/cdrom            auto    pamconsole,ro,exec,noauto,managed 0 0
/dev/hdc                /media/cdrecorder       auto    pamconsole,ro,exec,noauto,managed 0 0
/dev/fd0                /media/floppy           auto    pamconsole,exec,noauto,managed 0 0
Norm
 
Old 04-02-2005, 07:52 PM   #10
cevilgenius
LQ Newbie
 
Registered: Mar 2005
Posts: 7

Original Poster
Rep: Reputation: 0
Can anyone help?

Norm
 
Old 04-02-2005, 08:32 PM   #11
AndrewZorn
Member
 
Registered: Apr 2005
Posts: 108

Rep: Reputation: 15
Quote:
Originally posted by Seventh
This link should help you out. Seems like there's an RPM out there that should make things easier.
WOW... it actually worked! A few questions though...

I have a SATA hard drive with Windows/Linux on it, and I got that mounted to mnt/Windows.
I also have an IDE hard drive with all my stuff on it.

Can I just replace the mount point with like /Windows and /Extra or something better than that and then those folders will correspond to the drives?
If so, how do I remove the old mnt/ stuff?

I put in verbatim what you had in the quote there and it didn't work, but when i replaced hda with sda it all worked. if the IDE hard drive is the secondary hard drive, how would i reference that to mount it?

please respond soon i need to access my stuff from linux
 
Old 04-02-2005, 08:41 PM   #12
AndrewZorn
Member
 
Registered: Apr 2005
Posts: 108

Rep: Reputation: 15
OK i tried redoing the process except using HDA instead of SDA and now I have no DVDROM drive. how do i get it back SOMEONE
 
Old 04-02-2005, 08:42 PM   #13
AndrewZorn
Member
 
Registered: Apr 2005
Posts: 108

Rep: Reputation: 15
also why do you remove *.rpm because that just deleted my ati drivers
 
Old 04-12-2005, 02:33 PM   #14
dns21
Member
 
Registered: Feb 2004
Location: AZ
Distribution: Slackware, Ubuntu, CentOS, Debian
Posts: 139

Rep: Reputation: 15
Quote:
Originally posted by cevilgenius
Can anyone help?

Norm
Well, I see a few differences in my default file and yours. i haven't configured this machine yet, but my ntfs drive is up and running like champ. Here is the reference to ntfs in my fstab.

# Added by KNOPPIX
/dev/hda1 /mnt/hda1 ntfs noauto,users,exec,ro,unmask=000 0 0

you could try making a backup of your fstab and entering my options... (use your existing mountpoints)
 
Old 04-12-2005, 02:34 PM   #15
dns21
Member
 
Registered: Feb 2004
Location: AZ
Distribution: Slackware, Ubuntu, CentOS, Debian
Posts: 139

Rep: Reputation: 15
Quote:
Originally posted by AndrewZorn
also why do you remove *.rpm because that just deleted my ati drivers
removing the rpm will just remove the rpm, nothing else. If you uninstall the rpm, then you uninstall the rpm.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
mounting hard drive thug_poet22 Linux - Hardware 14 01-04-2005 02:11 AM
Mounting a Hard Drive Bill413 Linux - Newbie 6 11-15-2004 05:19 PM
Mounting a Hard Drive Garoth Linux - Software 9 11-11-2004 08:47 PM
mounting a second hard drive evilRhino Linux - General 2 10-17-2002 01:22 AM
mounting a hard drive n_ick2000 Linux - Newbie 5 04-10-2002 04:40 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 03:20 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration