-   Linux - Newbie (
-   -   Need help installing Intel(R) PRO/Wireless 3945BG Network Connection on BT3 (

bobhaha 10-10-2009 10:01 PM

Need help installing Intel(R) PRO/Wireless 3945BG Network Connection on BT3
ok first off hate this forums layout.. I'm totally lost!

any way! I think I'm in the right section.. please move it if I'm not.

Anyway on to my problem! I have recently downloaded my own copy of BT3 (black track 3) and I have successfully installed it to my usb drive and can boot from it! I'm running BT3 in the first option (can't remember wat its called... if needed I'll find out for ya.. its gui cause I'm a noob!)

I'm running it off my Toshiba A200 laptop from the USB disk as mentioned above! I need to install the drivers for the wireless... I have done a bit of research and found this info at this site ... it seems i have a Intel(R) PRO/Wireless 3945BG Network Connection


I have read most of it.. but I have no clue what their on about! so can some one in plain english spell it out for me? I know... I know.. but can some one help me out without flaming?

I don't have the drivers on a cd.. but I have found this website that has the ones I need...

Lastly if I install the drivers will it install them in the root (USB disk) or will it affect my HDD??

BTW yes I know i have posted this in another section.. but I need help ASAP!

Thanks in advance! -Adrian

John76 10-10-2009 11:41 PM

Reply to help request
I am only replying because I read the entire text of your post for help.
Sorry, but I don't have a clue as to what you are writing about or what it is you want beyond help with your problem which I don't understand.


bobhaha 10-10-2009 11:44 PM

ok well my wireless device (built in) is not supported by BT3 and I need to install the drivers.. can you please help me install them? I have no clue where to start or what to do!

John76 10-10-2009 11:51 PM

a second reply
I should have added: I, also, am a "newbie" to Linux.

rkski 10-11-2009 12:04 AM


Have a look at:
Need to install to root (USB).

bobhaha 10-11-2009 12:38 AM

ok cool thanks... would this be the right one?

iwlwifi-3945-ucode- (for Intel(R) PRO/Wireless 3945BG)

and now how do i install it?

This is the info on the website


The iwlwifi-3945 driver will look for the file iwlwifi-3945-2.ucode using the
kernel's firmware_loader infrastructure. In order to function
correctly, you need to have this support enabled in your kernel. When
you configure the kernel, you can find this option in the following

Device Drivers ->
Generic Driver Options ->
Hotplug firmware loading support

You can determine if your kernel currently has firmware loader support
by looking for the CONFIG_FW_LOADER definition on your kernel's

In addition to having the firmware_loader support in your kernel, you
must also have a working hotplug and udev infrastructure configured.
The steps for installing and configuring hotplug and udev are very
distribution specific.

Once you have the firmware loader in place (or if you aren't sure and
you just want to try things to see if it works), you need to install
the microcode file into the appropriate location.

Where that appropriate location is depends (again) on your system
distribution. You can typically find this location by looking in the
hotplug configuration file for your distro:

% grep \"^FIRMWARE_DIR\" /etc/hotplug/firmware.agent

This should give you output like:


If it lists more than one directory, you only need to put the
microcode in one of them. In the above example, installation is

% cp iwlwifi-3945-2.ucode /lib/firmware

You can now load the driver (see the INSTALL and README.iwlwifi provided with
the iwlwifi package for information on building and using that driver.)

I don't understand what to do? is there a simple way of doing this?

rkski 10-11-2009 12:58 AM


What is your kernel version?

What's the output of :

lsmod |grep iwl
You could try to move your post to Networking or Wireless Networking to get more exposure.

bobhaha 10-11-2009 01:09 AM

I am running BT3 in graphics mode (KDE)

output of that code was

iwl3945 169844 0
mac80211 157192 1 iwl3945

BTW doesn't this site have RSS feeds??? GOSH :D

rkski 10-11-2009 01:28 AM

So you have the driver for your wireless already loaded.
Do you have the firmware (microcode)? In my system it's installed in /lib/firmware. Your distro is based on ubuntu/debian so hopefully ubuntu users can be of help there.

bobhaha 10-11-2009 02:16 AM

ATM I got a file called iwlwifi-3945-ucode- I'm pretty sure that us the driver I need.. now I just need to do something with it.. do I just install it or put it some where.. like what do I do with it? when I tried to install ndis.. I used a command like this tar zxct ndiswrapper.tar.gz.... do I need to do that with this file?

hurry_hui 10-11-2009 03:45 AM

You need to first make sure whether you have already intel microcode (ucode)


#dmesg | grep -i ucode
and if it is. Have you tried unloading the driver first

#modprobe -r iwl3945
then try reloading the driver

#modprobe iwl3945

bobhaha 10-11-2009 04:09 AM

ok i tried all those codes.. no luck... i had no output from them! and same error message on wireless assistant.. it might be good to note that when i make a folder on the desktop and resart the system its not saving them.. i dont know why! btw this is BT3_final.iso i downloaded from torrent.. and its 694mb and im running off my usb!

Do u think its better to try download a better version? I think this version will work.. but i need to know how to install the drivers and what ever else i need!

bobhaha 10-11-2009 04:16 AM

ok guys major break through! look what i have found!!

This basically tells you exactly what i have to do! all i need to know is how to install those drivers and modules!! can anyone help!!

EDIT oops my this is aircrack.... guys i need easy to undertand language about installing divers and anything else needed!

hurry_hui 10-11-2009 09:49 AM

You said you try all those code? which one?


$dmesg | grep -i ucode
will result, as follows or similar to


tamu@sabayon ~ $ dmesg | grep -i ucode
[  31.441693] firmware: requesting iwlwifi-3945-1.ucode
tamu@sabayon ~ $

if you use iwl3945 module.

You need to modprobe driver to verify installation

#modprobe iwl3945

#modprobe ipw3945
both will not give any screen output if done correctly

check with


#ifconfig -a
if it lists your wlan card


#ifconfig wlan0 up

bobhaha 10-11-2009 10:54 PM

Ok "$dmesg | grep -i ucode" shows no result!

I'm running BT3 on USB version! I have desided that I need to install using ndiswrapper.. I was watching a video on youtube about it! I have downloaded ndiswrapper.. and i un tared it.. then type make.. it then does it thing! then after that i write make install.. it does it thing again! then when i write nidwrapper -l i message saying ls: cannont access /ect/ndiwrapper: no such directory!! Whats wrong??

next if i can get that working i need a EXE file for my wireless card.. its not like M$ exe file.. its a zip file. where would i get this file from? i have tried these places

I cant seem to find the one i need!!

Any helpe is appreciated.. btw when i make a file on desktop after a restart.. its not there any more... why is that?

All times are GMT -5. The time now is 11:45 AM.