LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   need help installing driver module SuSe 9.1 (https://www.linuxquestions.org/questions/linux-newbie-8/need-help-installing-driver-module-suse-9-1-a-442777/)

yoinker 05-08-2006 10:24 AM

need help installing driver module SuSe 9.1
 
Hi all

I'm still very new to Linux, and basically don't know what I'm doing, I'm trying to install the driver module for my wireless usb network card. Basically its a fresh install of SuSe 9.1, and my Kernel Version is 2.6.4-52. I have the source, I think ? downloaded it as an rpm ? I also had to get the make command, gcc and cpp, and installed with Yast. When I run the make from the directory of the untared module I get this:

linux:/home/chips/ZD1211LnxDrv_2_6_0_0 # make
make both
make[1]: Entering directory `/home/chips/ZD1211LnxDrv_2_6_0_0'
make clean
make[2]: Entering directory `/home/chips/ZD1211LnxDrv_2_6_0_0'
rm -rf .tmp_versions .*.cmd *.ko *.mod.c *.mod.o *.o src/*.o src/.*.o.cmd menudbg apdbg
make[2]: Leaving directory `/home/chips/ZD1211LnxDrv_2_6_0_0'
make ZD1211REV_B=0
make[2]: Entering directory `/home/chips/ZD1211LnxDrv_2_6_0_0'
/lib/modules/2.6.4-52-bigsmp/build
/home/chips/ZD1211LnxDrv_2_6_0_0
-I/home/chips/ZD1211LnxDrv_2_6_0_0/src/include -fomit-frame-pointer -O2 -Wall -Wstrict-prototypes -pipe -DZDCONF_WE_STAT_SUPPORT=1 -DHOST_IF_USB -DAMAC -DGCCK -DOFDM -DHOSTAPD_SUPPORT -DUSE_EP4_SET_REG -DDOWNLOADFIRMWARE -DfTX_GAIN_OFDM=0 -DfNEW_CODE_MAP=1 -DfWRITE_WORD_REG=1 -DfREAD_MUL_REG=1 -DENHANCE_RX=1 -DZDCONF_MENUDBG -DZDCONF_APDBG -DZD1211
src/zd1205.o src/zdasocsvc.o src/zdauthreq.o src/zdauthrsp.o src/zdmmrx.o src/zdshared.o src/zdhci.o src/zdglobal.o src/zdencrypt.o src/zdpmfilter.o src/zdpsmon.o src/zdsynch.o src/zdbuf.o src/zd1205_proc.o src/zdhw.o src/zddebug.o src/zdtkipseed.o src/zdmic.o src/zddebug2.o src/zdusb.o src/zd1211.o
make -C /lib/modules/2.6.4-52-bigsmp/build SUBDIRS=/home/chips/ZD1211LnxDrv_2_6_0_0 modules
make[3]: Entering directory `/usr/src/linux-2.6.4-52'
CHK include/linux/version.h
/bin/sh: line 1: cpp: command not found
UPD include/linux/version.h
*** Warning: Overriding SUBDIRS on the command line can cause
*** inconsistencies
HOSTCC scripts/basic/fixdep
scripts/basic/fixdep.c:97: sys/types.h: No such file or directory
scripts/basic/fixdep.c:98: sys/stat.h: No such file or directory
scripts/basic/fixdep.c:99: sys/mman.h: No such file or directory
scripts/basic/fixdep.c:100: unistd.h: No such file or directory
scripts/basic/fixdep.c:101: fcntl.h: No such file or directory
scripts/basic/fixdep.c:102: string.h: No such file or directory
scripts/basic/fixdep.c:103: stdlib.h: No such file or directory
scripts/basic/fixdep.c:104: stdio.h: No such file or directory
In file included from /usr/lib/gcc-lib/i386-unknown-linux/2.95.3/include/syslimits.h:7,
from /usr/lib/gcc-lib/i386-unknown-linux/2.95.3/include/limits.h:11,
from scripts/basic/fixdep.c:105:
/usr/lib/gcc-lib/i386-unknown-linux/2.95.3/include/limits.h:117: limits.h: No such file or directory
scripts/basic/fixdep.c:106: ctype.h: No such file or directory
scripts/basic/fixdep.c:107: netinet/in.h: No such file or directory
make[4]: *** [scripts/basic/fixdep] Error 1
make[3]: *** [scripts_basic] Error 2
make[3]: Leaving directory `/usr/src/linux-2.6.4-52'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/home/chips/ZD1211LnxDrv_2_6_0_0'
make[1]: *** [both] Error 2
make[1]: Leaving directory `/home/chips/ZD1211LnxDrv_2_6_0_0'
make: *** [all] Error 2

I don't really have any idea what this means, if anyone can help it would be greatly appreciated.

Thanks all

Yoinker

Artanicus 05-08-2006 11:55 AM

Id say youre missing gcc, probably also g++ ..
You might want to consider upgrading directly to SuSE 10.0 or 9.3, 9.1 is getting a bit old already (:

yoinker 05-08-2006 12:14 PM

Hi Artanicus

Thanks for your reply I did download and install gcc, or so I thought, what is g++, and what would I look for to get it, I tried a search on pbone, but didn't actually see anything that said g++. Would upgrading cure this problem ?


again, thanks for replying.

yoinker


All times are GMT -5. The time now is 10:33 AM.