Welcome to the most active Linux Forum on the web.
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 03-13-2007, 11:37 AM   #1
Registered: Apr 2005
Location: Ontario, Canada
Distribution: Ubuntu 10.10
Posts: 31

Rep: Reputation: 15
Need help getting MIDI sound to work (Ubuntu Edgy)

I posted this in the Ubuntu forum, but no response to date. Maybe someone here can help me?
When I run Timidity or Kmidi, I get a message indicating I don't have a "Sequencer" device. I don't have a clue how to install one.

Here is what I get from Timidity:
bryan@ubuntuPentium:~$ timidity -iA -B2,8 -Os &
[1] 6111
bryan@ubuntuPentium:~$ Requested buffer size 2048, fragment size 1024
ALSA pcm 'default' set buffer size 7524, period size 3760 bytes
TiMidity starting in ALSA server mode
ALSA lib seq_hw.c:457snd_seq_hw_open) open /dev/snd/seq failed: No such file or directory
error in snd_seq_open

With Kmidi I get an error message:
"Could not open /dev/sequencer.
Probably there is another program using it."

Any takers on this one?

Thanks, Bryan

PS - My (Ubuntu) Edgy install is on a P4. The sound system works fine - playing CD's, MP3's, sounds in browsers, etc. Just MIDI seems to be problematic. Also, MIDI works just fine under XP.
Old 03-16-2007, 01:22 AM   #2
LQ Guru
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Rep: Reputation: 555Reputation: 555Reputation: 555Reputation: 555Reputation: 555Reputation: 555
Sounds like you need to see if a) you have a module available for your midi onboard device, and b) if there is, make sure the module is loaded, and if it isn't loaded or compiled, you need to load or compile it.
As you are using alsa, you could use (in a console) the command ALSAMIXER, and see if there is a control(s) on the mixer panel for the midi channel/device, make sure it is activated there.
If you change anything in the mixer, then after you exit, you must use ALSACTL STORE to save the settings.
typing LSMOD in a terminal will tell you what modules you have loaded.
If you don't see one like "alsa_snd_seq" or something like that, then the sequencer is not loaded.
I am not too familiar with Ubuntu-Edgy, but on my system (Slackware) I have a modules-2.6.20 file in my /etc directory, which can be used to load or 'modplug' kernel modules during boot. If such a file exists on your system (in the /etc folder) search it for the needed sequencer module for your device, and uncomment the device line so it will load during boot.
Ubuntu may not have such files, so you will need to skip this step.
If there is a module compiled but not loaded, try typing MODPROBE ALSA_SND_SEQ (for 2.6 kernel) or INSMOD ALSA_SND_SEQ (2.4 kernels) and see if it will load.
As a last resort, I would venture a guess that you may need to enable support for the necessary midi device in the kernel, because it isn't there yet, in which case you would have to custom-config a kernel with the needed support.
It isn't as bad as it sounds, but if this gets you anywhere for starters, please post your findings and someone wll try to help further.

Last edited by GrapefruiTgirl; 03-16-2007 at 01:24 AM.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
5.1 surround sound nforce 2 ubuntu edgy kernel_geek Linux - Hardware 1 03-04-2007 08:57 AM
Need help getting MIDI sound to work (EDGY) VA3OG Ubuntu 0 02-23-2007 01:39 PM
Ubuntu/Kubuntu Dapper/Edgy dosen't work after os installation Kanesoban Linux - Software 0 01-04-2007 01:48 PM
Help!! chown oss, and now I have NOT sound at all in Ubuntu Edgy fabricio Ubuntu 1 11-06-2006 02:37 AM
midi / synth sound with SIS7012 aka Intel i8x0 onboard sound card does not work wahwah Linux - Hardware 1 11-10-2003 06:25 PM > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 10:49 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration