LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   ndiswrapper - going in circles (https://www.linuxquestions.org/questions/linux-newbie-8/ndiswrapper-going-in-circles-614800/)

Miketsho 01-19-2008 01:34 PM

ndiswrapper - going in circles
 
I am tring to install ndiswrapper on Fedora Core 5 system(2.6.15-1.2054_FC5 i686). I have installed:
kernel-devel-2.6.15-1.2054_FC5.i686.rpm
and
kernel-2.6.15-1.2054_FC5.src.rpm (see below).

But when I try to install ndiswrapper I get the following error: "Can't find kernel build files in /lib/modules/2.6.15-1.2054_FC5smp/build;"

---------------- Monitor Output and comments--------------------

[root@localhost ~]# uname -rm
2.6.15-1.2054_FC5 i686

First, I installed:
kernel-devel-2.6.15-1.2054_FC5.i686.rpm

No errors reported.

Next I installed:
kernel-2.6.15-1.2054_FC5.src.rpm

No errors reported.

Next I did a rpmbuild:
rpmbuild -bp --target=$(uname -m) /usr/src/redhat/SPECS/kernel-2.6.spec

No errors reported

Next I installed ndiswrapper-1.23

No errors reported

then I changed directories to the new ndiswrapper-1.23
and following direction I did the following:

[root@localhost ndiswrapper-1.23]# make uninstall

No errors reported

Next I did a 'make' with the following results:

[root@localhost ndiswrapper-1.23]# make
make -C driver
make[1]: Entering directory `/root/ndiswrapper-1.23/driver'
Can't find kernel build files in /lib/modules/2.6.15-1.2054_FC5smp/build;
give the path to kernel build directory with
KBUILD=<path> argument to make
make[1]: *** [prereq_check] Error 1
make[1]: Leaving directory `/root/ndiswrapper-1.23/driver'
make: *** [all] Error 2
[root@localhost ndiswrapper-1.23]#

---------------------End of output and comments------------

I have been working on this for about 3 days and I have run out of ideas. Did I miss something? If some one could help me with this I would greatly appreciate your help. I will be glad to send any info required. Thank you.

Mike Thompson

Lenard 01-19-2008 05:31 PM

You need to specify where the kernel-devel files are, they are not in the default location of /usr/src/linux-<version-number_here> but more like kernels/2.6.15-1.2054_FC5-i386

FYI: Fedora Core 5 is no supported, and your kernel is really out of date even for FC5 please update
FYI: ndiswrapper-1.23 is also way out of date

See: http://www.linuxquestions.org/questi...-linux-524948/

http://ndiswrapper.sourceforge.net/joomla/

Miketsho 01-20-2008 08:50 AM

Lenard,
Thank you for your insite. I had planned to upgrade to FC8 but wanted to try to get FC5 running first. I will upgrade today and hope the support group can help me resolve my problems. Thanks again.

Mike Thompson


All times are GMT -5. The time now is 09:34 AM.