LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   NDIS Wrapper and Ubuntu n00b Question (https://www.linuxquestions.org/questions/linux-newbie-8/ndis-wrapper-and-ubuntu-n00b-question-369111/)

nan0click 10-02-2005 02:31 PM

NDIS Wrapper and Ubuntu n00b Question
 
First let me say that I am a major n00b when it comes to using Linux, and so I figured I should post here because I am having problems with the command "make" when I try to install NDIS Wraper. Here is a post I put in another forum asking for help, and maybe this one will give me the help I seek too.

-------

I have done some searching on google and here about using NDIS Wrapper and Ubuntu. I used the tutorial off of the ubuntu install wiki. I get to the "make" part, and it says:

Code:

make -C driver
make[1]: Entering dierctory `/home/mike/Desktop/ndiswrapper-1.4rc3/driver'
Can't find kernel sources in /lib/modules/2.6.10-5-386/build;
 give the path to kernel sources with KSRC=<path> argument to make
make[1]: *** [prereq_check] Error 1
make[1]: Leaving directory `/home/mike/desktop/ndiswrapper-1.4rc3/driver'
make: *** [all] Error 2

using sudo doesnt fix anything either.

also, in the tutorial, it says to use the command
Code:

ln -s /usr/src/linux-<kernel-version> /lib/modules/VERSION/build
but there is no directory called linux-kernel-version (yes i know its numbers, not the literal word) and there is no folder called build in my /lib/modules/VERSION/ directory

Thank you for all the help you can offer.

otchie1 10-02-2005 07:12 PM

The problem is not with make but with ubuntu. In common witha lot of distros these days it does not routinely copy the source code for the kernel on to your hard drive. Hence the
Quote:

Can't find kernel sources in /lib/modules/2.6.10-5-386/build;
give the path to kernel sources with KSRC=<path> argument to make
problem.

The fix is as easy as firing up synaptic package manager via your graphical desktop and using it to get & install the sources for you...details are in the Ubuntu install howto under 'extras' IIRC but in any case 'install Ubuntu sources' in google should do nicely.

nan0click 10-02-2005 09:55 PM

I went into synaptic and installed the Linux-Header-etc files and then tried the command using what I think was the appropriate directories

ln -s /usr/src/linux-headers-2.6.10-5 /lib/modules/2.6.10-5-386/build

it seemed to go through correctly and make distclean worked i guess, but when I ran "make" it paused than scrolled a lot of stuff and finally stopped and says something about /bash/sh: gcc: command not found, and also it gives me Error 2 and Error 27.

Please contact me on Aim or MSN:

AIM: nan0click

MSN: nan0click at dgsolution dot net

btmiller 10-02-2005 09:58 PM

You'll need to install gcc -- apt-get install gcc would do it (or go through Synaptic) similar to how otchie1 told you to install the kernel sources.

nan0click 10-02-2005 10:03 PM

Ok, that went through fine, and now when I do it, I get a lot of things ending in "Error 2" I think this is bad. If I knew what this meant, maybe that would fix it. It normally follows after saying "leaving directory..." At the end, it says "make: *** [all] Error 2"

thanks for everything so far and I'm looking foward to more help,

nan0click


All times are GMT -5. The time now is 04:52 AM.