Review your favorite Linux distribution.
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 10-25-2012, 01:20 PM   #1
LQ Newbie
Registered: Oct 2012
Location: Kitale Kenya
Distribution: Fodora 17
Posts: 1

Rep: Reputation: Disabled
mysql problem

Have just installed mysql on fedora 17 and iam getting the following error when i want to access.
ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: NO)
How do you run PHP on mysql
Old 10-25-2012, 02:58 PM   #2
Senior Member
Registered: Jul 2012
Location: Grenoble, Fr.
Distribution: Sun Solaris, RHEL, Ubuntu, Debian 6.0
Posts: 1,800
Blog Entries: 4

Rep: Reputation: 286Reputation: 286Reputation: 286
Although I am not much familier with mysql, but it may be a problem with execution permissions or ownership. So first mention that how are you accessing it or executing it? What are permissions on executable?
Old 10-25-2012, 04:55 PM   #3
LQ Guru
Registered: Apr 2008
Distribution: PCLinux, Slackware
Posts: 7,541

Rep: Reputation: 1451Reputation: 1451Reputation: 1451Reputation: 1451Reputation: 1451Reputation: 1451Reputation: 1451Reputation: 1451Reputation: 1451Reputation: 1451
How did you install mysql? If you are planning to use php also, you may want to read a LAMP tutorial for Fedora, see the link below:

Have you set a root password for mysql? Did you check to see if mysql is running? Use this command: ps -e | grep my
Old 10-25-2012, 05:51 PM   #4
LQ Newbie
Registered: Oct 2012
Posts: 12

Rep: Reputation: Disabled
I did the same just yesterday - Make sure you install mysql-server, not just mysql, coz somehow I made that really simple mistake....

Also, you need to run the following to set the root user password:

mysqladmin -u root password PASSWORD

Last edited by goodvikings; 10-25-2012 at 05:52 PM. Reason: Added in extra help
Old 10-26-2012, 03:23 AM   #5
Wim Sturkenboom
Senior Member
Registered: Jan 2005
Location: Roodepoort, South Africa
Distribution: Slackware 10.1/10.2/12, Ubuntu 12.04, Crunchbang Statler
Posts: 3,786

Rep: Reputation: 282Reputation: 282Reputation: 282
Make sure you install mysql-server, not just mysql, ...
No doubt, that server is running, else one would not get that specific message.

iam getting the following error when i want to access
Did you specify a password during install (I don't use Fedora so don't know what it asks for)? If so, run the below and it will prompt you for password.
mysql -u root -p


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
postfix +Cyrus SASL authentication problem + pam-mysql+mysql database kibirango Slackware 1 12-25-2012 08:47 AM
[SOLVED] yum install php-mysql create problem to my running mysql database jsaravana87 Linux - Server 1 08-11-2011 03:24 AM
Problem changing mysql uid,gid: mysql start fails gjatute Linux - Newbie 7 02-25-2010 01:38 AM
Problem Starting MySQL on Fresh Fedora 8 Install w/ Yum'd MySQL blong4life Linux - Server 2 07-04-2008 07:44 PM
php-mysql dependancy problem after nitemare mysql upgrade. RHEL4 andrewc Red Hat 1 01-03-2006 04:16 PM > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 06:29 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration