LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   mysql-php-apache problems.. (https://www.linuxquestions.org/questions/linux-newbie-8/mysql-php-apache-problems-374506/)

khuti2005 10-18-2005 09:44 PM

mysql-php-apache problems..
 
hi, ok heres the thing, i installed fedora 2 as webserver with the extra bits for mysql php and apache.. anywho i did it the other day n forgot to add mysql.. but i started the service httpd and typed in localhost on a browser, which worked.. then tested it out with a basic php page. which also worked.. but now.. ive re-installed it with the xtras for mysql.. when i type localhost the default page comes up ok like before.. but as soon as i put in an index page of my own i get, FORBIDDEN you do not have permission etc..

so can anybody help me sort this? im not understandin as for 1.. im signed is as root user! 2 ive set up my basic account to have the user groups of apache. and still neither work. i would really appreciate sum help gettin this set up as i would like to get to work with my coding. so far ive wasted 32 hours approx tryin to set it all up, n im started to lose my cool. so if any1 came help me id reaaaaaaaally appreciate it.

thanks..

khuti

socrates71 10-19-2005 10:08 AM

Sounds like you are uploading a new default with incorrect permissions, probably permission for root. Try changing the owner to apache or nobody, or if that fails try chmod 777 index.html. This should rule out any permission probs...

also, ls -al in the web-root folder and check owners and groups are accessible...

khuti2005 10-19-2005 01:33 PM

hey thanks, it works now :D

but i have another problem lol.. i did a test page with the phpinfo() function which works fine..and mysql has been installed with it properly. ive set up a database n table with data for a test, but when i create the .php page it doesnt show anything. it doesnt come up with a weird error either. do u no what this could b n how i could solve it?.. once i get these to workin together ill b a happy bunny! :)

khuti

socrates71 10-20-2005 08:33 AM

in your php.ini enable all the error functions and try the page again. this should hopefully print out an error message if there is actually an error. alternatively, once you get your blank page, try viewing the source and see what is there, that may help narrow things down a bit.

also have you set the options for apache to process a php page as per php install instructions. also you will need to restart the apache service after making mods to either php.ini or httpd.conf (service httpd restart)

can you post your code here btw?

hth

khuti2005 10-20-2005 03:28 PM

its ok. ive got it all sorted now.. thanks tho. really do appreciate it. just got sum networking things to solve now :D

lol bit at a time! but i am well chuffed anywho at least i can get coding again! thanks to all that posted.

khuti


All times are GMT -5. The time now is 09:31 AM.