LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-13-2017, 09:58 AM   #1
Joe999
LQ Newbie
 
Registered: Oct 2017
Posts: 4

Rep: Reputation: Disabled
my wifi is disable auto ( not connect )


Hi guys i've a probleme, my wifi is disable auto ( not connect ) when the pc is restart or shut down, i'm tired for command always
service netwok-manager restart.
Please help me

Last edited by Joe999; 10-13-2017 at 01:25 PM.
 
Old 10-13-2017, 11:22 AM   #2
rtmistler
Moderator
 
Registered: Mar 2011
Location: USA
Distribution: MINT Debian, Angstrom, SUSE, Ubuntu, Debian
Posts: 9,314
Blog Entries: 13

Rep: Reputation: 4370Reputation: 4370Reputation: 4370Reputation: 4370Reputation: 4370Reputation: 4370Reputation: 4370Reputation: 4370Reputation: 4370Reputation: 4370Reputation: 4370
Hi Joe999 and welcome to LQ.

Suggest you review the following links to help improve your question to aid other members in helping you.

Welcome to LQ
Newbie Sticky Thread
 
1 members found this post helpful.
Old 10-13-2017, 11:22 AM   #3
jsbjsb001
Senior Member
 
Registered: Mar 2009
Location: Earth, unfortunately...
Distribution: Currently: OpenMandriva. Previously: openSUSE, PCLinuxOS, CentOS, among others over the years.
Posts: 3,869

Rep: Reputation: 2049Reputation: 2049Reputation: 2049Reputation: 2049Reputation: 2049Reputation: 2049Reputation: 2049Reputation: 2049Reputation: 2049Reputation: 2049Reputation: 2049
Quote:
Originally Posted by Joe999 View Post
Hi guys i've a probleme, my wifi is disable auto ( not connect ) when the pc is restart or shut down, i'm tired for command always
service netwok-manager restart.
Please help me
You need to tell us a lot more than that, for us to be able to help.

See this: https://www.linuxquestions.org/quest...#faq_lqwelcome

And post more details about your system.
 
1 members found this post helpful.
Old 10-13-2017, 12:55 PM   #4
jamison20000e
Senior Member
 
Registered: Nov 2005
Location: ...uncanny valley... infinity\1975; (randomly born:) Milwaukee, WI, US( + travel,) Earth( I wish,) END BORDER$!◣◢┌∩┐ Fe26-E,e...
Distribution: any GPL that works well on my cheapest; has been KDE or CLI but open... http://goo.gl/NqgqJx &c ;-)
Posts: 4,390
Blog Entries: 3

Rep: Reputation: 1436Reputation: 1436Reputation: 1436Reputation: 1436Reputation: 1436Reputation: 1436Reputation: 1436Reputation: 1436Reputation: 1436Reputation: 1436
Quote:
Today, 11:22 AM
^x2

The title could be more helpful to people who know how to help with networking and not just "you," can edit this by hitting "Edit" then "Go Advanced?"

Have fun!
 
1 members found this post helpful.
Old 10-13-2017, 01:56 PM   #5
JeremyBoden
Senior Member
 
Registered: Nov 2011
Location: London, UK
Distribution: Debian
Posts: 1,885

Rep: Reputation: 465Reputation: 465Reputation: 465Reputation: 465Reputation: 465
Quote:
Originally Posted by Joe999 View Post
Hi guys i've a probleme, my wifi is disable auto ( not connect ) when the pc is restart or shut down, i'm tired for command always
service netwok-manager restart.
Please help me
This is a wild-guess, off-the-cuff response based on zero information:-
Have you tried
Code:
sudo service network-manager restart
Note that netwok-manager is not the correct spelling.

This is not a proper fix, since your wifi should automatically connect without any user intervention.
 
1 members found this post helpful.
Old 10-13-2017, 02:38 PM   #6
jamison20000e
Senior Member
 
Registered: Nov 2005
Location: ...uncanny valley... infinity\1975; (randomly born:) Milwaukee, WI, US( + travel,) Earth( I wish,) END BORDER$!◣◢┌∩┐ Fe26-E,e...
Distribution: any GPL that works well on my cheapest; has been KDE or CLI but open... http://goo.gl/NqgqJx &c ;-)
Posts: 4,390
Blog Entries: 3

Rep: Reputation: 1436Reputation: 1436Reputation: 1436Reputation: 1436Reputation: 1436Reputation: 1436Reputation: 1436Reputation: 1436Reputation: 1436Reputation: 1436
Quick search found: https://unix.stackexchange.com/quest...er-hibernating
 
Old 10-13-2017, 03:41 PM   #7
Joe999
LQ Newbie
 
Registered: Oct 2017
Posts: 4

Original Poster
Rep: Reputation: Disabled
Of course, but when i restart the pc, the some process :/ Wifi Disable again
 
Old 10-13-2017, 05:36 PM   #8
jamison20000e
Senior Member
 
Registered: Nov 2005
Location: ...uncanny valley... infinity\1975; (randomly born:) Milwaukee, WI, US( + travel,) Earth( I wish,) END BORDER$!◣◢┌∩┐ Fe26-E,e...
Distribution: any GPL that works well on my cheapest; has been KDE or CLI but open... http://goo.gl/NqgqJx &c ;-)
Posts: 4,390
Blog Entries: 3

Rep: Reputation: 1436Reputation: 1436Reputation: 1436Reputation: 1436Reputation: 1436Reputation: 1436Reputation: 1436Reputation: 1436Reputation: 1436Reputation: 1436
And, then it works when you restart it?


Depending on desktop and distro or just in general you can run startup scripts\commands.


Or, maybe look into the startup* logs?
 
Old 10-14-2017, 03:18 AM   #9
AwesomeMachine
LQ Guru
 
Registered: Jan 2005
Location: USA and Italy
Distribution: Debian testing/sid; OpenSuSE; Fedora; Mint
Posts: 5,513

Rep: Reputation: 1009Reputation: 1009Reputation: 1009Reputation: 1009Reputation: 1009Reputation: 1009Reputation: 1009Reputation: 1009
It sound like a problem with the wireless firmware reload during wakeup from suspend. You can make customizations to the suspend config file (/etc/swsusp.conf) to unload and reload the wireless driver, which should reload the firmware correctly.
 
Old 10-14-2017, 05:32 AM   #10
ondoho
LQ Addict
 
Registered: Dec 2013
Posts: 17,235
Blog Entries: 10

Rep: Reputation: 5160Reputation: 5160Reputation: 5160Reputation: 5160Reputation: 5160Reputation: 5160Reputation: 5160Reputation: 5160Reputation: 5160Reputation: 5160Reputation: 5160
maybe op just hasn't figured out how to tell networkmanager to autoconnect?

edit:
dear op, if you want real help, you have to provide real info.
read the first link in my signature.
 
Old 10-14-2017, 06:42 AM   #11
Joe999
LQ Newbie
 
Registered: Oct 2017
Posts: 4

Original Poster
Rep: Reputation: Disabled
Networkmanager not auto connecting on reboot
Thanks
Now is Fixed
 
Old 10-14-2017, 07:52 AM   #12
jamison20000e
Senior Member
 
Registered: Nov 2005
Location: ...uncanny valley... infinity\1975; (randomly born:) Milwaukee, WI, US( + travel,) Earth( I wish,) END BORDER$!◣◢┌∩┐ Fe26-E,e...
Distribution: any GPL that works well on my cheapest; has been KDE or CLI but open... http://goo.gl/NqgqJx &c ;-)
Posts: 4,390
Blog Entries: 3

Rep: Reputation: 1436Reputation: 1436Reputation: 1436Reputation: 1436Reputation: 1436Reputation: 1436Reputation: 1436Reputation: 1436Reputation: 1436Reputation: 1436
Question

How you do it plus others may find that helpful?
 
1 members found this post helpful.
Old 10-14-2017, 08:45 AM   #13
Joe999
LQ Newbie
 
Registered: Oct 2017
Posts: 4

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by jamison20000e View Post
How you do it plus others may find that helpful?
Please these :
https://www.linuxquestions.org/quest...fi-4175582345/

https://ubuntuforums.org/showthread.php?t=2208333

https://www.google.com/search?q=Netw...hrome&ie=UTF-8
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 07:57 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration