-   Linux - Newbie (
-   -   my USB pen drive plug and play stopped all of a sudden (

nkd 09-19-2007 07:53 AM

my USB pen drive plug and play stopped all of a sudden
hi all,
I am using RHEL 4.0
I could just plug in my pen drive and it was detected and auto mounted \
in /media and a shortcut was available on the desktop right away.
All of a sudden it stopped. I can still use it after I mount it with
mount -t vfat /dev/sda /mnt command
I do not know what went wrong or if I did something wrongly.
Can someone help me out to restore things

Samotnik 09-20-2007 02:24 PM

After umounting check dmesg for errors related with this device.

nkd 09-20-2007 11:04 PM

thanks Samotnik,
I will give that a try and let you know what it showed me.
Can you just tell me what to look for in it.
Another issues is :
I have a HP Pavilion dv1000 laptop. I loaded RH 9.0 on it.
It won't detect any usb port and the usb mouse is unusable.
I checked out the /dev dir there are no sda* files in it. Also fdisk -l doesnot show any such device.
I downloaded the kernel and enabled the HID raw support and also the EHCI and OHCI support in them. But when I boot up using this kernel - it still doesnot detect my usb ports !
I know I am doing something wrong :confused: and it is something very basic. Can you help me with this problem.
Thanks again

AceofSpades19 09-20-2007 11:47 PM

RH 9 is really old and that is probably why it doesn't detect usb ports, you might want to try a newer distro

nkd 09-21-2007 05:55 AM

Thanks AceOfSpades19,
But I think it would be really cool to know what is going on under the surface and how to fix things.
You see, I can't really reload a OS allover again - that's not efficient. I tried upgrading the kernel and have a which is the latest stable version and that should have solved the problem - if it is something to do with the vintage of the distro.
I think I am doing something wrong while configuring the kernel. Could it be that I am missing out some type of support ???
Thanks again

james.farrow 09-21-2007 06:33 AM

RH9 is an old distro as previously stated, it is advisable to upgrade it, security reasons alone.
Centos 5 is a direct respin of the latest RHEL. You can get to grips with things under the hood as well.
dmesg and /proc are good places to start!!

nkd 09-23-2007 03:14 PM

Thanks James,
I think you are right with the Centos 5 stuff. can you tell me if I am right - I have upgraded the kernel to , shouldn't that fix the problems about vintage of the distro ????
I frankly donot know whether I am right or wrong ?
Ok I found out something more....
Whenever I umount the device from a terminal only then this problem occurs. If I logout after that or restart the machine the usb device auto detect works fine. It is becoz , of the default mount point defined in the fstab file is used only once by init ... Am I right. So I think if I can ask init to redo the fstab file someway , it should work even if I donot log out..... Will that work ?

All times are GMT -5. The time now is 11:05 PM.