LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   My Ubuntu-Mate 18.04.2 install was wiped out with green horozontal lines (https://www.linuxquestions.org/questions/linux-newbie-8/my-ubuntu-mate-18-04-2-install-was-wiped-out-with-green-horozontal-lines-4175653976/)

ljsejones 05-15-2019 04:13 PM

My Ubuntu-Mate 18.04.2 install was wiped out with green horozontal lines
 
First, some basic machine info:

Asus P5W DH Deluxe 32 bit MB
Intel Core Duo 2.4 E6600 CPU
(CPU soon to be replaced with an Intel Core 2 Extreme QX685 Quad Core 3.0 GHz)
8 GB of RAM
Nvidia GEForce 7950 GT Graphics card
AddOns: USB 3 PCI, 4 port SATA RAID PCIe and Bluetooth Dongle
This machine usually has both CPU and RAM overclocked, but not while installing Systems. I also use a 6 output SATA drive power switcher to switch between Mac OS X, Win. XP, Mint Cinnamon and Win 8.1. It had Win. 10 but I replaced it with Mint Cinnamon 19.1...Win 10 was useless for any of my purposes.

Back around 2005 I played with Red Hat and Yellow Dog, but can’t remember much. At that time, I was doing freelance graphic projects and my customers all used Adobe on Macs, linux wasn’t practical. All my best software requires Mac or XP.
When I was recently looking into Linux it appeared Mint and Ubuntu-Mate were good choices for first timers.

Mint installed perfectly, I was really impressed. Everything except my Cannon scanner worked right out of the box. I decided to also install Ubuntu-Mate 18.04.2 on switch 5 and play with both. With my SATA PCIe card I have 7 internal SATA ports and an external port on the MB, so why not!

On to my problem:
The install was a nogo. The logo screen came up perfectly; but the install screen was covered with green horizontal lines and unreadable. This is the first time I’ve had any graphics problems with this machine, I originally built this comp in 2006. I read that nomodeset was a workaround for this problem in the GRUB2 boot loader but holding down the shift key got me nowhere.

Anyone have any ideas?

michaelk 05-15-2019 05:08 PM

The Intel Core Duo is a 64 bit processor. Is your motherboard part number P5W DH versus D5W DH?

If so the motherboard has PS/2 connectors and assume you are using a USB keyboard. My first guess would be that you need to enable USB legacy support in the BIOS to allow the USB keyboard to work outside of the operating system.

ljsejones 05-15-2019 05:59 PM

Thanks
 
You're right my MB is a P5W. But I'm not sure why the keyboard would effect the video. CPUID identifies the MB as 32 bit, although I'm aware the processor will work on a 64 bit MB. The only issue I've had with I/O devices is Mac OS X doesn't recognize the hub I normally use for my mouse. It does have PS/2 but I haven't seen any PS/2 devices for a long time. I know the Ubuntu-Mate installer is OK because it installed perfectly on an old 2005 vintage Dell Octoplex my kids used to use (this thing has a working floppy drive and CRT monitor), but it has a 3.4 GHz CPU and 4 GBs of good quality RAM so I use it to experiment. By the way, both machines use the same DDR2 Ram. I will make sure the USB is set to legacy.

michaelk 05-15-2019 06:18 PM

The keyboard does not effect the video. Enabling USB legacy support allows you to enter commands in the grub2 boot loader.

grub is a special program that runs before the operating system but does not load any USB drivers. BIOS USB legacy enables the keyboard to work without drivers.

mrmazda 05-15-2019 06:22 PM

Without a picture to look at it's hard to guess, but horizontal lines where they don't belong is a common sign of hardware trouble. This kind of trouble can often be solved by reseating socketed cards. In yours this would most likely be the GeForce card, but RAM likely also could be responsible.

Power also could be a problem. 8-15 years ago a lot of power supplies shipped with cheap junk brand electrolytic capacitors that don't last as long as they should. Inspection of your caps or testing of your PS before replacing your 64bit 65W TDP E6600 with the hungrier 130W TDP QX6850 would be prudent regardless of its brand or output rating. All those goodies on any Asus ... Deluxe motherboard make it rather hungrier than average to start with, before adding RAID and USB3 cards. Mine with E6700 isn't a whole lot different from yours. I replaced its old PS with a 500W Antec 3 months ago, and its 30W TDP ATI gfxcard gets by on a passive heat sink (less power hungry than your 65W TDP 7950).

ljsejones 05-15-2019 07:28 PM

Thanks for the replies, I appreciate it.
 
When I held down the shift key, I got a line that said ďboot:Ē followed by a blinking cursor. It seemed to be asking what partition to boot from. When I do this on my Mint install, I do get the boot loader. The graphics card in the Dell Optiplex is almost the same card, a NVIDIA GEForce 7600 GT. Again no problem installing Ubuntu.

The RAM is new in the machine in question (the original 4 GBs of RAM from my better machine replaced the 1.5 GBs in the Dell). I ran the new memory through a USB MEMTEST stick because I overclocked the RAM a bitÖNo errors overclocked, right now itís on auto. But a power supply problem is a distinct possibility. I actually reseated the card a couple of weeks ago, it was easier to change the BIOS battery with the graphics card removed.

The processor upgrade might or might not happen. I bought two used QX685 CPUs from a computer salvage outfit in China for $35.00 ea, theyíre supposed to arrive at the end of May. I figure I have maybe a 25% chance one will pass a beating from Prime95 CPU tester without triggering an overheat response from Core Temp. If both pass, Iíll be amazed.

I could swap Graphic cards with the Dellís GT7600, and possibly do something to the Ubuntu install to let the GT7950 card work, but that feels a bit Mickey Mouse. If I have a power or Graphics card issue, it should be dealt with. Iím fully formatting a drive on the problem machine so I canít do much right now.

But thanks again for the food for thought.

P.S. One of the things I do to supplement my Social Security is to breath some life back into old tech machines for people without a lot of money. I intend for Linux to play a large part in this endeavor, at least, once I puzzle it out for myself.

mrmazda 05-15-2019 07:38 PM

Quote:

Originally Posted by ljsejones (Post 5995500)
When I held down the shift key, I got a line that said ďboot:Ē followed by a blinking cursor. It seemed to be asking what partition to boot from.

Usually when you see one of those prompts you can use the TAB key to get a list of available options, or one or more function keys to access menu or help screen(s). When you don't respond in (typically short) time, boot will proceed using a default selection.

ljsejones 05-15-2019 09:02 PM

I apologize if my forum etiquette is lacking
 
I generally have many things going on at once so my attention is divided. I mean no disrespect.

The tab key thing is new to me. The F key functions are another unknown. Iím reasonably competent in Mac OS X, and both OS X and Linux are at least cousins, but I really know very little about Linux.

The disk Iím formatting is at 90% so I can use the machine for more than word processing soon. Iíll try a few things you good people have suggested. I may even grab my camera to take a screen shot or two. Iím learning things that I can use laterÖThis is a good thing.

ljsejones 05-16-2019 03:39 PM

I'm back
 
1 Attachment(s)
Hi again all,
I had to put this project on hold for a short time.

What I ended up doing was taking the Ubuntu drive from my main machine and putting it into my old Dell. The Ubuntu install went just fine. I then reinstalled the drive in my main machine…I’m uploading a picture of the same mess I got during my first effort to install. I hope I did this correctly.

I did check to see if my USB was set to legacy; it was set to auto, I reset it to enabled. My Logitech keyboard seems to have a quirk; holding down the right hand shift key---no Grub bootloader. The left shift key gets me into the bootloader. I pressed “E” and got a command list screen. As an experiment, I erased the line that said ‘load_video’ and pressed Ctrl X. No change, but I see it as progress. Baby steps.

I think mrmazda’s suggestion of a power supply problem is probably correct. But even though this machine has five HDDs, only one runs at a time, all others are effectively unplugged. When I was dual booting Mac OS X and Win XP, both drives ran all the time. The DVD-RW drive is not on the SATA selector and available to whatever System is active.

This taught me not to use 10,000 RPM drives, they have a shorter lifespan. I’ve been buying 500GB Seagate Barracudas for $25.00 ea and these get the job done. I reserve SSDs for laptops.

Anyway, let’s imagine I’m looking at the GRUB2 command list screen with Ubuntu fully installed…What do I do now?

mrmazda 05-16-2019 06:35 PM

When you see that mess can you use the E key to edit the stanza in text mode? If you can proceed to boot from edit mode, you should be able to reconfigure Grub to use text mode. As a result of reconfiguration success, on succeeding boots you would see a text screen somewhat like this.

If the E key suggestion doesn't work, you should be able to temporarily swap in some other gfxcard, if you have one, to reconfigure. Graphical Grub seems to be having a problem with your GeForce.

ljsejones 05-16-2019 07:23 PM

Assume I am very slow
 
Most of what you wrote is lost to me. Yes, I can get into E key edit, I simply donít have a clue WHAT to do once I'm there.

Actually I do have a working graphics card I can swap, itís in the machine I loaded the System on this disk on.


ďto reconfigure. Graphical Grub seems to be having a problem with your GeForce.Ē


Alternatively, I can edit this install on the second machine, then return the drive to this machine. The immediate problem isÖI donít know how!!!

Once Iím in the E key edit, Iím running on empty; knowledge-wise.

Iíve run into assumed knowledge in the past many times. I need step-by-step directions the first time through. I donít know how to insert the key and start the engine.

Thanks for responding!

mrmazda 05-16-2019 11:02 PM

https://forum.antergos.com/topic/692...graphical-grub seems to be an appropriate Google result for configuring text Grub in place of graphical Grub.

While in edit mode in the Grub menu in your case nothing should actually be needed but to proceed to boot, as directed by the instruction on that screen. If this somehow manages to fail, you could try again in the E menu, but this time scroll down to the line that begins with linux, remove splash=silent and quiet with the BS or Del key, and append in its place plymouth.enable=0. This should enable a boot that will produce a lot of text messages before your login screen appears.

ljsejones 05-17-2019 02:45 AM

Bye for now, thank you all
 
Microsoft actually did the World a favor with Windows 10, they dumped a trash System on the market. I believe Linux is going to see an upsurge of activity. Personally, I have all the System software I need.

But Iím going to keep evaluating various Linux releases. I have a side activity of helping people with computer problems, I suspect Microsoftís blatant, unapologetically mercenary approach to their customers via Win 10 is going to go very badly.

As I write this, Iím downloading Linux ElementaryOS and ZorinOS. I really tried to sort out the Ubuntu 18.04.2 issue I was having, but the effort has petered out. Iím going to mark this thread as solved because itís time to move on. Actually, my first impression of the Ubuntu System on my other machine was; it didnít feel welcoming like Lime did. It had more of a ĎWell, Iím waiting, get on with it!í feel. (Silly, I know.)

If both ElementaryOS and ZorinOS install well, I may make them button 5 and button 6 on my machine (Iíll need to scare up another SATA laptop drive for button 6, like Iím using for button 5). I have two Seagate Barracudas still sealed in their bags, but my case wonít fit another full size driveÖIíve had worse problems.

I really do thank all of you for trying to help me out, you might well be hearing from me again.

NOTE: I found out my power supply is 550watts, but it is old. I have a 750watt supply in mind to switch to, but doing all that rewiring is a pain.

mrmazda 05-17-2019 04:23 AM

Quote:

Originally Posted by ljsejones (Post 5995983)
NOTE: I found out my power supply is 550watts, but it is old. I have a 750watt supply in mind to switch to, but doing all that rewiring is a pain.

Old power supplies typically become filthy power supplies. If really old, it's probably worth removing to both inspect caps, and to clean. Cleaning might be enough to solve the problem if the problem is power-related.

More advertised power isn't necessarily better. Some claim more than they can supply, others the opposite. Dell's Optiplex tower line's power supplies seem to top out at an advertised 260 watts, but don't seem to mind 4-5 HDs and a power hungry AMD or NVidia gfxcard with multiple connected displays.

ljsejones 05-17-2019 05:21 AM

Thanks
 
Yes, I feel I need to deal with my power supply. But my disposable income on Social Security is only about $150.00 a month and I've overspent by about $30.00 this month. I had to get a better CPU cooler to test the QX685 CPUs, I'm currently using the stock Intel cooler.

By the way, I installed both Linux OSs Elementary and Zorin. Both installs went perfectly. I'm currently typing this response on the Zorin install. I need to do some setup in this System, I'm getting crystal clear text, but it's white on black and a bit hard on my eyes.

I saw your response when I setup my email on this install. I used one of my Seagates, so I can't put my side panel back on until I find a 2.5 inch drive.

But now I still have to do the acid test; which is making sure all drives boot properly. I didn't think I'd ever use button 6, but that's what this drive is on. Now I have a great deal of exploring to do in all 3 Linux Systems. I sort of feel like 6 Systems on one comp is a bit obsessive, but what the hell, now I'm maxed out...But in a good way.

I have little doubt questions will have me back at the forum looking for answers.

Bye for now.


All times are GMT -5. The time now is 05:29 AM.