LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 03-14-2006, 11:02 PM   #1
nurid
LQ Newbie
 
Registered: Feb 2006
Posts: 4

Rep: Reputation: 0
my suse 10 cannot detect mouse


My Suse version History + problems arise when upgrading:

9.0 : this is my first installation. I install minimum xwindow
[everything seeems ok, I use icewm and fvwm, not kde or gnome
because my hdd is limited /double-booted with winxp pro]
- xmms can play
= mouse ok

upgrade to 9.3:
- xmms cannot play
= mouse ok

then upgrade to 10:
- xmms still cannot play
= suse cannot detect my mouse! when I start icewm, the cursor
stands still at the center. The cursor just lives there all time
at the center and it won't move, although I move my mouse.

[Remember, my mouse functions properly when I boot in winxp pro sp2]

My LinuxQuestions.Org are:

1. How to fix my mouse in linux, what part of linux shoud be fixed?
2. What is going on with this kind of trouble?
3. How to make xmms play in my suse 10?

Thanks very much!
 
Old 03-14-2006, 11:09 PM   #2
nadroj
Senior Member
 
Registered: Jan 2005
Location: Canada
Distribution: ubuntu
Posts: 2,539

Rep: Reputation: 58
we need to know your hardware information.

what kind of mouse are you using? how is it connected--ps2 or usb? have you looked on the manufacturers site for a linux driver?

what kind of sound care do you have? have you looked on the manufacturers site for a linux driver?

open the /etc/X11/xorg.conf file in some text editor. scroll down a little ways and look for the mouse input device section.. can you copy and paste that section in your next reply?

edit: woops.. forgot the mouse isnt working so i guess you cant do that! well, you can, with keyboard shortcuts.. but oh well. do this instead:
after you boot suse and login to the desktop, press CTRL + ALT + BACKSPACE to enter the console. type 'less /etc/X11/xorg.conf' instead of using a GUI text editor. instead of copying and pasting (obviously), just write it down somewhere, and type it out in your next post.
after your done that, type 'startx' to go back to your GUI. or type 'sudo su' and [enter], type in your root password, then issue the 'poweroff' or 'shutdown -now' commands to turn the computer off.

Last edited by nadroj; 03-14-2006 at 11:13 PM.
 
Old 03-14-2006, 11:38 PM   #3
nurid
LQ Newbie
 
Registered: Feb 2006
Posts: 4

Original Poster
Rep: Reputation: 0
This is the config file .....

I use Logitec mouse connected to serial port
/ PS2 (?)

It is a two-button mouse with a wheel between the buttons.

I see this code at the bottom of the mouse:

M-SAW90A




#=================================
# /.../
# SaX generated XFree86 config file
# Created on: 2004-03-23T14:55:47+0700.
#
# Version: 4.7
# Contact: Marcus Schaefer <sax@suse.de>, 2002
#
# Automatically generated by [ISaX] (4.7)
# PLEASE DO NOT EDIT THIS FILE!
#
Section "Files"
FontPath "/usr/X11R6/lib/X11/fonts/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/local"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/Type1"
FontPath "/usr/X11R6/lib/X11/fonts/URW"
FontPath "/usr/X11R6/lib/X11/fonts/Speedo"
FontPath "/usr/X11R6/lib/X11/fonts/PEX"
FontPath "/usr/X11R6/lib/X11/fonts/cyrillic"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/Type1"
FontPath "/usr/X11R6/lib/X11/fonts/latin7/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/baekmuk:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/japanese:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/kwintv"
FontPath "/usr/X11R6/lib/X11/fonts/truetype"
FontPath "/usr/X11R6/lib/X11/fonts/uni:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/CID"
FontPath "/usr/X11R6/lib/X11/fonts/ucs/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/ucs/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/ucs/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/hellas/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/hellas/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/hellas/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/hellas/Type1"
FontPath "/usr/X11R6/lib/X11/fonts/misc/sgi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/xtest"
InputDevices "/dev/ttyS0"
InputDevices "/dev/ttyS1"
InputDevices "/dev/ttyS2"
InputDevices "/dev/ttyS3"
InputDevices "/dev/ttyS4"
InputDevices "/dev/ttyS5"
InputDevices "/dev/ttyS6"
InputDevices "/dev/ttyS7"
InputDevices "/dev/ttyS8"
InputDevices "/dev/psaux"
InputDevices "/dev/logibm"
InputDevices "/dev/sunmouse"
InputDevices "/dev/atibm"
InputDevices "/dev/amigamouse"
InputDevices "/dev/atarimouse"
InputDevices "/dev/inportbm"
InputDevices "/dev/gpmdata"
InputDevices "/dev/mouse"
InputDevices "/dev/usbmouse"
InputDevices "/dev/adbmouse"
InputDevices "/dev/input/mice"
InputDevices "/dev/input/event0"
InputDevices "/dev/pointer0"
InputDevices "/dev/pointer1"
InputDevices "/dev/pointer2"
InputDevices "/dev/pointer3"
EndSection

Section "ServerFlags"
Option "AllowMouseOpenFail"
EndSection

Section "Module"
Load "dbe"
Load "type1"
Load "speedo"
Load "freetype"
Load "extmod"
Load "glx"
Load "v4l"
EndSection

Section "InputDevice"
Driver "kbd"
Identifier "Keyboard[0]"
Option "Protocol" "Standard"
Option "XkbLayout" "us"
Option "XkbModel" "pc104"
Option "XkbRules" "xfree86"
EndSection

Section "InputDevice"
Driver "mouse"
Identifier "Mouse[1]"
Option "Buttons" "5"
Option "Device" "/dev/mouse"
Option "Name" "Autodetection"
Option "Protocol" "imps/2"
Option "Vendor" "Sysp"
Option "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
Option "CalcAlgorithm" "CheckDesktopGeometry"
HorizSync 31-48
Identifier "Monitor[0]"
ModelName "SYNCMASTER 4S"
VendorName "SAMSUNG"
VertRefresh 43-75
UseModes "Modes[0]"
EndSection

Section "Modes"
Identifier "Modes[0]"
Modeline "1024x768" 63.04 1024 1128 1232 1328 768 769 772 795
Modeline "800x600" 40.19 800 832 912 1024 600 601 604 623
Modeline "800x600" 47.53 800 840 920 1040 600 601 604 626
Modeline "640x480" 25.10 640 656 720 800 480 481 484 498
Modeline "640x480" 29.84 640 664 728 816 480 481 484 501
EndSection

Section "Screen"
DefaultDepth 24
SubSection "Display"
Depth 15
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 32
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1024x768" "800x600" "640x480"
EndSubSection
Device "Device[0]"
Identifier "Screen[0]"
Monitor "Monitor[0]"
EndSection

Section "Device"
BoardName "GeForce2 MX/MX 400"
BusID "1:0:0"
Driver "nv"
Identifier "Device[0]"
VendorName "NVidia"
EndSection

Section "ServerLayout"
Identifier "Layout[all]"
InputDevice "Keyboard[0]" "CoreKeyboard"
InputDevice "Mouse[1]" "CorePointer"
Option "Clone" "off"
Option "Xinerama" "off"
Screen "Screen[0]"
EndSection

Section "DRI"
Group "video"
Mode 0660
EndSection

#======================================
 
Old 03-14-2006, 11:49 PM   #4
nadroj
Senior Member
 
Registered: Jan 2005
Location: Canada
Distribution: ubuntu
Posts: 2,539

Rep: Reputation: 58
the relevant information is:
Code:
Section "InputDevice"
Driver "mouse"
Identifier "Mouse[1]"
Option "Buttons" "5"
Option "Device" "/dev/mouse"
Option "Name" "Autodetection"
Option "Protocol" "imps/2"
Option "Vendor" "Sysp"
Option "ZAxisMapping" "4 5"
EndSection
which i asked for earlier.. oh well.

sudo to root, change the "protocol" in this file section to "ps2", save the file, and 'startx'.. does it work now?

if it still doesnt work, look in the /dev file for psaux. if it exists, change "Device" section of the file from '/dev/mouse' to '/dev/psaux'.. save, startx.. does it work?

i also asked about the sound card information.. post that as well if you want help with it.

Last edited by nadroj; 03-14-2006 at 11:51 PM.
 
Old 03-15-2006, 12:30 AM   #5
nurid
LQ Newbie
 
Registered: Feb 2006
Posts: 4

Original Poster
Rep: Reputation: 0
I have tried and erred using sax2 tool, and now the (relevant) configuration
changed to this:

Quote:
Section "InputDevice"
Driver "mouse"
Identifier "Mouse[1]"
Option "AutoSoft" "on"
Option "Device" "/dev/input/mice"
Option "Name" "Generic"
Option "Protocol" "Auto"
Option "Vendor" "Auto"
Option "ZAxisMapping" "4 5"
EndSection
and my mouse now works but the wheel become impotent [it cannot be used like
when I was in 9.3 or 9.0 of the suse ]

How to make the wheel of the mouse work?

Thanks.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Not able to detect mouse device simontki Linux - Hardware 2 03-12-2006 06:55 PM
slackware doesn't detect my mouse nick021 Linux - Hardware 2 06-24-2005 02:04 AM
xwindows can't detect the mouse fatblueduck Linux - Software 1 04-20-2005 11:40 PM
my slackbox didn't detect my mouse Paxmaster Linux - Software 2 09-24-2004 04:56 PM
Laptop does not detect my mouse Belize Linux - General 7 09-13-2003 07:40 AM


All times are GMT -5. The time now is 08:51 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration