LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   My spell checker in the browser is checking British instead of US English (https://www.linuxquestions.org/questions/linux-newbie-8/my-spell-checker-in-the-browser-is-checking-british-instead-of-us-english-4175547770/)

Gregg Bell 07-11-2015 05:52 PM

My spell checker in the browser is checking British instead of US English
 
1 Attachment(s)
My spell checker in the browser is checking British English instead of US English. (LibreOffice however is checking US English.) I've been using Mozilla as the browser so I checked the preferences and US English is selected. (see screenshot) Anybody know what might be happening? Thanks.

Aia 07-11-2015 06:23 PM

What you are showing is your preferences for your browser's language. The spelling is a different matter.
By default, firefox has spelling enable for any entry box where you can type more that one line, like when you post in this forum.
Right click on the box to write and you'll see languages as an option on the menu. Make sure it is what you want.
https://support.mozilla.org/en-US/kb...+spell+checker

ardvark71 07-11-2015 06:25 PM

Quote:

Originally Posted by Gregg Bell (Post 5390213)
My spell checker in the browser is checking British English instead of US English. (LibreOffice however is checking US English.) I've been using Mozilla as the browser so I checked the preferences and US English is selected. (see screenshot) Anybody know what might be happening?

Hi Gregg...

Do any of the solutions here or here help? :)

Regards...

Gregg Bell 07-11-2015 06:41 PM

Quote:

Originally Posted by Aia (Post 5390222)
What you are showing is your preferences for your browser's language. The spelling is a different matter.
By default, firefox has spelling enable for any entry box where you can type more that one line, like when you post in this forum.
Right click on the box to write and you'll see languages as an option on the menu. Make sure it is what you want.
https://support.mozilla.org/en-US/kb...+spell+checker

Thanks Aia. That did it. Appreciate it.

---------- Post added 07-11-15 at 06:41 PM ----------

Quote:

Originally Posted by ardvark71 (Post 5390223)
Hi Gregg...

Do any of the solutions here or here help? :)

Regards...

Aia's thing worked, Ardvark, but I'll keep those links you gave me in mind just in case there's complications. Thanks.

Habitual 07-11-2015 06:47 PM

Firefox 27.0.1

I have US Dictionary and it is selected, but both
canceled and cancelled
pass right through. I KNOW I did not "Add to dictionary" for "cancelled".

Code:

ls -1 /opt/firefox/dictionaries/en-US*
/opt/firefox/dictionaries/en-US.aff
/opt/firefox/dictionaries/en-US.dic

and now cancelled
doesn't pass and all I did was install https://support.mozilla.org/en-US/kb...+spell+checker

The plot thickens.

ardvark71 07-11-2015 06:47 PM

Hi Gregg...

Glad you got it fixed. :)

Regards...

Gregg Bell 07-11-2015 06:54 PM

Quote:

Originally Posted by Habitual (Post 5390233)
Firefox 27.0.1

I have US Dictionary and it is selected, but both
canceled and cancelled
pass right through. I KNOW I did not "Add to dictionary" for "cancelled".

Code:

ls -1 /opt/firefox/dictionaries/en-US*
/opt/firefox/dictionaries/en-US.aff
/opt/firefox/dictionaries/en-US.dic

and now cancelled
doesn't pass and all I did was install https://support.mozilla.org/en-US/kb...+spell+checker

The plot thickens.

It's all the Brits' fault! :)


All times are GMT -5. The time now is 09:09 PM.