LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   My Runlevel is in 333 (https://www.linuxquestions.org/questions/linux-newbie-8/my-runlevel-is-in-333-a-734922/)

malickhat 06-23-2009 02:21 AM

My Runlevel is in 333
 
Hi,
I'm a newbie in Linux ,i've installed fedora 10 in my pc and i'm looking to do RHCT ,so for my studies i made a change in differnet run levels from[1-5],unfortunatley instead of typing 3 i mistyped it as 333 without knowing it i saved the inittab and rebooted my system and problem occurs

the error i get is telinit 333 illegal runlevel

and i don't want to format my entire system ,pls help me to get out of this peoblem

Thanks
Linux newbie

acid_kewpie 06-23-2009 02:40 AM

on the grub screen hit e to edit, and add a 1 to the boot options, that'll stick you into runlevel 1 by force and let you change the file.

malickhat 06-23-2009 02:49 AM

Quote:

Originally Posted by acid_kewpie (Post 3583096)
on the grub screen hit e to edit, and add a 1 to the boot options, that'll stick you into runlevel 1 by force and let you change the file.

So you want me to boot in rescue mode with a linux boot cd right.
But can't i do it with some other command line technique

colucix 06-23-2009 02:57 AM

Quote:

Originally Posted by malickhat (Post 3583100)
So you want me to boot in rescue mode with a linux boot cd right.
But can't i do it with some other command line technique

No. He want you to boot in single user mode and modify /etc/inittab from the command line. He never spoke about a boot cd.

kirukan 06-23-2009 02:59 AM

Quote:

Originally Posted by acid_kewpie View Post
on the grub screen hit e to edit, and add a 1 to the boot options, that'll stick you into runlevel 1 by force and let you change the file.
It means single user mode not a rescue mode, instead of 1 you can type the word "single"

malickhat 06-23-2009 03:06 AM

Quote:

Originally Posted by kirukan (Post 3583109)
It means single user mode not a rescue mode, instead of 1 you can type the word "single"

Still i can't figure it out ,in my Pc all i get is a fedora Loading screen ,and i don't know how to go in a single user mode with this ,please assist me with this .

colucix 06-23-2009 03:19 AM

When you power on the PC, the first screen (it should have a blue background in Fedora) is the GRUB screen, which let you choose between two or more different kernels. At that point (and you have a few seconds to do this) press the key "E". This will stop the automatic boot process and let you edit the kernel options. Add "1" at the end of the line containing the default kernel parameters ad the system will boot in single user mode.

kirukan 06-23-2009 03:22 AM

While you are at grub screen press "e". Look for line with kernel parameters and then edit the line and at the end of it put word "single" or ("1" numeric) and press Enter then at this line press "b" to boot into single user mode.

malickhat 06-23-2009 03:43 AM

Quote:

Originally Posted by colucix (Post 3583120)
When you power on the PC, the first screen (it should have a blue background in Fedora) is the GRUB screen, which let you choose between two or more different kernels. At that point (and you have a few seconds to do this) press the key "E". This will stop the automatic boot process and let you edit the kernel options. Add "1" at the end of the line containing the default kernel parameters ad the system will boot in single user mode.

Thanks it works now,thanks all

acid_kewpie 06-23-2009 04:52 AM

meh, how come I get no thanks clicky thing but the guy that repeats exactly what I said does? no fair! Boo hoo...

colucix 06-23-2009 04:57 AM

Quote:

Originally Posted by acid_kewpie (Post 3583170)
meh, how come I get no thanks clicky thing but the guy that repeats exactly what I said does? no fair! Boo hoo...

Uh... you're absolutely right! I feel as I had stolen one thank from you. I can ask Jeremy to transfer one of mine to you...! ;)


All times are GMT -5. The time now is 08:33 AM.