LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-03-2008, 11:35 PM   #1
kenan6346
LQ Newbie
 
Registered: May 2008
Location: Australia
Distribution: openSUSE 10.3 with KDE
Posts: 5

Rep: Reputation: 0
my monitor is offset


Hi, I'm a new user of openSUSE 10.3 with KDE. I've had a bit of experience Ubuntu and Mandriva but I've had the same problem with all of the OS's. I have 2 hard drives, one with openSUSE and one with Windows, and I dual boot them. The problem is that when I go from Windows into openSUSE, the screen is offset to the right and I have to adjust the monitor settings from the buttons on the monitor. The same thing happens when I go back into Windows; the screen is offset to the left and I have to adjust it.

Is there anything I can do with either OS (pref. Linux) that can make it so I don't have to adjust the monitor everytime I boot into a different OS?

Cheers,
Kenan
 
Old 05-03-2008, 11:43 PM   #2
Baldrick65
Member
 
Registered: Aug 2003
Location: Dunedin NZ
Distribution: Mint 13 Cinnamon
Posts: 653

Rep: Reputation: 31
Hi,

My guess would be that you need to make sure that the screen resolution and refresh rates in both OS's are identical (e.g both at 1024x768 70Hz). Hopefully that should fix the problem.

Whether you choose to do that in Linux or Windows is up to you.

HTH
Baldrick
 
Old 05-04-2008, 12:12 AM   #3
kenan6346
LQ Newbie
 
Registered: May 2008
Location: Australia
Distribution: openSUSE 10.3 with KDE
Posts: 5

Original Poster
Rep: Reputation: 0
Unhappy

thanks for replying, I tried what you said but it didn't seem to do much. Is there anything else I could do?
 
Old 05-04-2008, 12:28 AM   #4
Wim Sturkenboom
Senior Member
 
Registered: Jan 2005
Location: Roodepoort, South Africa
Distribution: Slackware 10.1/10.2/12, Ubuntu 12.04, Crunchbang Statler
Posts: 3,786

Rep: Reputation: 282Reputation: 282Reputation: 282
I could adjust my old Matrox card under Windows to move the picture around using some software. So adjust the monitor correctly under Linux, switch to Windows and adjust it there using the provided software.

If above is no option, you need to create modelines and add them to your xorg.conf in Linux. See e.g. http://www.linuxquestions.org/questi...onitor-585602/
 
Old 05-04-2008, 01:05 AM   #5
vortexdevice
LQ Newbie
 
Registered: Dec 2007
Location: Brazil
Distribution: Slackware 13 64-bit
Posts: 25

Rep: Reputation: 15
I had this trouble a long time ago, and as some games were using different modes, my monitor was without room to record new configurations. I solved the issue changing the refresh rate of the windows desktop, so it matched the rate I used in X.
 
Old 05-04-2008, 02:05 AM   #6
Sunfist
Member
 
Registered: Jun 2007
Location: Washington
Distribution: Ubuntu 12.04
Posts: 37

Rep: Reputation: 15
I had that problem when I first installed Linux and it was cause I needed to install the most recent driver for my video card in Linux. I had allready installed it in WinXP, so the two OS were running with different versions of the driver until I upgraded the Linux one.
 
Old 05-04-2008, 08:06 AM   #7
kenan6346
LQ Newbie
 
Registered: May 2008
Location: Australia
Distribution: openSUSE 10.3 with KDE
Posts: 5

Original Poster
Rep: Reputation: 0
sorry I haven't replied all day, I really appreciate all you're help. it's late over here, I'm pretty tired and I've got school and exams to study for, so I'll post back when I try all your suggestions. cheers
 
Old 05-04-2008, 08:13 AM   #8
kenan6346
LQ Newbie
 
Registered: May 2008
Location: Australia
Distribution: openSUSE 10.3 with KDE
Posts: 5

Original Poster
Rep: Reputation: 0
ok I just tried that xvidtune thing from one of the links here, and it worked great. Thanks for all your suggestions, peace
 
Old 05-05-2008, 04:34 AM   #9
kenan6346
LQ Newbie
 
Registered: May 2008
Location: Australia
Distribution: openSUSE 10.3 with KDE
Posts: 5

Original Poster
Rep: Reputation: 0
I'm still having a bit of trouble with this. I got xvidtune to work and I've got a modeline
Code:
"1024x768"     65.00   1024 1064 1200 1344    768  771  777  806 -hsync -vsync
, but I don't know where to put it in the XF86Config file.

My XF86Config file looks like this:
Code:
# /.../
# SaX generated X11 config file
# Created on: 2008-05-04T14:07:49+1000.
#
# Version: 8.1
# Contact: Marcus Schaefer <sax@suse.de>, 2005
# Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
#
# Automatically generated by [ISaX] (8.1)
# PLEASE DO NOT EDIT THIS FILE!
#

Section "Files"
  FontPath     "/usr/share/fonts/misc:unscaled"
  FontPath     "/usr/share/fonts/local"
  FontPath     "/usr/share/fonts/75dpi:unscaled"
  FontPath     "/usr/share/fonts/100dpi:unscaled"
  FontPath     "/usr/share/fonts/Type1"
  FontPath     "/usr/share/fonts/URW"
  FontPath     "/usr/share/fonts/Speedo"
  FontPath     "/usr/share/fonts/PEX"
  FontPath     "/usr/share/fonts/cyrillic"
  FontPath     "/usr/share/fonts/latin2/misc:unscaled"
  FontPath     "/usr/share/fonts/latin2/75dpi:unscaled"
  FontPath     "/usr/share/fonts/latin2/100dpi:unscaled"
  FontPath     "/usr/share/fonts/latin2/Type1"
  FontPath     "/usr/share/fonts/latin7/75dpi:unscaled"
  FontPath     "/usr/share/fonts/baekmuk:unscaled"
  FontPath     "/usr/share/fonts/japanese:unscaled"
  FontPath     "/usr/share/fonts/kwintv"
  FontPath     "/usr/share/fonts/truetype"
  FontPath     "/usr/share/fonts/uni:unscaled"
  FontPath     "/usr/share/fonts/CID"
  FontPath     "/usr/share/fonts/ucs/misc:unscaled"
  FontPath     "/usr/share/fonts/ucs/75dpi:unscaled"
  FontPath     "/usr/share/fonts/ucs/100dpi:unscaled"
  FontPath     "/usr/share/fonts/hellas/misc:unscaled"
  FontPath     "/usr/share/fonts/hellas/75dpi:unscaled"
  FontPath     "/usr/share/fonts/hellas/100dpi:unscaled"
  FontPath     "/usr/share/fonts/hellas/Type1"
  FontPath     "/usr/share/fonts/misc/sgi:unscaled"
  FontPath     "/usr/share/fonts/xtest"
  FontPath     "/opt/kde3/share/fonts"
  InputDevices "/dev/gpmdata"
  InputDevices "/dev/input/mice"
EndSection

Section "ServerFlags"
  Option       "AllowMouseOpenFail" "on"
EndSection

Section "Module"
  Load         "glx"
  Load         "type1"
  Load         "extmod"
  Load         "dbe"
  Load         "freetype"
EndSection

Section "InputDevice"
  Driver       "kbd"
  Identifier   "Keyboard[0]"
  Option       "Protocol" "Standard"
  Option       "XkbLayout" "gb"
  Option       "XkbModel" "microsoftpro"
  Option       "XkbRules" "xfree86"
EndSection


Section "InputDevice"
  Driver       "mouse"
  Identifier   "Mouse[1]"
  Option       "Buttons" "5"
  Option       "Device" "/dev/input/mice"
  Option       "Name" "ImPS/2 Generic Wheel Mouse"
  Option       "Protocol" "explorerps/2"
  Option       "Vendor" "Sysp"
  Option       "ZAxisMapping" "4 5"
EndSection


Section "Monitor"
  Option       "CalcAlgorithm" "XServerPool"
  DisplaySize  304 228
  HorizSync    30-48
  Identifier   "Monitor[0]"
  ModelName    "MEA DV152"
  Option       "DPMS"
  VendorName   "MEA"
  VertRefresh  50-60
  UseModes     "Modes[0]"
EndSection


Section "Modes"
  Identifier   "Modes[0]"
EndSection


Section "Screen"
  DefaultDepth 24
  SubSection "Display"
    Depth      15
    Modes      "1024x768" "800x600" 
  EndSubSection
  SubSection "Display"
    Depth      16
    Modes      "1024x768" "800x600" 
  EndSubSection
  SubSection "Display"
    Depth      24
    Modes      "1024x768" "800x600" 
  EndSubSection
  SubSection "Display"
    Depth      8
    Modes      "1024x768" "800x600" 
  EndSubSection
  Device       "Device[0]"
  Identifier   "Screen[0]"
  Monitor      "Monitor[0]"
EndSection


Section "Device"
  BoardName    "GeForce2 MX/MX 400"
  BusID        "1:0:0"
  Driver       "nv"
  Identifier   "Device[0]"
  Screen       0
  VendorName   "NVidia"
EndSection



Section "ServerLayout"
  Identifier   "Layout[all]"
  InputDevice  "Keyboard[0]" "CoreKeyboard"
  InputDevice  "Mouse[1]" "CorePointer"
  Option       "Clone" "off"
  Option       "Xinerama" "off"
  Screen       "Screen[0]"
EndSection


Section "DRI"
    Group      "video"
    Mode       0660
EndSection

Section "Extensions"
EndSection# /.../
# SaX generated X11 config file
# Created on: 2008-05-04T14:07:49+1000.
#
# Version: 8.1
# Contact: Marcus Schaefer <sax@suse.de>, 2005
# Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
#
# Automatically generated by [ISaX] (8.1)
# PLEASE DO NOT EDIT THIS FILE!
#

Section "Files"
  FontPath     "/usr/share/fonts/misc:unscaled"
  FontPath     "/usr/share/fonts/local"
  FontPath     "/usr/share/fonts/75dpi:unscaled"
  FontPath     "/usr/share/fonts/100dpi:unscaled"
  FontPath     "/usr/share/fonts/Type1"
  FontPath     "/usr/share/fonts/URW"
  FontPath     "/usr/share/fonts/Speedo"
  FontPath     "/usr/share/fonts/PEX"
  FontPath     "/usr/share/fonts/cyrillic"
  FontPath     "/usr/share/fonts/latin2/misc:unscaled"
  FontPath     "/usr/share/fonts/latin2/75dpi:unscaled"
  FontPath     "/usr/share/fonts/latin2/100dpi:unscaled"
  FontPath     "/usr/share/fonts/latin2/Type1"
  FontPath     "/usr/share/fonts/latin7/75dpi:unscaled"
  FontPath     "/usr/share/fonts/baekmuk:unscaled"
  FontPath     "/usr/share/fonts/japanese:unscaled"
  FontPath     "/usr/share/fonts/kwintv"
  FontPath     "/usr/share/fonts/truetype"
  FontPath     "/usr/share/fonts/uni:unscaled"
  FontPath     "/usr/share/fonts/CID"
  FontPath     "/usr/share/fonts/ucs/misc:unscaled"
  FontPath     "/usr/share/fonts/ucs/75dpi:unscaled"
  FontPath     "/usr/share/fonts/ucs/100dpi:unscaled"
  FontPath     "/usr/share/fonts/hellas/misc:unscaled"
  FontPath     "/usr/share/fonts/hellas/75dpi:unscaled"
  FontPath     "/usr/share/fonts/hellas/100dpi:unscaled"
  FontPath     "/usr/share/fonts/hellas/Type1"
  FontPath     "/usr/share/fonts/misc/sgi:unscaled"
  FontPath     "/usr/share/fonts/xtest"
  FontPath     "/opt/kde3/share/fonts"
  InputDevices "/dev/gpmdata"
  InputDevices "/dev/input/mice"
EndSection

Section "ServerFlags"
  Option       "AllowMouseOpenFail" "on"
EndSection

Section "Module"
  Load         "glx"
  Load         "type1"
  Load         "extmod"
  Load         "dbe"
  Load         "freetype"
EndSection

Section "InputDevice"
  Driver       "kbd"
  Identifier   "Keyboard[0]"
  Option       "Protocol" "Standard"
  Option       "XkbLayout" "gb"
  Option       "XkbModel" "microsoftpro"
  Option       "XkbRules" "xfree86"
EndSection


Section "InputDevice"
  Driver       "mouse"
  Identifier   "Mouse[1]"
  Option       "Buttons" "5"
  Option       "Device" "/dev/input/mice"
  Option       "Name" "ImPS/2 Generic Wheel Mouse"
  Option       "Protocol" "explorerps/2"
  Option       "Vendor" "Sysp"
  Option       "ZAxisMapping" "4 5"
EndSection


Section "Monitor"
  Option       "CalcAlgorithm" "XServerPool"
  DisplaySize  304 228
  HorizSync    30-48
  Identifier   "Monitor[0]"
  ModelName    "MEA DV152"
  Option       "DPMS"
  VendorName   "MEA"
  VertRefresh  50-60
  UseModes     "Modes[0]"
EndSection


Section "Modes"
  Identifier   "Modes[0]"
EndSection


Section "Screen"
  DefaultDepth 24
  SubSection "Display"
    Depth      15
    Modes      "1024x768" "800x600" 
  EndSubSection
  SubSection "Display"
    Depth      16
    Modes      "1024x768" "800x600" 
  EndSubSection
  SubSection "Display"
    Depth      24
    Modes      "1024x768" "800x600" 
  EndSubSection
  SubSection "Display"
    Depth      8
    Modes      "1024x768" "800x600" 
  EndSubSection
  Device       "Device[0]"
  Identifier   "Screen[0]"
  Monitor      "Monitor[0]"
EndSection


Section "Device"
  BoardName    "GeForce2 MX/MX 400"
  BusID        "1:0:0"
  Driver       "nv"
  Identifier   "Device[0]"
  Screen       0
  VendorName   "NVidia"
EndSection



Section "ServerLayout"
  Identifier   "Layout[all]"
  InputDevice  "Keyboard[0]" "CoreKeyboard"
  InputDevice  "Mouse[1]" "CorePointer"
  Option       "Clone" "off"
  Option       "Xinerama" "off"
  Screen       "Screen[0]"
EndSection


Section "DRI"
    Group      "video"
    Mode       0660
EndSection

Section "Extensions"
EndSection
Should I change the Monitor section to look like this?
Code:
Section "Monitor"
  Option       "CalcAlgorithm" "XServerPool"
  DisplaySize  304 228
  HorizSync    30-48
  Identifier   "Monitor[0]"
  ModelName    "MEA DV152"
  Option       "DPMS"
  VendorName   "MEA"
  VertRefresh  50-60
  UseModes     "Modes[0]"
  Modeline     "1024x768"     65.00   1024 1064 1200 1344    768  771  777  806 -hsync -vsync
EndSection
Thanks
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
register offset? ashlesha Programming 2 07-28-2006 06:49 PM
offset on lm-sensor? bobbens Linux - Hardware 3 01-20-2005 04:34 PM
Download-Offset possible? Cornholio Linux - Software 0 01-10-2005 04:47 AM
monitor offset moschi Linux - Newbie 3 04-18-2004 12:09 PM
Print-out is offset Cichlid Linux - Hardware 1 05-06-2002 05:54 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 11:06 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration