LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   my / become read-only (https://www.linuxquestions.org/questions/linux-newbie-8/my-become-read-only-104696/)

atesz 10-16-2003 10:21 AM

my / become read-only
 
Hi there,

Since yesterday my laptop cannot be started. There is a lot of message about that the / is read-only and cannot be written.

I have found some others on the net who had the same or similar problem, but no solutions were found. (Having a new install is not a solution I think ).

SuSE 8.2 with Reiserfs worked fine me for some month, so if you have any idea it was a great deal for me to try it out.
(Grub manages the boot and there is a Win98 on another partition too).

Thanx

Mara 10-16-2003 04:21 PM

This may happen when there were serious errors and the filesystem needs to be fixed. You need to boot from a rescue floppy (cdrom) and run fsck on the partition you've got problems with. Before this, run teh following command (it'll check the partition)
reiserfsck /dev/hdaX
Where /dev/hdaX is the partition you've got problems with (if there's WIndows C:, linux / and swap, your / is probably /dev/hda5).

atesz 10-17-2003 12:48 AM

Yes that is what I also think about this ... ,but:

I could start the machine in single mode. After login I could make the fs become rw (mount -o remount /). And it works (for that I hope there is no serious dataloss yet.).

If I make a /fastboot named empty file, the system can be started. I have found the idea in /etc/inid.d/boot.localfs script. But I do not really understand the concept of this ...

I also tried fsck in single mode. If the fs is in read-only, the check runs and no error is found. After making the fs r/w the fsck fails.
I've found reiserfsck in /sbin, which has some option, but I do not understand them yet.

Thanks for your advices.

Mara 10-17-2003 02:15 PM

How does fsck fail in rw mode? Please copy the error messages.

quatsch 10-17-2003 02:21 PM

you can't fsck a filesystem when it is mounted r/w so it is no surprise you get error messages trying to do that.
There might be something wrong with your sysinit script. It's probably something like
/etc/rc.d/rc.sysinit

(you can look at /etc/inittab to find out what the sysinit script is).

Those things are usually very well commented so you should be able to locate the point at which your / filesystem should get remounted r/w - basically after all the stuff about fscking. Maybe you can fix it (do make a backup of your init script first).


All times are GMT -5. The time now is 04:25 AM.