LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-14-2003, 11:27 PM   #1
DesertWolf0132
Member
 
Registered: Oct 2003
Distribution: Mdk 9.2, Slack 10
Posts: 37

Rep: Reputation: 15
Must...not...strangle Mandrake designer


This Mandrake configuration is kicking my...well you get the idea. Everything works fine with the exception of two things:

1. I cannot telnet, ssh, or ping the firewall itself. I have telnet, ssh, and icmp ports open in the /etc/shorewall/rules and they are fully configured.

2. I cannot get Remote Desktop Protocol to work through it. I need to connect from my home machine to the 2k server for maintenance. I have tried RDP connections from XP and Linux and nada.

The box is set to Higher security level (one step below paranoid).

To make things more interesting, when I change the security level to high Draksec won't let me change any of its defaults to secure what I don't need open. I even manually tried to override with the /etc/security/msec/security.conf to no avail.

I need an assist.
 
Old 10-14-2003, 11:34 PM   #2
emetib
Member
 
Registered: Feb 2003
Posts: 482

Rep: Reputation: 33
i know that on my server, if the sec setting is higher, i can't get to it at all. unless i'm actually on that machine. what you will have to do to be able to ssh to it with the higher sec level is to edit the /etc/hosts.allow

sshd: ALL

or you could just put your ip in there, but i would go with the all just incase you have to get there from somewhere else.

at least i think i read your post properly.

cheers.
 
Old 10-14-2003, 11:51 PM   #3
Read_Icculus
Member
 
Registered: Oct 2002
Distribution: MDK 9.2, Debian
Posts: 74

Rep: Reputation: 16
/etc/security/msec/security.conf only is for configuring the security checks that can be run via msec. level.local is for messing with the stuff like "allow_root_login", perms.local is for the various permissions. After you edit these config files you'll need to run something like "msec 2" or "msec 3". If you are going to use the /etc/security/msec files to override the DrakSec rules your DrakSec setting should be normal or default. This doesn't matter since you can edit the config files to get any of the benefits from the various security levels. I imagine that the "higher" security setting might have something to do with some of your problems.

Also setting up shorewall to do everything that you need can somtimes be frustrating if you aren't too experienced with it, if you are running KDE I suggest trying out Guarddog as it is very easy to setup, you can just check some boxes to allow ssh, telnet, ftp, tracert, whatever.
 
Old 10-15-2003, 12:07 AM   #4
DesertWolf0132
Member
 
Registered: Oct 2003
Distribution: Mdk 9.2, Slack 10
Posts: 37

Original Poster
Rep: Reputation: 15
Thanks for the help. I think I figured out the RDP issue (actually a Microsoft problem...shock of all shocks.) I will attempt the /etc/hosts.allow and level.local edits in the morning. Will post how they turn out. Thanks again.
 
Old 10-15-2003, 01:17 AM   #5
rahulsundaram
Member
 
Registered: May 2003
Location: India
Distribution: Knoppix, RedHat
Posts: 246

Rep: Reputation: 30
Hi

An RDP issue with MS is a shock for you?. well thats the least suprising element to me

not being a zealot.

regards

rahul sundaram
 
Old 10-15-2003, 11:02 AM   #6
DesertWolf0132
Member
 
Registered: Oct 2003
Distribution: Mdk 9.2, Slack 10
Posts: 37

Original Poster
Rep: Reputation: 15
Sorry if I wasn't clear in my sarcasm. It is shocking when any product bearing the Microsoft moniker actually works. I should know. I am Microsoft certified. Thank God I can use Linux at home. It still freaks my dad out when I create documents in OpenOffice.org that he can read flawlessly in Word. One day I shall convert him.

Quote:
Originally posted by rahulsundaram
Hi

An RDP issue with MS is a shock for you?. well thats the least suprising element to me

not being a zealot.

regards

rahul sundaram
 
Old 10-15-2003, 01:58 PM   #7
DesertWolf0132
Member
 
Registered: Oct 2003
Distribution: Mdk 9.2, Slack 10
Posts: 37

Original Poster
Rep: Reputation: 15
Shock of all frigging shocks, the RDP works and it looks like the other things will work. I will know for sure when I get to play with the settings after work. Thanks for all the help.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Do you use QT designer? DJOtaku Programming 6 04-24-2005 05:56 PM
DB Designer ewinandar LinuxQuestions.org Member Success Stories 0 11-17-2004 08:59 PM
Qt Designer HELP! dolvmin Linux - Software 1 07-20-2004 11:11 PM
QT Designer Tynoan Linux - Software 0 09-10-2003 03:40 PM
qt designer chandan Programming 4 06-16-2003 04:21 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 09:49 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration