LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Multisync make error (https://www.linuxquestions.org/questions/linux-newbie-8/multisync-make-error-113442/)

Maximilian 11-07-2003 12:15 PM

Multisync make error
 
Hi,
I am trying to install multisync from source but it hangs at some point. Does anyone understand why?

7020CTX:/tmp/0/multisync-0.80 # make
make all-recursive
make[1]: Entering directory `/tmp/0/multisync-0.80'
Making all in src
make[2]: Entering directory `/tmp/0/multisync-0.80/src'
Making all in libversit
make[3]: Entering directory `/tmp/0/multisync-0.80/src/libversit'
make[3]: Nothing to be done for `all'.
make[3]: Leaving directory `/tmp/0/multisync-0.80/src/libversit'
make[3]: Entering directory `/tmp/0/multisync-0.80/src'
source='main.c' object='main.o' libtool=no \
depfile='.deps/main.Po' tmpdepfile='.deps/main.TPo' \
depmode=gcc3 /bin/sh ../depcomp \
gcc -DHAVE_CONFIG_H -I. -I. -I.. -DPACKAGE_DATA_DIR=\""/usr/local/share/multisync"\" -DPACKAGE_LOCALE_DIR=\""/usr/local//locale"\" -DORBIT2=1 -pthread -I/opt/gnome2/include/libgnomeui-2.0 -I/opt/gnome2/include/libgnome-2.0 -I/opt/gnome2/include/libgnomecanvas-2.0 -I/usr/include/gtk-2.0 -I/usr/include/libart-2.0 -I/opt/gnome2/include/gconf/2 -I/opt/gnome2/include/libbonoboui-2.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/orbit-2.0 -I/opt/gnome2/include/libbonobo-2.0 -I/opt/gnome2/include/gnome-vfs-2.0 -I/opt/gnome2/lib/gnome-vfs-2.0/include -I/usr/include/linc-1.0 -I/opt/gnome2/include/bonobo-activation-2.0 -I/usr/include/pango-1.0 -I/usr/X11R6/include -I/usr/include/freetype2 -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/libxml2 -I../include -DPLUGINDIR=\"/usr/local/lib/multisync\" -g -c `test -f 'main.c' || echo './'`main.c
In file included from /opt/gnome2/include/libgnome-2.0/libgnome/libgnome.h:29,
from /opt/gnome2/include/libgnomeui-2.0/gnome.h:5,
from support.h:5,
from main.c:13:
/opt/gnome2/include/libgnome-2.0/libgnome/gnome-program.h:35:18: popt.h: No such file or directory
In file included from /opt/gnome2/include/libgnome-2.0/libgnome/libgnome.h:29,
from /opt/gnome2/include/libgnomeui-2.0/gnome.h:5,
from support.h:5,
from main.c:13:
/opt/gnome2/include/libgnome-2.0/libgnome/gnome-program.h:195: error: parse error before "gnome_program_preinit"
/opt/gnome2/include/libgnome-2.0/libgnome/gnome-program.h:198: warning: data definition has no type or storage class
In file included from /opt/gnome2/include/libgnomeui-2.0/libgnomeui/libgnomeui.h:54,
from /opt/gnome2/include/libgnomeui-2.0/gnome.h:7,
from support.h:5,
from main.c:13:
/opt/gnome2/include/libgnomeui-2.0/libgnomeui/gnome-ui-init.h:50: error: parse error before "poptContext"
make[3]: *** [main.o] Error 1
make[3]: Leaving directory `/tmp/0/multisync-0.80/src'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/tmp/0/multisync-0.80/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/tmp/0/multisync-0.80'
make: *** [all] Error 2

Thanks in advance for the answer.

Maximilian

evil_Tak 11-07-2003 12:42 PM

Quote:

/opt/gnome2/include/libgnome-2.0/libgnome/gnome-program.h:35:18: popt.h: No such file or directory
It wants libpopt (or libpopt-dev).

Maximilian 11-08-2003 08:57 AM

You are my god!!!
By the way is debian better for desktop use than linux SuSE?
Thanks once more for the prompt answer.
Maximilian


All times are GMT -5. The time now is 07:32 AM.