LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-06-2010, 02:12 AM   #1
divyashree
Senior Member
 
Registered: Apr 2007
Location: bbsr,orissa,India
Distribution: RHEL5 ,RHEL4,CENT OS5,FEDORA,UBUNTU
Posts: 1,363

Rep: Reputation: 135Reputation: 135
Multiple NIC Cards


I have 3 NIC . lspci shows the three different models of NIC connected as

Code:
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 02)
03:00.0 Ethernet controller: VIA Technologies, Inc. VT6105/VT6106S [Rhine-III] (rev 8b)
03:01.0 Ethernet controller: Hangzhou Silan Microelectronics Co., Ltd. SC92031 PCI Fast Ethernet Adapter (rev 01)
but the third interface is not detecting by ifconfig, it only shows eth0 and eth1 and not showing eth2 ?

Last edited by Tinkster; 12-06-2010 at 02:15 AM. Reason: replaced PHP w/ CODE tags
 
Old 12-06-2010, 02:39 AM   #2
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,979

Rep: Reputation: Disabled
Hello divyashree,

did you check if the module for the device is loaded?
You may as well execute
Code:
lspci -v
which is more verbose and look at the end of the section for this nic where the module/s should be shown.

Markus
 
Old 12-06-2010, 08:19 AM   #3
divyashree
Senior Member
 
Registered: Apr 2007
Location: bbsr,orissa,India
Distribution: RHEL5 ,RHEL4,CENT OS5,FEDORA,UBUNTU
Posts: 1,363

Original Poster
Rep: Reputation: 135Reputation: 135
Quote:
Originally Posted by markush View Post
Hello divyashree,

did you check if the module for the device is loaded?
You may as well execute
Code:
lspci -v
which is more verbose and look at the end of the section for this nic where the module/s should be shown.

Markus
I have changed my third NIC, still same problem,
this is lspci -vv

PHP Code:
02:00.0 Ethernet controllerRealtek Semiconductor Co., LtdRTL8111/8168B PCI Express Gigabit Ethernet controller (rev 02)
        
SubsystemGiga-byte Technology GA-EP45-DS5 Motherboard
        Control
I/OMemBusMasterSpecCycleMemWINVVGASnoopParErrSteppingSERRFastB2B-
        
StatusCap66MHzUDFFastB2BParErrDEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR-
        
Latency0Cache Line Size32 bytes
        Interrupt
pin A routed to IRQ 58
        Region 0
I/O ports at c000 [size=256]
        
Region 2Memory at e3010000 (64-bitprefetchable) [size=4K]
        
Region 4Memory at e3000000 (64-bitprefetchable) [size=64K]
        [
virtualExpansion ROM at e3020000 [disabled] [size=64K]
        
Capabilities: [40Power Management version 3
                Flags
PMEClkDSID1D2AuxCurrent=375mA PME(D0+,D1+,D2+,D3hot+,D3cold+)
                
StatusD0 PME-EnableDSel=0 DScale=0 PME-
        
Capabilities: [50Message Signalled Interrupts64bitQueue=0/1 Enable+
                
Address00000000fee00000  Data403a
        Capabilities
: [70Express Endpoint IRQ 1
                Device
SupportedMaxPayload 256 bytesPhantFunc 0ExtTag-
                
DeviceLatency L0s <512nsL1 <8us
                Device
AtnBtnAtnIndPwrInd-
                
DeviceErrorsCorrectableNon-FatalFatalUnsupported-
                
DeviceRlxdOrdExtTagPhantFuncAuxPwrNoSnoop-
                
DeviceMaxPayload 128 bytesMaxReadReq 4096 bytes
                Link
Supported Speed 2.5Gb/sWidth x1ASPM L0s L1Port 0
                Link
Latency L0s <512nsL1 <64us
                Link
ASPM Disabled RCB 64 bytes CommClkExtSynch-
                
LinkSpeed 2.5Gb/sWidth x1
        Capabilities
: [b0MSI-XEnableMaskTabSize=2
                Vector table
BAR=4 offset=00000000
                PBA
BAR=4 offset=00000800
        Capabilities
: [d0Vital Product Data
        Capabilities
: [100Advanced Error Reporting
        Capabilities
: [140Virtual Channel
        Capabilities
: [160Device Serial Number 78-56-34-12-78-56-34-12

03
:00.0 Ethernet controllerVIA TechnologiesIncVT6105/VT6106S [Rhine-III] (rev 8b)
        
SubsystemD-Link System Inc Unknown device 1405
        Control
I/OMemBusMasterSpecCycleMemWINVVGASnoopParErrSteppingSERRFastB2B-
        
StatusCap66MHzUDFFastB2BParErrDEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR-
        
Latency64 (750ns min2000ns max), Cache Line Size32 bytes
        Interrupt
pin A routed to IRQ 233
        Region 0
I/O ports at d000 [size=256]
        
Region 1Memory at e2001000 (32-bitnon-prefetchable) [size=256]
        
Capabilities: [44Power Management version 2
                Flags
PMEClkDSID1D2AuxCurrent=0mA PME(D0+,D1+,D2+,D3hot+,D3cold+)
                
StatusD0 PME-EnableDSel=0 DScale=0 PME-

03:01.0 Ethernet controllerHangzhou Silan Microelectronics Co., LtdSC92031 PCI Fast Ethernet Adapter (rev 01)
        
ControlI/OMemBusMasterSpecCycleMemWINVVGASnoopParErrSteppingSERRFastB2B-
        
StatusCap66MHzUDFFastB2BParErrDEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR-
        
Latency64 (5000ns min10000ns max)
        
Interruptpin A routed to IRQ 11
        Region 0
Memory at e2000000 (32-bitnon-prefetchable) [size=256]
        
Region 1I/O ports at d100 [size=256]
        [
virtualExpansion ROM at 80000000 [disabled] [size=128K]
        
Capabilities: [50Power Management version 2
                Flags
PMEClkDSID1D2AuxCurrent=375mA PME(D0-,D1+,D2+,D3hot+,D3cold+)
                
StatusD0 PME-EnableDSel=0 DScale=0 PME-
        
Capabilities: [60Vital Product Data 

It's showing the three NICs but while ifup eth2 ,its saying device not seeme to be present,delaying intialization.
 
Old 12-06-2010, 09:57 AM   #4
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,979

Rep: Reputation: Disabled
Well, if the device is not present in the output of ifconfig it means that there is a driver missing.
The driver is already in the kernelsources and the modulename is sc92031, you may try
Code:
modprobe sc92031
if this doesn't work, you'll have to rebuild your kernel.

Markus
 
Old 12-06-2010, 11:27 AM   #5
divyashree
Senior Member
 
Registered: Apr 2007
Location: bbsr,orissa,India
Distribution: RHEL5 ,RHEL4,CENT OS5,FEDORA,UBUNTU
Posts: 1,363

Original Poster
Rep: Reputation: 135Reputation: 135
Quote:
Originally Posted by markush View Post
Well, if the device is not present in the output of ifconfig it means that there is a driver missing.
The driver is already in the kernelsources and the modulename is sc92031, you may try
Code:
modprobe sc92031
if this doesn't work, you'll have to rebuild your kernel.

Markus
I already compilled and insert the module of sc92031, but in ifconfig -a , a _tmp interface is showing and not showing as eth2.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Various xorg.conf examples for using (multiple) cards + (multiple) monitors GrapefruiTgirl Linux - Hardware 5 09-01-2009 10:22 PM
how to mount nfs for higher data tranfer rate with multiple NIC cards. vishwanath.m.g Linux - Networking 4 04-03-2007 03:35 AM
Multiple nic cards spaceopera Linux - Networking 1 06-20-2006 11:17 PM
Question about multiple NIC Cards lucktsm Linux - Networking 7 01-06-2006 09:13 AM
Multiple NIC cards - public and private IPs harryinjapan Linux - Networking 2 12-02-2001 05:25 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 11:32 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration