LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-21-2015, 04:00 AM   #1
hokkupi
LQ Newbie
 
Registered: Mar 2015
Posts: 4

Rep: Reputation: Disabled
Multi_Key problems (Ubuntu Gnome 14.10, Finnish layout)


Greetings.

I have a slight problem regarding my right Windows key, which is working as a Multi_Key (Compose).
I'd like it to work as a Super key instead of a Multi_Key since I don't need the latter.
Picture of my keyboard for reference if needed
Xev reports the right Windows key to have a keycode of 134. If you need more information, I'm more than happy to provide.

Thank you for your time.
 
Old 03-21-2015, 06:19 AM   #2
beachboy2
Senior Member
 
Registered: Jan 2007
Location: Wild West Wales, UK
Distribution: Linux Mint 18 MATE, antiX-16.1, MX-16
Posts: 2,145
Blog Entries: 9

Rep: Reputation: 771Reputation: 771Reputation: 771Reputation: 771Reputation: 771Reputation: 771Reputation: 771
hokkupi,

Welcome to LQ.

You have probably looked at these links already:

http://askubuntu.com/questions/19558...and-hyper-keys

https://help.ubuntu.com/community/ComposeKey


I suggest that you look in:

Code:
/usr/share/X11/xkb/rules/base.lst
and look under option for compose, altwin etc and see if there is anything suitable for your requirements.

If there is, then open Terminal:

Code:
gksudo gedit /etc/default/keyboard

Then enter the desired key value between the quotation marks in:

XKBOPTIONS=""

Save the modified file and exit.

Additional information

My Compose key options on a UK keyboard are:

Compose key Position of Compose key
compose:ralt Right Alt
compose:lwin Left Win
compose:lwin-altgr 3rd level of Left Win
compose:rwin Right Win
compose:rwin-altgr 3rd level of Right Win
compose:menu Menu
compose:menu-altgr 3rd level of Menu
compose:lctrl Left Ctrl
compose:lctrl-altgr 3rd level of Left Ctrl
compose:rctrl Right Ctrl
compose:rctrl-altgr 3rd level of Right Ctrl
compose:caps Caps Lock
compose:caps-altgr 3rd level of Caps Lock
compose:102 <Less/Greater>
compose:102-altgr 3rd level of <Less/Greater>
composeaus Pause
composersc PrtSc
compose:sclk Scroll Lock

Under xev, my Right Windows key is 134 and this is the Super key (keycode 134 keysm 0xffec, Super_R), NOT the Compose key .

Your one may in fact be the Compose key as you stated in your post.
Please double-check this.

If your Right Windows key is the Super key then you are okay.

If your Right Windows key is the Compose key, then change it to the Right Alt (AltGr) key by entering compose:ralt in XKBOPTIONS=""

to give

Code:
XKBOPTIONS="compose:ralt"
This will free up the Right Windows key to be used as the Super key.

By the way, all the Finnish keyboards I found looked nothing like your one.

Last edited by beachboy2; 03-21-2015 at 11:01 AM. Reason: additions
 
Old 03-21-2015, 10:29 AM   #3
hokkupi
LQ Newbie
 
Registered: Mar 2015
Posts: 4

Original Poster
Rep: Reputation: Disabled
Sadly that didn't work. However, I found the solution from Debian documentation soon after.

Quote:
# dpkg-reconfigure keyboard-configuration
# reboot now
From here to be precise.
 
Old 03-21-2015, 11:03 AM   #4
beachboy2
Senior Member
 
Registered: Jan 2007
Location: Wild West Wales, UK
Distribution: Linux Mint 18 MATE, antiX-16.1, MX-16
Posts: 2,145
Blog Entries: 9

Rep: Reputation: 771Reputation: 771Reputation: 771Reputation: 771Reputation: 771Reputation: 771Reputation: 771
hokkupi,

I am glad that you fixed it.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Multi_key, xorg.conf & setxkbmap jtwdyp Linux - General 2 04-13-2011 04:22 PM
is there any Keyboard layout switcher in gnome newlinux1995 Linux - Software 2 01-06-2011 06:13 AM
Multi_key not working in Slack-current? BroX Slackware 1 04-17-2007 12:10 PM
keyboard layout: one character missing (Gnome, Ubuntu) bricedebrignaisplage Linux - Desktop 0 03-11-2007 10:58 PM
Editing Gnome Menu Layout neville310 Linux - Newbie 1 02-06-2007 11:07 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 01:47 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration