LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   mplayer rpm (https://www.linuxquestions.org/questions/linux-newbie-8/mplayer-rpm-462966/)

nikhilbalaji 07-11-2006 09:44 AM

mplayer rpm
 
i tried installing mplayer.downloaded the rpm and tried running it.(after promting me to enter root password)it says software info cannot be retrieved.
i downloaded yum too since i read on some site that it aids software installation and updating.do i really need yum?
what do i do?

redhat143 07-11-2006 10:21 AM

Can you plz mention which LInux distribution you use?? Since you mentioned yum I guessed you are using gnome.Once you mention the distro it will be easy to help you.

hazmatt20 07-11-2006 10:28 AM

What does it return when you type
Code:

rpm -qa|grep mplayer
redhat143, yum has nothing to do with gnome, it is Red Hat's package distrobution. Also, he has FC5 next to distrobution. In Fedora, yum is the easiest and most effective way to install programs and update your system. It should be installed by default. You should probably do this:

Code:

yum update
If you've never done it before, it'll probably be several hundred MB.

redhat143 07-11-2006 10:39 AM

I am sorry I didnt look at the distribution shown on the left.
Also sorry for the mistake.I always related yum to gnome in RH and yast2 to KDE in SUSE.Just searched and read about it.Thanks a lot for correcting me.

nikhilbalaji 07-11-2006 10:59 AM

i tried rpm -qa|grep mplayer and nothing happened(did it under root)..
when i tried yum update it says:
loading "installonlyn" plugin
setting up core processes
setting up repositories
cannot find a valid baseurl for repo:core
error:cannot find a valid baseurl for repo:core

i've just started using linux.
so cant make head or tail of it.
what to do?

Dummy-in-Linux 07-11-2006 11:11 AM

Hello Nikhilbalaji,

Download this file

http://farang.pai-nai.com/yum.repos.d.zip

It has all repo know including mirrors, copy the files from this archive into /etc/yum.repos.d and you will have all yum mirrors and base source

hazmatt20 07-11-2006 11:24 AM

There are a lot of third-party repos in that zip file. Just saying.

If rpm -qa|grep mplayer didn't return anything, it isn't installed. Once yum is working you should be able to say
Code:

yum install mplayer
and it should work fine. However, this is a problem with some installations of FC5. I installed FC5 for a few days before going back to FC4 (the last straw was no flash support) and had this problem. Unfortunately, I forgot what I did. If yum gives you the same error after unloading that file, tell us the contents of fedora-core.repo. You can use
Code:

vi /etc/yum.repo.d/fedora-core.repo
or if you don't want a terminal,
Code:

gedit /etc/yum.repo.d/fedora-core.repo


All times are GMT -5. The time now is 12:21 AM.