LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   MPLayer GUI Issues - Please :) (https://www.linuxquestions.org/questions/linux-newbie-8/mplayer-gui-issues-please-34983/)

Slinger 11-09-2002 12:34 PM

MPLayer GUI Issues - Please :)
 
Hello all - i have compiled MPlayer 0.90pre9-1 on a full Red Hat 8.0 installation. MPlayer itself seems to work ok, however I am unable to launch gmplayer. I have installed the gui, the skins and the fonts.... Get the following Error:

*******************************************
Using GNU internationalization
Original domain: messages
Original dirname: /usr/share/locale
Current domain: mplayer
Current dirname: /usr/share/locale


MPlayer 0.90pre9-RPM-3.1 (C) 2000-2002 Arpad Gereoffy (see DOCS)

CPU: Intel Pentium 4 Xeon Foster (Family: 8, Stepping: 2)
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled with RUNTIME CPU Detection - warning, it's not optimal! To get best performance, recompile MPlayer with --disable-runtime-cpudetection
[cfg] read config file: /root/.mplayer/gui.conf
****************************************

I did do as it says and recompile it with the --disable-runtime-cpudetection option. However, that didnt seem to do a thing to help.

Any help in getting this to run is appreciated. I like a lot and had it running fine on my previous machine.

Slinger 11-09-2002 01:51 PM

Well, figured it out so thought I would post what i did.

I ran the ./configure with the --enable-gui and --disable-runtime-cpudetection options. Went better this time, not sure why it didnt before.

Then I was getting errors on no skins installed when I had a bunch in the /usr/share/mplayer/Skin directory. This is a default directory for the skins - for some reason mplayer did not like them there - not a great install procedure, anyways - through some research I copied the Skin directory into /~user~/.mplayer and then it worked fine.

Hope this helps

acid_kewpie 11-09-2002 02:19 PM

teh cpu detect message is NOT an error. Just like the skin messaages are NOT errors. you just have to specifically enable the gui as you found out.


All times are GMT -5. The time now is 06:55 AM.