LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-20-2005, 05:49 PM   #1
koodoo
Member
 
Registered: Aug 2004
Location: a small village faraway in the mountains
Distribution: Fedora Core 1, Slackware 10.0 | 2.4.26 | custom 2.6.14.2, Slackware 10.2 | 11.0, Slackware64-13
Posts: 345

Rep: Reputation: 32
mplayer codecs problem


Hi,

I installed mplayer from mplayer-1.Opre2-3.i686.rpm

It did not have support for .wmv and quicktime files.

How do I add the required codecs?

I downloaded the essential codecs tarball "essential-20050412.tar.bz2"

www1.mplayerhq.hu/MPlayer/releases/codecs/essential-20050412.tar.bz2

and extracted the file.

It gave me a lot of lib*.so. and .dlls

The readme file said to place these codecs in the /usr/local/lib/codecs directory
or the /usr/local/lib/win32 or the /usr/lib/win32 or the /usr/lib/codecs directory

i.e. at any place from where mplayer could read the codecs.

I do not have any of these directories in my system.So could anyone tell me where to place these files so that I can play .wmv and quicktime files.I even created a /usr/lib/codes directory and copied all the files there but it did not work

Can these files be used for xine also?

Thanx in anticipation.
 
Old 05-20-2005, 06:05 PM   #2
Tuttle
Senior Member
 
Registered: Jul 2003
Location: Wellington, NZ
Distribution: mainly slackware
Posts: 1,289

Rep: Reputation: 52
What works for me is:
Code:
mkdir /usr/local/lib/codecs
extract all codecs into it:
Code:
cd /tmp
tar -xvjf /pathto/essential-20050412.tar.bz2
mv ./essential-20050412/* /usr/local/lib/codecs
rmdir ./essential-20050412
then create a link for compatibility:
Code:
* assuming win32 doesn't exist yet *

ln -s /usr/local/lib/codecs /usr/lib/win32
/usr/lib/win32 is the old place for codecs as far as I know.

Last edited by Tuttle; 05-20-2005 at 06:17 PM.
 
Old 05-20-2005, 06:48 PM   #3
koodoo
Member
 
Registered: Aug 2004
Location: a small village faraway in the mountains
Distribution: Fedora Core 1, Slackware 10.0 | 2.4.26 | custom 2.6.14.2, Slackware 10.2 | 11.0, Slackware64-13
Posts: 345

Original Poster
Rep: Reputation: 32
Hi

I created /usr/lib/win32 directory and copied all the codecs there.

xine worked mplayer didn,t

Then I created a /usr/local/lib/codecs directory and also copied the codecs there.
Then I created a symbolic link :
ln -s /usr/local/lib/codecs /usr/lib/win32

mplayer still didn't work. It gave a segmentation fault error :

Code:
[root@localhost tmp]# mplayer sweetlama.wmv
MPlayer 1.0pre2-RPM-3.3.2 (C) 2000-2003 MPlayer Team
 
CPU: Intel Pentium 4/Xeon/Celeron Northwood 2020 MHz (Family: 8, Stepping: 4)
Detected cache-line size is 64 bytes
CPUflags:  MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled for x86 CPU with extensions: MMX MMX2 SSE SSE2
 
Reading config file /etc/mplayer/mplayer.conf
Reading config file /root/.mplayer/config
Reading /root/.mplayer/codecs.conf: Can't open '/root/.mplayer/codecs.conf': No such file or directory
Reading /etc/mplayer/codecs.conf: 61 audio & 157 video codecs
font: can't open file: /root/.mplayer/font/font.desc
font: can't open file: /usr/share/mplayer/font/font.desc
Failed to open /dev/rtc: Device or resource busy (mplayer should be setuid root or /dev/rtc should be readable by the user.)
Using usleep() timing
Can't open input config file /root/.mplayer/input.conf: No such file or directory
Input config file /etc/mplayer/input.conf parsed: 52 binds
 
Playing sweetlama.wmv
Cache fill:  0.00% (0 bytes)    ASF file format detected.
============ ASF Stream group == START ===
 object size = 38
 stream count=[0x2][2]
   stream id=[0x1][1]
   max bitrate=[0x100c5][65733]
   stream id=[0x2][2]
   max bitrate=[0x6f455][455765]
============ ASF Stream group == END ===
VIDEO:  [WMV3]  320x240  24bpp
Clip info:
 comments:
==========================================================================
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
AUDIO: 44100 Hz, 2 ch, 16 bit (0x10), ratio: 8005->176400 (64.0 kbit)
Selected audio codec: [ffwmav2] afm:ffmpeg (DivX audio v2 (ffmpeg))
==========================================================================
vo: X11 running at 1024x768 with depth 24 and 32 bpp (":0.0" => local display)
==========================================================================
Opening video decoder: [dmo] DMO video codecs
Segmentation fault
[root@localhost tmp]#
Any ideas??
Thanx
 
Old 05-20-2005, 07:03 PM   #4
Tuttle
Senior Member
 
Registered: Jul 2003
Location: Wellington, NZ
Distribution: mainly slackware
Posts: 1,289

Rep: Reputation: 52
try executing this as root:

sysctl -w dev.rtc.max-user-freq=1024

then try mplayer again.
If it fixes things then put it in a startup script.
If it doesn't work, try removing then reinstalling the mplayer rpm. You are better off compiling mplayer from source though, more optimized for your system.

edit: put "sysctl -w dev.rtc.max-user-freq=1024" in a startup script anyway
 
Old 05-20-2005, 11:22 PM   #5
morneo
Member
 
Registered: Mar 2005
Location: New York
Distribution: FC3
Posts: 39

Rep: Reputation: 15
Goto: http://ftp3.mplayerhq.hu/MPlayer/releases/codecs/

download: all-20050115.tar.bz2
extract all-20050115.tar.bz2 to /usr/lib/
must have root privileges to do that.
name the folder "all-20050115" to win32
so now you must have a folder /usr/lib/win32 with all the codecs necessary for mplayer.

now try watching the movie again and see if it works. If it doesn't let me know.
 
Old 05-26-2005, 10:25 AM   #6
koodoo
Member
 
Registered: Aug 2004
Location: a small village faraway in the mountains
Distribution: Fedora Core 1, Slackware 10.0 | 2.4.26 | custom 2.6.14.2, Slackware 10.2 | 11.0, Slackware64-13
Posts: 345

Original Poster
Rep: Reputation: 32
Hi,

Sorry guys for replying so very late.
My local LAN was DOWN so could't connect to the internet


Quote:
try executing this as root:

sysctl -w dev.rtc.max-user-freq=1024

then try mplayer again.
If it fixes things then put it in a startup script.
If it doesn't work, try removing then reinstalling the mplayer rpm. You are better off compiling mplayer from source though, more optimized for your system.

edit: put "sysctl -w dev.rtc.max-user-freq=1024" in a startup script anyway
I tried that but to no effect. Mplayer still gave that very same error.
I even uninstalled mplayer and then installed it again from the same package but it still gave the same "segmentation fault" error.


Quote:
Goto: http://ftp3.mplayerhq.hu/MPlayer/releases/codecs/

download: all-20050115.tar.bz2
extract all-20050115.tar.bz2 to /usr/lib/
must have root privileges to do that.
name the folder "all-20050115" to win32
so now you must have a folder /usr/lib/win32 with all the codecs necessary for mplayer.

now try watching the movie again and see if it works. If it doesn't let me know.
I tried this also.
Xine works fine.
Mplayer can play some .wmv files but cannot play some others.It gives that same "segmentation fault" error with those files that it cannot play.



Also mplayer crashes too much :

It says that mplayer was interrupted by signal 11 in module video_decode and also that,
mplayer crashed due to improper use of CPU/FPU/RAM
I even reinstalled mplayer but it still keeps crashing.Think I'll have to upgrade to a newer version.

Thanx again and sorry for replying so late.
 
Old 05-26-2005, 12:22 PM   #7
clausawits
Member
 
Registered: Jun 2001
Posts: 143

Rep: Reputation: 16
Quote:
Originally posted by koodoo
Mplayer can play some .wmv files but cannot play some others.It gives that same "segmentation fault" error with those files that it cannot play.
I'm guessing you've got the same situation I have (when I'm running Fedora Core 2). I believe you're not going to be able to fix it without recompiling mplayer from source (*groan*). Check out this thread:
http://www.linuxquestions.org/questi...16#post1662016
one of my posts in that thread also links to a discussion at this site:
http://sourceforge.net/mailarchive/f...&forum_id=3438

I used the latest SimplyMepis 3.3.1 livecd and was able to play an offending video without crashes using the codecs installed on my FC2 partition (a few steps were required to do that). That reassured me that it's not mplayer, per se, but FC2's package of mplayer.

I plan on just waiting until FC4 is released in a couple weeks, and then I'm going to update to that and see if that resolves the issue. I'm not going to spend my time recompiling mplayer unless I get in the mood to spend some quality time going tourrettes at my computer dealing with libraries, dependencies, build options, non-standard directory names and locations, etc.

Last edited by clausawits; 05-26-2005 at 12:24 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Mplayer codecs Surfmonkey Linux - Newbie 8 12-22-2004 07:32 PM
mplayer codecs mightyer2 Debian 5 08-16-2004 09:37 PM
codecs for mplayer bhupee Linux - Software 1 07-01-2004 03:02 PM
Mplayer codecs LUB997 Linux - Software 3 12-12-2003 04:23 PM
MPlayer Codecs Igman Linux - Software 3 07-27-2003 05:11 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 03:23 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration