LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Mozilla update, now launcher = no function! (https://www.linuxquestions.org/questions/linux-newbie-8/mozilla-update-now-launcher-%3D-no-function-60890/)

jabbermacy 05-20-2003 07:59 PM

Mozilla update, now launcher = no function!
 
Hi guys, (running RH9, new to Linux)

OK, I updated Moz to the latest beta no sweat, but the only way I can launch it is opening a term, navigating to /usr/local/mozilla and doing a 'sh run-mozilla.sh'. I cannot use the launcher button nor can I just type 'mozilla' in a term window. I tried to create a 'link to application', but that's about as clear as mud. If this is inded how to link to the shell script, what exactly needs to go in each option to execute the script when 'dubble click' on the link??? Hey, four days into Linux and this is my FIRST question I cannot figure out myself. Not too shabby ;) (but more coming I'm sure)

THANKS!!!!!!!!!!!!

Tinkster 05-20-2003 08:47 PM

Try to locate the original version ...
remove it
then create a link
ln -s /path/to/new/mozilla /path/to/old/mozilla

That should get you sorted... :)

Btw, it's a bit uncommon to see /usr/local
utilised on a RedHat box ;) ... how did you
install?

Cheers,
Tink

jabbermacy 05-21-2003 07:25 AM

Well, I just used the 'standard' install options for Mozilla. I install everything as 'root' - is that OK? This is ALL new to me, but it's getting there ;)

The thing I still don't understand is how to create a link that will run a shell script! I want to run 'sh run-mozilla.sh' when I click on a link but NOTHING I've tried works!

Tinkster 05-21-2003 07:46 PM

I don't think you need the "sh" in "sh run-mozilla.sh".
If run-mozilla.sh is rwxr-xr-x ...

Cheers,
Tink


All times are GMT -5. The time now is 08:34 PM.