-   Linux - Newbie (
-   -   Mozilla problem (

Boom 01-30-2003 02:44 PM

Mozilla problem
Im having a problem with Mozilla that Ive had before in previous Linux installations.

When I try to launch the program I get an error "Mozilla cannot use the profile "default" because it is in use. Please choose another profile or create a new one.

I dont really care about profiles, I just want the program to work and have all my previous settings. How can I disable this? I dont need multiple profiles, 1 is just fine for me :) Thanks

rshaw 01-30-2003 03:17 PM

mozilla is already running, start 'top' as root and kill all mozilla processes, then start mozilla from your user account.

Boom 01-31-2003 01:45 AM

Thanks got it working. :)

k4zau 02-26-2003 03:04 PM

I'm having the same problem, except I always log in as root. Even after I kill all processes that seem to be related to Mozilla, the profile manager still comes up and it won't let me go back into my old profile because it says it's still in use. I use Mozilla 1.2 (I think 1.0.1 is still installed on the system but it was before, and never caused any trouble) The problem began when Mozilla wouldn't work, and I restarted the computer... when it came back up, this profile crap began. This is making me angry.

Thanks in advance for your help.

Crashed_Again 02-26-2003 09:00 PM

You shouldn't be running Mozilla as root anyway!

k4zau 02-27-2003 02:07 PM

:rolleyes: I know. I don't care. Some insight into the problem would be more effective

Crashed_Again 02-27-2003 04:01 PM

:confused: Well your not going to get any help with that attitude! No really I've had this problem before and I did fix it. Of course your situation may be different but what I did was uninstall the previous version of Mozilla. I think somehow it was using my profile from the old Mozilla when I open up the new Mozilla.

I assume you know how to uninstall it so I won't go into that. Let me know if this is "effective" for you.

k4zau 02-27-2003 04:38 PM

Well, I didn't mean to be a smarta** but I was a bit irked at first.. this was a very frustrating problem. Actually, once I left this site, I decided to take a chance and just uninstall and then reinstall the Mozilla RPM... I saved my bookmark file to another location and then ran the RPM; Mozilla let me put the bookmarks in the new profile folder after restart.

So I guess that's the only way to fix the problem. Thanks for the information, apparently that's the way to go.

jost_d 03-17-2003 09:15 PM

One reason for mozilla to not launch the default profile is the presence of a stale lock file in the profiles directory. The file is usually a link named "lock". Deleting the file should allow you to lauch the default profile again...

- Jost:)

Crashed_Again 03-17-2003 09:29 PM

Where is the profiles directory?

macx11 03-31-2003 02:48 PM

Kill the mozilla-bin process
Inside your home directory is .mozilla. Navigate through default and through the next directory (it'll have a random name). Inside is a link call lock that points to The PID is the mozilla-bin Process ID. Type ps PID replacing the PID with the actual number that came after the colin. Top will not show this process because it's idling and would be at the very bottom of the list. Type kill -9 PID to kill it right away. It'll come back as normal now.

No need to remove:

Linus VanPelt 03-31-2003 03:00 PM

I've noticed that Mozilla will let you open new windows by doing Cntl-N, but if you select Mozilla from a menu or the desktop I get the error message you describe.

AFAIK, this also happens if you are switching from one desktop to another.

Crickit 04-11-2003 10:09 AM

The lock file is what prevents you from creating new instances of Mozilla. I was playing around with the lock file, and this is what I found:

-Everytime you open a new instance of Mozilla, a new lock file is made.
-Everytime a new lock is made, it points to a new PID.
-Deleting the lock file allows you to open 1 new window, then a new lock file is created.
-A lock file is not made if you open a new window using Ctrl+N or File > New > Navigator Window

Maybe this info will come in handy to someone. I'm still trying to find a way around the lock file, myself...

inveigh 05-22-2003 10:06 PM

far and away not the cleanest solution, but I ended up using an alias to clean up the mess:

alias moz 'rm /home/inveigh/.mozilla/default/jraqn4og.slt/lock ; mozilla '

killing the PID as mentioned by macx11 kills the window that created the lock (at least it does for me)

oot 05-26-2003 02:20 PM


I've noticed that Mozilla will let you open new windows by doing Cntl-N, but if you select Mozilla from a menu or the desktop I get the error message you describe.
Try setting your shortcuts to Mozilla to run
mozilla -remote "xfeDoCommand (openBrowser)"

All times are GMT -5. The time now is 07:38 AM.