LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-12-2002, 06:45 PM   #1
XavierP
Moderator
 
Registered: Nov 2002
Location: Kent, England
Distribution: Debian Testing
Posts: 19,192
Blog Entries: 4

Rep: Reputation: 472Reputation: 472Reputation: 472Reputation: 472Reputation: 472
Mozilla not starting in one account


I have recently installed Mandrake 9 and have 3 user accounts - 1 for myself, 1 for my daughter and 1 for my partner. Everything works fine....

We all use Mozilla as our default web browsers and for myself and my daughter clicking the app in either the KDE menu or on the shortcut I added to the taskbar loads up Mozilla. In my partners account clicking the shortcuts does nothing. Mozilla simply will not load (there are no error messages, just the 'wristwatch' symbol and then nothing). In case this was a general browsing error, I checked to see if Galeon and Konqueror had the same problem - they don't, both work fine. Because my girlfriend has gotten used to Mozilla, obviously she qould like this back. She was recently using Enlightenment as her desktop and that was when the problem started (after about 3-4 days of no problems).

Unfortunately, as a newbie, that is the end of my troubleshooting. Is it possible to find the Mozilla 'executable' file (I am guessing that I need to open a console and type'Mozilla' or 'mozilla'). Can anyone help me with recreating the shortcuts if that is the problem?

Many thanks
 
Old 12-12-2002, 06:48 PM   #2
XavierP
Moderator
 
Registered: Nov 2002
Location: Kent, England
Distribution: Debian Testing
Posts: 19,192
Blog Entries: 4

Original Poster
Rep: Reputation: 472Reputation: 472Reputation: 472Reputation: 472Reputation: 472
Update: have just tried running Mozilla from a console in her account - it still failed to start,although Galeon and Kinqueror di start.

Most odd.
 
Old 12-12-2002, 07:05 PM   #3
Ciccio
Member
 
Registered: Nov 2002
Location: Paraguay
Distribution: Mandrake 10
Posts: 573

Rep: Reputation: 30
Ok, the command line to star mozilla in mozilla.

Try running the command (not from a V terminal) using [alt] + [F2] and typing mozilla. if it still doesn't work try running it as another user (or maybe root, not very secure). Check if the link is working (in the properties make sure that the path is corret).

Make sure she didn't modify her env. try adding /usr/bin to the PATH variable

Code:
[user@domain user]$ PATH=/usr:/X11R6/bin:/usr/local/bin:/bin:/usr/bin
[user@domain user]$ export PATH
You could try using another WM like KDE, perhaps it would work.

do you get any error when you start it from a console (or Virtual Teminal)try running
Code:
[user@domain user]$ /usr/bin/mozilla
If that does not work try explaining better your problem.
 
Old 12-12-2002, 07:05 PM   #4
Ciccio
Member
 
Registered: Nov 2002
Location: Paraguay
Distribution: Mandrake 10
Posts: 573

Rep: Reputation: 30
Uh, BTW, Netscape is very similar to mozilla, perhaps taht could be another solution...
 
Old 12-12-2002, 07:26 PM   #5
XavierP
Moderator
 
Registered: Nov 2002
Location: Kent, England
Distribution: Debian Testing
Posts: 19,192
Blog Entries: 4

Original Poster
Rep: Reputation: 472Reputation: 472Reputation: 472Reputation: 472Reputation: 472
Not entirely sure which of the above actions did the job, but Mozilla is back. Thanks.

I tried doing [Alt]+[F2] mozilla - nothing. Did it again running as root - it worked. Tried again as user - nothing. Added /usr/bin to PATH and it still wouldn't work for the user. Opened Mozilla Mail (ok) and Mozilla Addressbook (fine) then tried Mozilla again from the shortcut and it opened.

Whatever worked seems to have worked well - so thanks again.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Log on to a remote windows account when starting a Linux machine bothy Linux - Newbie 3 11-16-2005 05:47 AM
Mozilla and Firefox don't start on user account blkmage Linux - Newbie 6 06-04-2004 06:14 PM
Mozilla user account Riichard Linux - Software 3 11-14-2003 02:13 PM
hotmail account in mozilla Chappy Linux - Software 3 11-01-2003 04:35 AM
Problem installing mozilla with root account.. tarballed Slackware 11 07-19-2003 03:46 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 04:18 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration