LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-21-2006, 07:06 PM   #1
Homerous
LQ Newbie
 
Registered: Jun 2006
Distribution: Suse Linux 10.1
Posts: 6

Rep: Reputation: 0
Moving files beetween Linux and Windows partitions


Hi everybody. I'm a new member very new to Linux and this is my first post.
I have just installed Suse 10.1 on a dual boot system on two different physical disks.
Linux recognizes all my Windows partitions on the first disk, and everything works ok, except two things.
First, I cannot move or save a file from my Linux partition to a Windows partition. When copying a file and trying to paste or move it to a Windows disc I get the following message: "could not make folder/windows/" or "could not write to/windows/" when trying to save it.
Any ideas?
The other problem is that something is probably wrong with the installation of the boot loader and the Linux OS is not visible by the computer during boot time. It goes straight to Windows unless I insert the Suse DVD and choose "boot from cd" and then "boot from hard disc" and finally choose Linux. Can I fix that or do I have to reinstall Linux?
Thanks in advance.
 
Old 06-21-2006, 07:15 PM   #2
pljvaldez
LQ Guru
 
Registered: Dec 2005
Location: Somewhere on the String
Distribution: Debian Wheezy (x86)
Posts: 6,094

Rep: Reputation: 271Reputation: 271Reputation: 271
1) Many things can be wrong when trying to write to the Windows partition. First and foremost is that if you have 2000 or XP, the filesystem is NTFS, which linux doesn't write (normally) because it's not very reliable (i.e. you could seriously hose your windows partition). Typically you share things between Windows and linux by using a separate FAT32 partition. If you're having problems with that, you probably just need to modify you /etc/fstab file a bit to make it work.

2) It seems like the bootloader didn't install to the master boot record of the windows disk (either by your choice or otherwise). Now you have a decision to make: (1)swap the disks and fiddle with the grub settings to make the suse disk bootable and the windows disk bootable or (b)boot with your suse CD and then from suse type grub-install /dev/hda as root to install grub to the MBR on the windows disk. Note that /dev/hda is the first IDE hard drive. If you're using SATA hard drives, be sure to use /dev/sda instead. You can tell which you're using by typing fdisk -l from a root command line.
 
Old 06-21-2006, 08:35 PM   #3
Homerous
LQ Newbie
 
Registered: Jun 2006
Distribution: Suse Linux 10.1
Posts: 6

Original Poster
Rep: Reputation: 0
First of all Pljvaldez, thanks for your quick reply.
I formated a large Windows partition from to FAT32 with Partition Magic, and went back to Linux.
The disc and the format change are recognizable by Linux but when I try to see the contents of the disc I get the error "permissions denied". Is there anything I can do to change that?
Thanks
 
Old 06-21-2006, 09:25 PM   #4
pljvaldez
LQ Guru
 
Registered: Dec 2005
Location: Somewhere on the String
Distribution: Debian Wheezy (x86)
Posts: 6,094

Rep: Reputation: 271Reputation: 271Reputation: 271
Can you post your /etc/fstab?

Usually you need a line like
Code:
/dev/hda4  /mnt/shared   vfat   defaults,user,rw,umask=000   0   0
Sometimes you can use uid=yourusername instead if umask doesn't work.
 
Old 06-22-2006, 04:40 AM   #5
Homerous
LQ Newbie
 
Registered: Jun 2006
Distribution: Suse Linux 10.1
Posts: 6

Original Poster
Rep: Reputation: 0
PHP Code:
/dev/hdc7            /                    reiserfs   acl,user_xattr        1 1
/dev/hdc8            /home                reiserfs   acl,user_xattr        1 2
/dev/sda1            /windows/C           ntfs       ro,users,gid=users,umask=00
02
,nls=utf8 0 0
/dev/hdc5            /windows/D           ntfs       ro,users,gid=users,umask=00
02
,nls=utf8 0 0
/dev/sda5            /windows/E           ntfs       ro,users,gid=users,umask=00
02
,nls=utf8 0 0
/dev/hdc6            swap                 swap       defaults              0 0
proc                 
/proc                proc       defaults              0 0
sysfs                
/sys                 sysfs      noauto                0 0
debugfs              
/sys/kernel/debug    debugfs    noauto                0 0
usbfs                
/proc/bus/usb        usbfs      noauto                0 0
devpts               
/dev/pts             devpts     mode=0620,gid=5       0 0
/dev/fd0             /media/floppy        auto       noauto,user,sync      0 0 
dev/hdc5 windows/D is the disc that I have formatted in fat32 and I need to have full write and read access to.
 
Old 06-22-2006, 12:37 PM   #6
pljvaldez
LQ Guru
 
Registered: Dec 2005
Location: Somewhere on the String
Distribution: Debian Wheezy (x86)
Posts: 6,094

Rep: Reputation: 271Reputation: 271Reputation: 271
I think if you change the following, it should work:
Quote:
Originally Posted by Homerous
Code:
/dev/hdc7            /                    reiserfs   acl,user_xattr        1 1
/dev/hdc8            /home                reiserfs   acl,user_xattr        1 2
/dev/sda1            /windows/C           ntfs       ro,users,gid=users,umask=00
02,nls=utf8 0 0
/dev/hdc5            /windows/D           vfat       rw,users,gid=users,umask=0000,nls=utf8 0 0
/dev/sda5            /windows/E           ntfs       ro,users,gid=users,umask=00
02,nls=utf8 0 0
/dev/hdc6            swap                 swap       defaults              0 0
proc                 /proc                proc       defaults              0 0
sysfs                /sys                 sysfs      noauto                0 0
debugfs              /sys/kernel/debug    debugfs    noauto                0 0
usbfs                /proc/bus/usb        usbfs      noauto                0 0
devpts               /dev/pts             devpts     mode=0620,gid=5       0 0
/dev/fd0             /media/floppy        auto       noauto,user,sync      0 0
If you still have a problem, try using uid=yourusername instead of the gid option.

By the way, the umask for the NTFS partitions should be umask=0222 for read-only.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
moving files between windows partitions, in knoppix Antilocust Linux - Software 6 07-24-2005 06:48 AM
moving files from windows to linux...urgent samyakm Linux - Newbie 5 01-02-2005 03:56 AM
Moving and resizing partitions to install Windows IBBoard Linux - General 11 08-03-2004 10:50 AM
moving files between windows and linux endezeichen Linux - Software 4 11-19-2003 03:39 AM
Sharing files between Linux and Windows partitions Rudebr00d Linux - Newbie 3 07-08-2003 04:21 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 09:08 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration