Welcome to the most active Linux Forum on the web.
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 06-16-2007, 03:28 PM   #1
LQ Newbie
Registered: Sep 2006
Posts: 22

Rep: Reputation: 15
MouseWheel on KDE, Slack 11

I have an mx300 on ps2 port... i want the mouse wheel to work!!

Heres my input mice section...

Section "InputDevice"

# Identifier and driver
# On platforms where PnP mouse detection is supported the following
# protocol setting can be used when using a newer PnP mouse:
# Option "Protocol" "Auto"
# The available mouse protocols types that you can set below are:
# Auto BusMouse GlidePoint GlidePointPS/2 IntelliMouse IMPS/2
# Logitech Microsoft MMHitTab MMSeries Mouseman MouseManPlusPS/2
# MouseSystems NetMousePS/2 NetScrollPS/2 OSMouse PS/2 SysMouse
# ThinkingMouse ThinkingMousePS/2 Xqueue
# which is usually a symbolic link to the real device.
# Option "Device" "/dev/ttyS0"
# Option "Device" "/dev/ttyS1"
# When using XQUEUE, comment out the above two lines, and uncomment
# the following line.
# Option "Protocol" "Xqueue"
# Baudrate and SampleRate are only for some Logitech mice. In
# almost every case these lines should be omitted.
# Option "BaudRate" "9600"
# Option "SampleRate" "150"
# Emulate3Buttons is an option for 2-button Microsoft mice
# Emulate3Timeout is the timeout in milliseconds (default is 50ms)
# Option "Emulate3Buttons"
# Option "Emulate3Timeout" "50"
# ChordMiddle is an option for some 3-button Logitech mice
Option "MouseWheel"
Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "PS/2"
# The mouse device. The device is normally set to /dev/mouse,
Option "Device" "/dev/mouse"
# Option "Device" "/dev/psaux"

What should i change to make it owrk?

Old 06-16-2007, 03:31 PM   #2
Senior Member
Registered: Mar 2002
Location: Oklahoma
Posts: 1,154

Rep: Reputation: 184Reputation: 184
change Option "Protocol" "PS/2" to Option "Protocol" "ImPS/2"

and add a line:

Option "ZAxisMapping" "4 5 6 7"
Old 06-16-2007, 03:38 PM   #3
LQ Newbie
Registered: Sep 2006
Posts: 22

Original Poster
Rep: Reputation: 15
Originally Posted by Okie
change Option "Protocol" "PS/2" to Option "Protocol" "ImPS/2"

and add a line:

Option "ZAxisMapping" "4 5 6 7"
It did workd!! thanks very much



Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
KDE and mousewheel. Doesnt work properly kc0eks Linux - Hardware 1 04-03-2007 04:46 PM
mousewheel in x drigz Linux - Hardware 4 05-16-2004 05:42 AM
mousewheel change desktop in kde? tweakness Linux - Software 5 11-04-2003 07:26 PM
mousewheel MrPolite Linux - General 5 11-03-2002 03:52 PM
MouseWheel? MrPolite Linux - General 1 08-25-2002 11:34 PM > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 02:48 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration