LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-27-2003, 04:00 AM   #1
edu2
LQ Newbie
 
Registered: Sep 2003
Posts: 15

Rep: Reputation: 0
mouse wheel not working


I can't make the wheel on my mouse to work. It's a wireless optical logitech mouseman. Help please.
 
Old 09-27-2003, 04:10 AM   #2
J.W.
LQ Veteran
 
Registered: Mar 2003
Location: Boise, ID
Distribution: Mint
Posts: 6,642

Rep: Reputation: 85
Add this to your /etc/X11/XF86Config file, in the Mouse section:
Option "ZAxisMapping" "4 5"

-- J.W.
 
Old 09-27-2003, 04:22 AM   #3
ehdwuld
Member
 
Registered: Jul 2003
Distribution: Currently Suse 11.1 but have RH7,8,9 / Fedora 7,8_64,9_64,&10_64
Posts: 634

Rep: Reputation: 30
I use an Intellimouse from MS
set mine up with
menu>system settings>mouse

it wa a little freaked out when I first set it up
( cursor ran round the screen despite where the mouse was )
cntrl + alt + backspace
to log out
log back in
 
Old 09-27-2003, 02:52 PM   #4
edu2
LQ Newbie
 
Registered: Sep 2003
Posts: 15

Original Poster
Rep: Reputation: 0
Re: mouse wheel not working

Quote:
Originally posted by edu2
I can't make the wheel on my mouse to work. It's a wireless optical logitech mouseman. Help please.
I already did it, but still, the wheel doesn't work. I still can't scroll pages in the internet. I am using a Logitech cordless optical mouse.
 
Old 09-27-2003, 03:06 PM   #5
edu2
LQ Newbie
 
Registered: Sep 2003
Posts: 15

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by J.W.
Add this to your /etc/X11/XF86Config file, in the Mouse section:
Option "ZAxisMapping" "4 5"

-- J.W.
I already did it, but still, the wheel doesn't work at all.
 
Old 09-27-2003, 03:51 PM   #6
pfunk
Member
 
Registered: Jun 2002
Distribution: Suse, Redhat, Knoppix
Posts: 104

Rep: Reputation: 15
add this too

Change the protocol in the mouse section to "imps2" and then restart X windows.
 
Old 09-27-2003, 09:45 PM   #7
xlycer
LQ Newbie
 
Registered: Sep 2003
Posts: 8

Rep: Reputation: 0
I've made all those changes myself with a logitech mx500 (same as the wireless, but wired).

I've gone through every setting at least a dozen times

The strange thing, is that xev does not report a "button click" or any kind of event when scrolling the wheel up and down.

I've made another post about this, with no luck
 
Old 09-27-2003, 11:25 PM   #8
J.W.
LQ Veteran
 
Registered: Mar 2003
Location: Boise, ID
Distribution: Mint
Posts: 6,642

Rep: Reputation: 85
pfunk's advice is correct, and I should have included it in my original post. Good catch pfunk.

Regarding the scrolling issue: first, did you exit X and restart as pfunk indicated? If not, do it and see if that solves it. If you did restart and continue to have problems, then what distro are you using, and could you post the mouse section of your XF86Config file. -- J.W.
 
Old 09-28-2003, 05:11 PM   #9
edu2
LQ Newbie
 
Registered: Sep 2003
Posts: 15

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by J.W.
pfunk's advice is correct, and I should have included it in my original post. Good catch pfunk.

Regarding the scrolling issue: first, did you exit X and restart as pfunk indicated? If not, do it and see if that solves it. If you did restart and continue to have problems, then what distro are you using, and could you post the mouse section of your XF86Config file. -- J.W.
I already did what pfunk said. I already restarted the X server, but I still can't scroll.

Here is the mouse section in my XF86Config file:

# Pointer section
# **********************************************************************

Section "Pointer"
Protocol "IMPS/2"
Device "/dev/psaux"
ZAxisMapping 4 5

# For wheel support - can not be used with Emulate3Buttons
#
# ZAxisMapping 4 5

# When using XQUEUE, comment out the above two lines, and uncomment
# the following line.
# Protocol "Xqueue"

# Baudrate and SampleRate are only for some Logitech mice
# BaudRate 9600
# SampleRate 150

# Emulate3Buttons is an option for 2-button Microsoft mice
# Emulate3Timeout is the timeout in milliseconds (default is 50ms)
# Emulate3Buttons
Emulate3Timeout 50

# ChordMiddle is an option for some 3-button Logitech mice
# ChordMiddle

EndSection
 
Old 09-28-2003, 07:00 PM   #10
J.W.
LQ Veteran
 
Registered: Mar 2003
Location: Boise, ID
Distribution: Mint
Posts: 6,642

Rep: Reputation: 85
Get rid of the comment marks (the #'s). Here's what my XF86Config looks like (well, the mouse section anyway)

Section "InputDevice"

Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/mouse"
Option "ZAxisMapping" "4 5"

EndSection
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
PS2 wheel mouse/wheel not working jayhel Linux - Hardware 2 06-18-2006 07:54 PM
How do I get my mouse wheel working? Faceless42001 Slackware 2 08-16-2004 01:56 PM
mouse wheel not working curmudgeon42 Linux - General 3 08-13-2004 05:13 PM
mouse wheel not working oldi Slackware 7 04-19-2004 05:39 PM
how to get Mouse wheel working fwee Slackware 13 07-06-2003 03:09 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 10:23 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration