LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-09-2004, 08:27 AM   #1
subaruwrx
Member
 
Registered: Mar 2004
Distribution: Ubuntu Feisty
Posts: 641

Rep: Reputation: 30
Mouse not working in Slackware


Using a USB mouse. Everything in XF86Config is correct.

Could it be that when installing slackware, theres 1 thing call hotplug system, do I have to install that to get my usb mouse working?
 
Old 06-09-2004, 10:58 AM   #2
rose_bud4201
Member
 
Registered: Aug 2002
Location: St Louis, MO
Distribution: Xubuntu, RHEL, Solaris 10
Posts: 929

Rep: Reputation: 30
I don't think so; I've got a USB mouse on Slackware and never had a problem. Could you post the relevant section of your XF86Config file?
 
Old 06-10-2004, 02:21 PM   #3
subaruwrx
Member
 
Registered: Mar 2004
Distribution: Ubuntu Feisty
Posts: 641

Original Poster
Rep: Reputation: 30
Quote:
Originally posted by rose_bud4201
I don't think so; I've got a USB mouse on Slackware and never had a problem. Could you post the relevant section of your XF86Config file?
Got another problem. Seems like it cannot detect my floppy drive?

mount /dev/floppy /mnt/floppy

It say can't find /dev/floppy?
 
Old 06-10-2004, 04:52 PM   #4
rose_bud4201
Member
 
Registered: Aug 2002
Location: St Louis, MO
Distribution: Xubuntu, RHEL, Solaris 10
Posts: 929

Rep: Reputation: 30
For me at least, it's not /dev/floppy; it's /dev/fd0

My /etc/fstab:
.
.
.
/dev/fd0 /mnt/floppy auto noauto,user 0 0

hth,
Laura
 
Old 06-12-2004, 12:06 PM   #5
subaruwrx
Member
 
Registered: Mar 2004
Distribution: Ubuntu Feisty
Posts: 641

Original Poster
Rep: Reputation: 30
Heres my xf86config.


# **********************************************************************
# Core Pointer's InputDevice section
# **********************************************************************

Section "InputDevice"

# Identifier and driver

Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "Auto"
Option "Device" "/dev/mouse"

# Mouse-speed setting for PS/2 mouse.

# Option "Resolution" "256"

# When using XQUEUE, comment out the above two lines, and uncomment
# the following line.

# Option "Protocol" "Xqueue"

# Baudrate and SampleRate are only for some Logitech mice. In
# almost every case these lines should be omitted.

# Option "BaudRate" "9600"
# Option "SampleRate" "150"

# Emulate3Buttons is an option for 2-button Microsoft mice
# Emulate3Timeout is the timeout in milliseconds (default is 50ms)

# Option "Emulate3Buttons"
# Option "Emulate3Timeout" "50"

# ChordMiddle is an option for some 3-button Logitech mice

# Option "ChordMiddle"

EndSection
 
Old 06-12-2004, 12:37 PM   #6
Balkman
Member
 
Registered: Jan 2004
Location: USA, Pa
Distribution: Slackware 10
Posts: 65

Rep: Reputation: 15
when you configure your xf86config file, one of the first questions ask what protocol your mouse is. Instead of pressing "1" for auto try the usb choice, but i dont think this will solve your problem. I personally use a ps/2 mouse.
 
Old 06-12-2004, 12:52 PM   #7
subaruwrx
Member
 
Registered: Mar 2004
Distribution: Ubuntu Feisty
Posts: 641

Original Poster
Rep: Reputation: 30
I'm using a MS Wheelmouse Optical.

btw, I see through the list of /dev, can't find mouse.

Last edited by subaruwrx; 06-12-2004 at 01:57 PM.
 
Old 06-12-2004, 05:58 PM   #8
elyk
Member
 
Registered: Jun 2004
Distribution: Slackware
Posts: 198

Rep: Reputation: 32
Your mouse device might be in /dev/usb, maybe mouse0 or mouse1. Try this:

cat /dev/usb/mouse0

now move your mouse and see if it prints some characters to the screen. Use ^c to exit
If that's not the mouse, try changing the 0 to 1 or some other number.
 
Old 06-12-2004, 08:17 PM   #9
subaruwrx
Member
 
Registered: Mar 2004
Distribution: Ubuntu Feisty
Posts: 641

Original Poster
Rep: Reputation: 30
Quote:
Originally posted by elyk
Your mouse device might be in /dev/usb, maybe mouse0 or mouse1. Try this:

cat /dev/usb/mouse0

now move your mouse and see if it prints some characters to the screen. Use ^c to exit
If that's not the mouse, try changing the 0 to 1 or some other number.
How do I navigate to the console using keyboard?
 
Old 06-12-2004, 08:30 PM   #10
elyk
Member
 
Registered: Jun 2004
Distribution: Slackware
Posts: 198

Rep: Reputation: 32
I assume you're running KDE or gnome? Press alt+ctrl+F2 and it will bring up a terminal. Log in as root, then run this:

cat /dev/usb/mouse0

now move the mouse, click the buttons, and see if anything happens. If so, that's your mouse. If not, try another mouse device in /dev/usb.

Now, since you said you don't have /dev/mouse, run this:

ln -s /dev/usb/mouse0 /dev/mouse

That will make a link named /dev/mouse that points to /dev/usb/mouse0.

Now restart and see if it all works.
 
Old 06-12-2004, 11:33 PM   #11
subaruwrx
Member
 
Registered: Mar 2004
Distribution: Ubuntu Feisty
Posts: 641

Original Poster
Rep: Reputation: 30
Quote:
Originally posted by elyk
I assume you're running KDE or gnome? Press alt+ctrl+F2 and it will bring up a terminal. Log in as root, then run this:

cat /dev/usb/mouse0

now move the mouse, click the buttons, and see if anything happens. If so, that's your mouse. If not, try another mouse device in /dev/usb.

Now, since you said you don't have /dev/mouse, run this:

ln -s /dev/usb/mouse0 /dev/mouse

That will make a link named /dev/mouse that points to /dev/usb/mouse0.

Now restart and see if it all works.
Sorry I think I made a mistake. There is /dev/mouse.

Anyway, tried changing the device to /dev/usb/mouse0, /dev/usb/mouse1. Both didn't work.
 
Old 06-13-2004, 01:10 PM   #12
rose_bud4201
Member
 
Registered: Aug 2002
Location: St Louis, MO
Distribution: Xubuntu, RHEL, Solaris 10
Posts: 929

Rep: Reputation: 30
Well, on my system it's /dev/mouse, which is a symlink to /dev/input/mice. I'm not sure what the problem is, then :-/
 
Old 06-13-2004, 01:18 PM   #13
subaruwrx
Member
 
Registered: Mar 2004
Distribution: Ubuntu Feisty
Posts: 641

Original Poster
Rep: Reputation: 30
Quote:
Originally posted by rose_bud4201
Well, on my system it's /dev/mouse, which is a symlink to /dev/input/mice. I'm not sure what the problem is, then :-/
Maybe I will try reinstalling slackware again
 
Old 06-13-2004, 01:23 PM   #14
rose_bud4201
Member
 
Registered: Aug 2002
Location: St Louis, MO
Distribution: Xubuntu, RHEL, Solaris 10
Posts: 929

Rep: Reputation: 30
Have you tried setting the protocol to "IMPS/2" ?
 
Old 06-13-2004, 02:20 PM   #15
subaruwrx
Member
 
Registered: Mar 2004
Distribution: Ubuntu Feisty
Posts: 641

Original Poster
Rep: Reputation: 30
Quote:
Originally posted by rose_bud4201
Have you tried setting the protocol to "IMPS/2" ?
Yup.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Slackware - how to get mouse scroll wheel working xanas3712 Slackware 17 10-21-2007 05:04 PM
usb mouse is not working, slackware 10.2 amer_58 Linux - Newbie 7 11-07-2005 07:26 PM
Slackware 10.2 USB Mouse Configuration not working right. PastorFrederick Linux - Newbie 3 10-09-2005 08:31 PM
USB Optical Mouse and Slackware 9 - I cannot get it working GIJoe Linux - Newbie 0 10-13-2003 02:36 PM
Slackware - Got Mouse Working but how do you speed it up? alpinewonder Linux - Newbie 5 07-30-2003 02:11 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 10:00 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration