LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-29-2003, 08:30 PM   #1
heck
LQ Newbie
 
Registered: Jan 2003
Location: Canada
Posts: 19

Rep: Reputation: 0
Question mouse not working in rh8


Hi,

I just installed RH8 in vmware. Everything is working except my mouse.

I mave a ms intellimouse usb (but plugged via the ps2 adaptor).

I checked the XF86Config and changed the
Option "protocol" "Intellimouse" to Option "protocol" "PS/2"

That didn't work. The mouse cursor is always in the middle of the screen.

Any help would be appreciated!

Thanks
heck
 
Old 01-29-2003, 09:19 PM   #2
born4linux
Senior Member
 
Registered: Sep 2002
Location: Philippines
Distribution: Slackware, RHEL&variants, AIX, SuSE
Posts: 1,127

Rep: Reputation: 49
is your vmware device setup configured properly? run mouseconfig under RH or redhat-config-mouse

Last edited by born4linux; 01-29-2003 at 09:25 PM.
 
Old 01-29-2003, 11:26 PM   #3
heck
LQ Newbie
 
Registered: Jan 2003
Location: Canada
Posts: 19

Original Poster
Rep: Reputation: 0
I tried the mouse config. Nothing. Cursor is still in the middle of the screen.

This is what my XF86Config looks like:

Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZaxisMapping" "4 5"
Option "Emulate3Buttons" "no"

These are not the original settings...
 
Old 02-02-2003, 10:57 PM   #4
heck
LQ Newbie
 
Registered: Jan 2003
Location: Canada
Posts: 19

Original Poster
Rep: Reputation: 0
anyone have a idea about my problem please?

I'm a complete newbie. Are there some commands i can use to see if there is even a mouse detected?

My XF86Config settings are the same as above except for:

Option "Device" "/dev/input/mice"

that i changed to

Option "Device" "/dev/usbmouse"

Also, how can i access the "taskbar" using the keyboard?
There is a big red exclamation mark fashing and since the mouse doesn't work.. can't see what it is.

Thanks for any reply!
 
Old 03-19-2003, 06:48 PM   #5
SteveS
LQ Newbie
 
Registered: Mar 2003
Posts: 1

Rep: Reputation: 0
Hi,

I don't know if you had any joy with this, but I had been struggling with this on and off for a week. I'm running Win2k with a USB Logitech Cordless Trackman Wheel, RH8 under VMWare 3.2.0, and had exactly the same experience as you.

However, after searching Google and finding your email, I tried the mouseconfig programme suggested by born4linux. The first time it ran, it gave no options other than offering to update XF86Config. The second time I ran it, it displayed the full list of mouse options. I chose the Standard 3-button PS/2 mouse, saved it, allowed it to update XF86Config, and voila, I now have a working mouse under VMWare.

Have you tried this at all? Remember that VMWare maps the USB mouse to PS/2 in Linux.

Cheers,
SteveS.
 
Old 03-19-2003, 07:04 PM   #6
heck
LQ Newbie
 
Registered: Jan 2003
Location: Canada
Posts: 19

Original Poster
Rep: Reputation: 0
I got everything working properly now: mouse, internet, and screen.

Somewhere in the VMware help it says that you must select a specific type of mouse from the list in the rh8 setup (i think it's the default suggested mouse). Look in the help files for VMware... they are very complete, just hard to find the information bcuz there is so much of it. I ended up reinstalling RH8 to do this and the mouse then worked.

I have a ms optical mouse... it's usb but i using the ps/2 connector. Don't forget to also install the VMware tools. This is what gets everything working properly.

Hope that helps.

The only thing i couldn't do was share a folder between rh8 and win2k. I stopped trying .
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
RH8 mouse problems! cucolin@ Red Hat 2 04-19-2004 09:27 PM
ps/2 mouse in rh8 rooman Linux - Hardware 2 11-23-2003 03:23 PM
scrolling mouse RH8 pteren Linux - General 6 03-02-2003 02:40 AM
mouse prob RH8 Cass Linux - Distributions 2 02-15-2003 04:27 PM
RH8.0 USB Mouse not working rhubarb Linux - Newbie 1 01-31-2003 02:46 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 03:29 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration