-   Linux - Newbie (
-   -   mouse goes vertical; not horizontal (slack) (

nadroj 04-27-2005 10:40 PM

mx700 logitech mouse: not working properly
just put slack 10.1 on.. chose the same mouse as i did when i had (for the short time) slack 10, a usb mouse which worked.

i have a wireless usb logitech keyboard, and my mouse is a logitech mx700 wireless optical connected with the same usb port as the keyboard.

i tried running mouseconfig as root and when i choose usb mouse the mouse is recognized but only moves up and down, and acts weird, ie: right mouse jumps the cursor to far right of screen, the left side button of mouse (not 'left click') cliking will move the cursor to the far left of screen... the top mouse button (sorry, theres like 9 buttons on it) moves the cursor 1px to the left, etc etc.
i didnt find one that acted as a 'click' however.

how can i switch all the buttons around so that it moves properly X & Y? and get my left/right main buttons working appropriately?

i thought iv seen before that gpm was the mouse setup program for X (sorry i dont exactly know what im talking about :D) but i found out that it is just the program to allow for cut/paste in virtual consoles.

i havent ran xf86config, i believe its called.. would this be the appropriate thing to do, and is it pretty straight forward?


edit: bah! i cant wait... imma go try and break i mean fix it now

nadroj 04-27-2005 11:03 PM

ok, i couldnt even find the xf86config command.

any tips?

DeadPenguin 04-28-2005 12:32 AM

Here is the website that really helped me when i installed 10.0.Shilo is a Geek

Your are looking for the xf86config.

I think it is here: /etc/X11/XF86Config

if not use slocate or whereis to find it.

Read This

Good Luck.

For mouse Auto has always worked for me.

Good Luck. Slackware is a great distro. I learned a lot using it.


nadroj 04-28-2005 01:03 AM

ya i was checking out the xorg.conf file and changed what it was to Auto and restarted computer but it didnt seem to do anything.. hopefully the first link will work for 10.*1* also.
thanks, ill check those things out now

nadroj 04-28-2005 01:12 AM

i couldnt find much about the mouse on the first site, that was very helpful that i didnt know..
but the 2nd site, the very last line on the page, i believe it is, says that slackware [10?] doesnt use xf86free anymore? it uses so i need to run xorgconfig not xf86config.
ill go try that one, although i had previously edited the file manually and it didnt help.. and i would think this program is just an easier way of manually editing the file, oh well ill give it a shot

DeadPenguin 04-28-2005 07:09 AM

I'm still on 10.0.
I thought 10.1 was still using xfree.

freakyg 04-28-2005 12:56 PM


Originally posted by DeadPenguin
I'm still on 10.0.
I thought 10.1 was still using xfree.

xfree is included in the unsupported directory..........but
xorg is the default......

nadroj 04-28-2005 10:05 PM

ok, cant get my wireless USB Logitech mx700 to work properly. i have ran mouseconfig, xorgconfig, and manually edited the /etc/X11/xorg.conf file and set the mouse to Auto and usb, but its not working.

any help?

nadroj 04-28-2005 11:59 PM

ok heres my /etc/X11/xorg.conf input[mouse] section:

Section "InputDevice"
Option "CorePointer"
Option "Device" "/dev/mouse"
Option "Protocol" "ExplorerPS/2"
Option "Emulate3Buttons" "false"
Option "Buttons" "7"
Option "ZAxisMapping" "6 7"

and i have ran this command 'xmodmap -e ponter = 1 2 3 6 7 4 5' but get an error.. something like ' cannot open display for '' ' or something similar.. sorry i cant remmeber it right now, in M$.

i thought there was a .xmodmap file i was supposed to edit (iv been searching LQ for other threads regarding this problem) but couldnt find one.. maybe i was just mistaken and you dont edit that file, or create it.

the mouse is recognized.. but say, moving up mouse the curosr down, and vice versa... right clicking mouse cursor far left, etc etc... its all screwy.

anyone any suggestions?

pokemaster 04-29-2005 09:45 PM

Option "CorePointer"
Option "AlwaysCore"

also, you might want to change
Protocol "Explorer/PS2"
Protocol "imps/2"
I'm not sure that will help, but I've had better luck with imps/2 protocol than explorer mouse.

That said, I've had similar issues with my usb mouse in slack, and I got them fixed. (Unfortunately I can't remember how for the life of me).

You might want to try something like
ZAxisMapping "*insert two numbers here*"
and I think there's something similar in xorg for XAxis and YAxis. (X/Y are motion, Z is scrolling), and I'm sure there are options used to enable all your other copious buttons ;)

anyhow, good luck, hope something I said was at least a *little* help

nadroj 04-29-2005 11:33 PM

indeed was, poke. thank you.

about the protocol.. ya iv been going through afew, iv just seen more who had this problem using ExplorerPS2 to solve it, oh well ill try your way too; cant hurt.

the alwaysCore option i never heard of, ill change that.

the x,y axismapping options you mention i also didnt see in my searches.. although makes logical sense!

thats my main problem.. my mouse IS recognized.. but only mouse up/down.. and its odd, as i said earlier.. my right click moves the cursor left, etc etc..
maybe i can add that xaxismapping and that might help for the X-coordinate problem.. still none of the clickys will work though :confused:

thanks though, ill try it.

ramke 05-05-2005 08:18 AM

I had that problem too
i have to type

modprobe -r usbmouse
modprobe hid

every time i reboot my system.


Section "InputDevice"
Option "CorePointer"
Option "Device" "/dev/mouse"
Option "Protocol" "ExplorerPS/2"
Option "Emulate3Buttons" "false"
Option "Buttons" "7"
Option "ZAxisMapping" "6 7"

just won't work for me,

pokemaster 05-05-2005 11:02 AM

Quick little question... is the mouse you're having trouble with the only mouse on your system?

i.e. I work on a laptop, when my mouse did those things it was my usb mouse goin screwy, but my touchpad still worked beautifully. Turned out all I had to do was to create a second mouse section in my xorg.conf file to accomodate the usb mouse. Here's my xorg.conf stuff, maybe it'll help:


Section "ServerLayout"
        Identifier    "Default Layout"
        Screen      0  "Screen0" 0 0
        ### here's the server declaration of my two mice,
        ### note that only one mouse can be "CorePointer",
        ### the rest must be "AlwaysCore"
        InputDevice    "Mouse0" "CorePointer"
        InputDevice    "Mouse1" "AlwaysCore"
        InputDevice    "Keyboard0" "CoreKeyboard"

Section "Files"
        RgbPath      "/usr/X11R6/lib/X11/rgb"
        FontPath    "unix/:7100"

Section "Module"
. unimportant...

Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "kbd"
        Option      "XkbModel" "pc105"
        Option      "XkbLayout" "us"

Section "InputDevice"        ### This is my touchpad, and has lots of touchpad-specific options (ones with ***)
        Identifier  "Mouse0"
        ***Driver      "synaptics"
        ***Option      "Protocol" "auto-dev"
        Option      "Device" "/dev/input/mice"
        Option      "ZAxisMapping" "4 5"
        ***Option      "SHMConfig" "yes"
        ***Option      "MaxSpeed" "1"
        ***Option      "AccelFactor" "1"
        Option      "Emulate3Buttons" "yes"

Section "Input Device"        ### This is my usb mouse section, note I don't have the "AlwaysCore" in here,
        Identifier  "Mouse1"  ### Because that's in the ServerLayout section.
        Driver      "mouse"
        Option      "Protocol" "imps/2"
        Option      "Device" "/dev/mice"
        Option      "ZAxisMapping" "4 5"

Section "Monitor"
. unimportant....

Section "Device"
. vid card....

Section "Screen"
. also unimportant...

Section "DRI"        ### lol, no idea what this is, but probably something for my vid display...
        Group        0
        Mode        0666

As always, hope that helps...

[edit] something I noticed just after I posted... try changing /dev/mouse to /dev/mice, b/c /dev/mice seems to work better with usb mice for some reason...:Pengy: [/edit]

nadroj 05-05-2005 04:40 PM

alright.. thanks alot poke, appreciated.

what mouse do you have/how many buttons on it? (the usb one)

yes.. i only have one mouse (logitech mx700 optical wireless usb) on my desktop.
the reply before this one that i made, referring to your response, i did try and it didnt seem to solve it.

i tried the both (one or the other) corepointer/alwayscore options with no success it seems.

for the protocol, isnt there just one for 'usb' or something? i dont understand why i should set it to *ps/2.. oh well, it seems thats what everyone uses anyway.

also.. 2 nights ago i deleted the slack partition, cause i was gonna try gentoo.. and that is a nitemare! i didnt even get to install it cause i was lost after booting to the install cd! but i also downloaded and burned knoppix live cd... i checked the xorg.conf file there and under device it said '/dev/input/mice' i believe.. i can double check... but if this is the case, should editing the default line that it had for me in my slackware install's xorg.conf (id be happy to reinstall it if it might work) to the one that it shows for the knoppix system?

the mouse still works and is recognized with how it was layed out in the xorg file for my slack install, just not working properly... would changing that /dev/... line really matter?

thanks again.

and ya, is helpful.

pokemaster 05-05-2005 05:05 PM

Yea, the /dev line is gonna be different depending on the system. Often, /dev/mouse is a symlink for the psaux (ps2 mouse) and /dev/mice links to the usb. Try reinstalling slack, and put your knoppix xorg mouse options in the place of the slack ones -- it should fix your problems!

All times are GMT -5. The time now is 11:05 PM.