-   Linux - Newbie (
-   -   Mouse goes haywire in RH on Thinkpad T21 (

rhubarb 01-31-2003 04:52 AM

Mouse goes haywire in RH on Thinkpad T21
This week I made my first Linux installation.
It's redhat 8.0 (Psyche) running on an IBM Thinkpad T21 dual booting (grub) with Windows XP.
(A default Workstation installation without kernel source and running the default Gnome windows manager)

My first problem was getting the mouse working at all. Neither the MS Intelli Mouse nor the trackpoint were working at all. I was forced to use the keyboard navigation to switch on the mousekey accessibility feature until I resolved this.
The solution was to switch the trackpoint from automatic to enabled in the BIOS.
With this I could use the trackpoint, but the external mouse only worked through the PS2 port, not through USB, and the wheelie button doesnít work at all.

I have tried all the appropriate settings in the GUI mouse dialog settings. With no luck.
But I haven't yet looked at this config file that others have mentioned, where is it?

Simultaneously I am trying to install a pptp client. Following instructions I found on the web, I need first to install an mppe compatible kernel. I found an i386 mppe kernel as a binary RPM and installed it and rebooted.

Now Grub shows me XP, my original Linux, and now a new Linux version for the new kernel.
I guess this is so I can recover if the new kernel doesnít work right?

Here's the big problem:
As soon as I log in, my mouse goes crazy. I have some control over it with either the PS2 mouse or the track point, but I can only move it a short distance before it springs back to the bottom left of the screen. And it seems to be left clicking constantly and randomly.

The first time this happened I had 2 terminal windows that were saved from the last time I shutdown and I managed to click in one and type reboot. (Keyboard works fine and the mouse doesnít cause problems if I'm not touching it).
The second time I couldn't even do this and had to power off the machine.

I don't know if it is my fiddling with the mouse settings, or the new kernel causing the problem. The thing is the mouse settings didnít change anything and the problem only started with the first reboot after the kernel install.

I tried booting into the previous version of the kernel from grub, but I get the same problem.

Mouse and trackpoint are working fine under XP though.

someone help a newbie out?

Zeratool Box 08-01-2003 01:39 AM

I had the same problem with my imb a20m. It was an easy fix for me. I edited /etc/X11/XF86Config-4 file and in the mouse section I changed the protocol from IMPS/2 to auto. That did the fix for me, hope you have good luck with it too.

All times are GMT -5. The time now is 12:18 AM.