-   Linux - Newbie (
-   -   Mouse Config (

jd300 12-28-2001 10:13 PM

Mouse Config
Why is it that things that worked in Mandrake do not work here in RedHat. My wheel on my mouse does not scroll here in RH 7.2. I have tried /usr/sbin/mouseconfig but the effects do not happen. Is there another solution?

salman 12-29-2001 05:31 AM

Hello there,

In Red Hat 7.2, you have to edit the "InputDevice" section of your /etc/X11/XF86Config-4 file as given below :

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/psaux"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no

Afterwards restart X and then wheel mouse will work for all applications except Netscape. And then to see how to fix Netscape problems, check out this page :

Best regards,

jd300 01-02-2002 08:37 PM

Are these commands or should I type something else in order to see these items?

taz.devil 01-02-2002 09:56 PM

These are settings you'll have to add and/or edit IN your /etc/X11/XF86Config-4 file. There is an input.txt file that will also help with what is being talked about. It is in the kernel source directory.

/usr/src/linux-2.4.7-10/Documentation/usb/input.txt or

It's a very helpful file...I can't remember if 2.4.7-10 is the exact kernel dir, but you get the jist.

ryanstrayer 01-29-2002 01:44 AM

Anyone know why when I do this - it makes my mouse in X goes nuts? I have a Microsoft Intellimouse with wheel (not 5 button).

Aussie 01-29-2002 03:37 AM

imwheel can make mice go nuts on new distro' can gpm.

ryanstrayer 01-30-2002 12:23 PM

There has got to be a way to make this work - with a third party program or something.

All times are GMT -5. The time now is 12:18 PM.