LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-08-2002, 09:24 PM   #1
Kompressor
LQ Newbie
 
Registered: Jun 2002
Location: mass
Posts: 14

Rep: Reputation: 0
Question Mounting with suSE 8 HELP Tried Everything


I have just installed suse linux 8 and have spent the last 5 hours trying to mount the cdrom drive. I have read other posts and have tryed many of their script solutions, but they don't seem to work. I know my drive is labled as hdb, but i m a little confused about what to write in the fstab file. COuld someone maybe post what they have in their folder so they can have tehir cd-rom drive mounted, and tell me what to do so that it atomaticly mounts for every user. I am very interested in switching to linux, but this little thing is making me a little uneay about it.

P.S i have tried to edit that fstab file before, but i guess i screwed up and i for some reason made kde not run, so i had to reinstall it. Because of this i am weary of trying knew things with the fstab file, but if anyone can give good details, i would be willing to try them out.
 
Old 06-08-2002, 10:42 PM   #2
rshaw
Senior Member
 
Registered: Apr 2001
Location: Perry, Iowa
Distribution: Mepis , Debian
Posts: 2,692

Rep: Reputation: 45
you shouldn't have to alter the fstab, or anything else for the matter, have you tried clicking on the cdrom icon that's on the desktop? it should mount the drive and display the contents automagically.
 
Old 06-08-2002, 10:52 PM   #3
Kompressor
LQ Newbie
 
Registered: Jun 2002
Location: mass
Posts: 14

Original Poster
Rep: Reputation: 0
Error Message

When i right click mount i get the following error message:

Could not mount device.
The reported error was:
/dev/cdrom: Input/output error
mount: you must specify the filesystem type

i assume you must enter iso9660 to specify the filesystem type, but i have no idea where
 
Old 06-08-2002, 11:05 PM   #4
rshaw
Senior Member
 
Registered: Apr 2001
Location: Perry, Iowa
Distribution: Mepis , Debian
Posts: 2,692

Rep: Reputation: 45
ok,here's what my fstab looks like

/dev/hda7 / reiserfs defaults 1 2
/dev/hda5 /boot ext2 defaults 1 2
/dev/cdrom /media/cdrom auto ro,noauto,user,exec 0 0
devpts /dev/pts devpts defaults 0 0
/dev/fd0 /media/floppy auto noauto,user,sync 0 0
proc /proc proc defaults 0 0
usbdevfs /proc/bus/usb usbdevfs noauto 0 0
/dev/hdb1 /media/zip auto noauto,user 0 0
/dev/hda6 swap swap pri=42 0 0


this isn't an audio cd your trying to mount is it?

Last edited by rshaw; 06-08-2002 at 11:11 PM.
 
Old 06-08-2002, 11:15 PM   #5
Kompressor
LQ Newbie
 
Registered: Jun 2002
Location: mass
Posts: 14

Original Poster
Rep: Reputation: 0
DATA CD

I am trying to mount a data cd and my fstab file looks just like yours, are you running suse 8. i still get the same problems when i try to click mount
 
Old 06-08-2002, 11:33 PM   #6
rshaw
Senior Member
 
Registered: Apr 2001
Location: Perry, Iowa
Distribution: Mepis , Debian
Posts: 2,692

Rep: Reputation: 45
is this a combination cd and dvd drive?
 
Old 06-08-2002, 11:38 PM   #7
Kompressor
LQ Newbie
 
Registered: Jun 2002
Location: mass
Posts: 14

Original Poster
Rep: Reputation: 0
No

No its a cyberdrive 36x burner
 
Old 06-08-2002, 11:42 PM   #8
rshaw
Senior Member
 
Registered: Apr 2001
Location: Perry, Iowa
Distribution: Mepis , Debian
Posts: 2,692

Rep: Reputation: 45
at the root prompt type:ln -sf /dev/sr0 /dev/cdrom then try to mount again.
 
Old 06-08-2002, 11:44 PM   #9
Kompressor
LQ Newbie
 
Registered: Jun 2002
Location: mass
Posts: 14

Original Poster
Rep: Reputation: 0
i can mount and unmount my windows drive

i have a feeling that because it is a cd burner, it might be scsi inside, and so linux might detect that and so i might have to change some settings.

I'm have reinstalled a couple of times and this keeps popping up, so i assume everyone that installs suSE 8 has to go through this.
 
Old 06-08-2002, 11:47 PM   #10
Kompressor
LQ Newbie
 
Registered: Jun 2002
Location: mass
Posts: 14

Original Poster
Rep: Reputation: 0
thanx that totally worked you are soo cool
i love you!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Mounting in Suse eval 9.2 caa1980 SUSE / openSUSE 3 08-31-2005 04:55 AM
Mounting NTSF in SuSE? zenith_zth Linux - General 1 01-15-2005 04:02 PM
Mounting iPod on SuSE 9.1 melao Linux - Software 1 11-14-2004 05:51 AM
SuSE 9.1 mounting problems hamstar SUSE / openSUSE 13 10-26-2004 03:57 AM
Mounting NTFS in SuSE 8.0 Fred Affe Linux - Newbie 11 08-15-2003 01:59 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 02:22 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration