LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Mounting Windows Partition (https://www.linuxquestions.org/questions/linux-newbie-8/mounting-windows-partition-87365/)

johnny_575 08-30-2003 12:39 PM

Mounting Windows Partition
 
I am trying to mount my Windows (ntfs) partition 'hda1'. I'm learning as I go here and was able to create a mount point '/mnt/hda1' and then I tried to mount it by typing 'mount -t ntfs dev/hda1/ mnt/hda1'. I thought I had it figured out but I got this message 'fs is not supported by kernel'. I'm using Red Hat 9 and the kernel version is 2.4 20-6. What should I do?

I just want to be able to read from this parition, I know I can't write to it. I wanted to copy some True Type fonts from my windows partion over to Linux for starters. Any help would be great. Thanks!

koyi 08-30-2003 12:50 PM

I think there is a rpm package that you can install to enable your Redhat to read from ntfs partition. Try to search from this forum for ntfs and you would probably find many of tips. This is all I can tell as I myself haven't tried to do it before but I have read several threads on this topic before in this forum. Hope you can find what you want. :)

peace 08-30-2003 12:52 PM

Red Hat 9 does not come with NTFS support by default. Search google or look here for getting NTFS read support for RH:

http://linux-ntfs.sourceforge.net/info/redhat.html

If you searched LQ before you posted you would have found this out. Do so next time please.

Electro 08-30-2003 05:30 PM

NTFS is experimental when writing so mount NTFS partitons as read-only. For example

mount -t ntfs -o ro dev/hda1/ mnt/hda1

You can check what filesystems your kernel supports by typing cat /proc/filesystems

johnny_575 08-30-2003 06:36 PM

Got it. Thanks everybody.


All times are GMT -5. The time now is 02:44 PM.